summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2003-10-08 06:54:53 +0000
committerLisa M. Seelye <lisa@gentoo.org>2003-10-08 06:54:53 +0000
commit9e2419d1ee688e2d1b802081e45a87c20e3ca682 (patch)
tree5e5b13fa830c4b20556fced3ae761fb571045551 /sys-devel
parentversion bump. gtk non using gnome users should be happy! (diff)
downloadgentoo-2-9e2419d1ee688e2d1b802081e45a87c20e3ca682.tar.gz
gentoo-2-9e2419d1ee688e2d1b802081e45a87c20e3ca682.tar.bz2
gentoo-2-9e2419d1ee688e2d1b802081e45a87c20e3ca682.zip
version bump. gtk non using gnome users should be happy!
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/distcc/ChangeLog7
-rw-r--r--sys-devel/distcc/Manifest4
-rw-r--r--sys-devel/distcc/distcc-2.11.1.ebuild125
-rw-r--r--sys-devel/distcc/files/digest-distcc-2.11.11
4 files changed, 134 insertions, 3 deletions
diff --git a/sys-devel/distcc/ChangeLog b/sys-devel/distcc/ChangeLog
index bd92973f5596..8d03edfee757 100644
--- a/sys-devel/distcc/ChangeLog
+++ b/sys-devel/distcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/distcc
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.76 2003/09/24 23:10:28 lisa Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.77 2003/10/08 06:54:48 lisa Exp $
+
+*distcc-2.11.1 (08 Oct 2003)
+
+ 08 Oct 2003; Lisa Seelye <lisa@gentoo.org> distcc-2.11.1.ebuild:
+ version bump. gtk non using gnome users should be happy!
*distcc-2.11-r2 (24 Sep 2003)
diff --git a/sys-devel/distcc/Manifest b/sys-devel/distcc/Manifest
index e8049a6e403d..dd08afe98f6a 100644
--- a/sys-devel/distcc/Manifest
+++ b/sys-devel/distcc/Manifest
@@ -1,4 +1,4 @@
-MD5 92b1f9206b5f5b90d0dd312385af5b8d ChangeLog 13237
+MD5 1485715d250d577863963f36cfd3b69e ChangeLog 13395
MD5 58d1c3a6aa178de53f9e352990c8ff23 distcc-2.10-r3.ebuild 3380
MD5 2feb5ef608b6a01791939a04b33548a3 distcc-2.11-r1.ebuild 3549
MD5 e4e4e2dca5c232ba88219df0097f734b distcc-2.11-r2.ebuild 3551
@@ -6,7 +6,7 @@ MD5 3f24933f751d9ba7a6c90c2751a3e083 distcc-2.5-r1.ebuild 3208
MD5 c68dd76338384f0a996204db7364f8f7 distcc-2.8-r2.ebuild 3357
MD5 f7332ba9718f262c2f3efb2f7f8945c7 distcc-2.9.ebuild 3445
MD5 70619e7eb5fa4fd0aa4f3588579cd50d metadata.xml 443
-MD5 fb8376be7a067064055d9b72627a5507 distcc-2.11.1.ebuild 3770
+MD5 967c3d0113029203557f2ab5a2a65d92 distcc-2.11.1.ebuild 3923
MD5 996b45704fdf266745dfc2e6038a1f76 files/digest-distcc-2.10-r3 64
MD5 8d8b631e78e00fe0e948b53145e0e47a files/digest-distcc-2.11-r1 64
MD5 8d8b631e78e00fe0e948b53145e0e47a files/digest-distcc-2.11-r2 64
diff --git a/sys-devel/distcc/distcc-2.11.1.ebuild b/sys-devel/distcc/distcc-2.11.1.ebuild
new file mode 100644
index 000000000000..29fb8b2699dd
--- /dev/null
+++ b/sys-devel/distcc/distcc-2.11.1.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-2.11.1.ebuild,v 1.1 2003/10/08 06:54:48 lisa Exp $
+
+inherit eutils gcc flag-o-matic
+[ `gcc-major-version` -eq 2 ] && filter-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+
+PATCHLEVEL="2.11"
+
+HOMEPAGE="http://distcc.samba.org/"
+SRC_URI="http://distcc.samba.org/ftp/distcc/distcc-${PV}.tar.bz2"
+DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm"
+IUSE="gnome gtk"
+
+DEPEND=">=sys-apps/portage-2.0.49-r6
+ >=sys-devel/gcc-config-1.3.1
+ sys-apps/shadow"
+
+RDEPEND="gnome? ( >=x11-libs/gtk+-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.0.0.0
+ >=gnome-base/libglade-2.0.0
+ x11-libs/pango
+ )
+ gtk? (
+ >=x11-libs/gtk+-2.0.0
+ >=gnome-base/libglade-2.0.0
+ x11-libs/pango
+ )
+ selinux? ( sec-policy/selinux-distcc )"
+
+src_compile() {
+ local myconf="--with-included-popt "
+ #Here we use the built in parse-options package. saves a dependancy
+
+ #not taking any chances here, guessing which takes precedence in the
+ #configure script, so we'll just make the distinction here:
+ #gnome takes precedence over gtk if both are specified (gnome pulls
+ #in gtk anyways...)
+ use gtk && ! use gnome && myconf="${myconf} --with-gtk"
+ use gtk && use gnome && myconf="${myconf} --with-gnome"
+
+ econf ${myconf} || die "econf ${myconf} failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D%/}" install
+
+ insinto /usr/share/doc/${PN}
+ doins "${S}/survey.txt"
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/${PATCHLEVEL}/distcc-config"
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/${PATCHLEVEL}/conf" distccd
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/${PATCHLEVEL}/init" distccd
+
+ # create and keep the symlink dir
+ dodir /usr/lib/distcc/bin
+ keepdir /usr/lib/distcc/bin
+
+ # create the distccd pid directory
+ dodir /var/run/distccd
+ keepdir /var/run/distccd
+}
+
+pkg_preinst() {
+ # non-/ installs don't require us to do anything here
+ [ "${ROOT}" != "/" ] && return 0
+
+ # stop daemon since script is being updated
+ [ -n "$(pidof distccd)" -a -x /etc/init.d/distccd ] && \
+ /etc/init.d/distccd stop
+
+ # moved user creation and permissions to distcc-config script
+ # because of ROOT install requirements
+}
+
+pkg_postinst() {
+ # handle DISTCC_HOSTS upgrade better
+ local ENVFILE
+ ENVFILE="${ROOT}etc/env.d/02distcc"
+ [ ! -f "${ENVFILE}" ] && \
+ ENVFILE="${ROOT}etc/env.d/04distcc"
+ if [ -f "${ENVFILE}" ]
+ then
+ # save hosts to new file
+ ROOT="${ROOT}" ${ROOT}usr/bin/distcc-config --set-hosts \
+ $(egrep '^DISTCC_HOSTS' "${ENVFILE}" | sed 's,[^=]*=,,')
+ # now remove from the file
+ grep -v 'DISTCC_HOSTS' "${ENVFILE}" > "${ENVFILE}.new"
+ mv "${ENVFILE}.new" "${ENVFILE}"
+ fi
+
+ if [ "${ROOT}" = "/" ]; then
+ einfo "Installing links to native compilers..."
+ /usr/bin/distcc-config --install-user
+ /usr/bin/distcc-config --install-links
+ /usr/bin/distcc-config --install-links "${CHOST}"
+ /usr/bin/distcc-config --set-env DISTCC_DIR ""
+ else
+ # distcc-config can *almost* handle ROOT installs itself
+ # but for now, but user must finsh things off
+ ewarn "*** Installation is not complete ***"
+ ewarn "You must run the following as root:"
+ ewarn " /usr/bin/distcc-config --install"
+ ewarn "after booting or chrooting into ${ROOT}"
+ fi
+ einfo "Tips on using distcc with Gentoo can be found at"
+ einfo "http://www.gentoo.org/doc/en/distcc.xml"
+ ewarn "As of distcc-2.11, the only thing you have to do to configure distcc"
+ ewarn "is to set your hosts (see the Guide, above) and to add distcc to"
+ ewarn "the FEATURES line in /etc/make.conf"
+ echo ""
+ einfo "To use the distccmon programs with Gentoo you should use this command:"
+ einfo " DISTCC_DIR=/var/tmp/portage/.distcc distccmon-text N"
+}
diff --git a/sys-devel/distcc/files/digest-distcc-2.11.1 b/sys-devel/distcc/files/digest-distcc-2.11.1
new file mode 100644
index 000000000000..078e2ae837ea
--- /dev/null
+++ b/sys-devel/distcc/files/digest-distcc-2.11.1
@@ -0,0 +1 @@
+MD5 7b096504d7ef4805d30b0638224c7f46 distcc-2.11.1.tar.bz2 251577