summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-08-01 20:16:19 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-08-01 20:16:19 +0000
commita1d59ee0644d3c5b9ed49d397be9e8d297b70008 (patch)
tree4614cb2184e44064b743c8ff247d3d2ff6d75764 /sys-devel
parentre-added 2.4 (diff)
downloadgentoo-2-a1d59ee0644d3c5b9ed49d397be9e8d297b70008.tar.gz
gentoo-2-a1d59ee0644d3c5b9ed49d397be9e8d297b70008.tar.bz2
gentoo-2-a1d59ee0644d3c5b9ed49d397be9e8d297b70008.zip
temporary fix for ppc and sparc
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/binutils-2.11.90.0.27.ebuild82
-rw-r--r--sys-devel/binutils/binutils-2.11.90.0.31.ebuild113
-rw-r--r--sys-devel/binutils/binutils-2.11.90.0.7-r1.ebuild86
-rw-r--r--sys-devel/binutils/binutils-2.12.90.0.14.ebuild149
-rw-r--r--sys-devel/binutils/binutils-2.12.90.0.7.ebuild23
-rw-r--r--sys-devel/binutils/binutils-2.12.90.0.9.ebuild137
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.11.90.0.271
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.11.90.0.312
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.11.90.0.7-r12
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.12.90.0.141
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.12.90.0.91
11 files changed, 16 insertions, 581 deletions
diff --git a/sys-devel/binutils/binutils-2.11.90.0.27.ebuild b/sys-devel/binutils/binutils-2.11.90.0.27.ebuild
deleted file mode 100644
index ff86bdc7e97d..000000000000
--- a/sys-devel/binutils/binutils-2.11.90.0.27.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.11.90.0.27.ebuild,v 1.9 2002/08/01 11:40:16 seemant Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Tools necessary to build programs"
-SRC_URI="http://ftp.kernel.org/pub/linux/devel/binutils/${P}.tar.bz2"
-LICENSE="GPL-2 LGPL-2 BINUTILS"
-SLOT="0"
-KEYWORDS="x86"
-HOMEPAGE="http://sources.redhat.com/binutils/"
-
-DEPEND="virtual/glibc"
-
-src_compile() {
- local myconf
- if [ -z "`use nls`" ]
- then
- myconf="--disable-nls"
- fi
- ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} ${myconf} || die
- if [ "`use static`" ]
- then
- emake -e LDFLAGS=-all-static || die
- else
- emake || die
- fi
-}
-
-src_install() {
- make prefix=${D}/usr mandir=${D}/usr/share/man install || die
- #c++filt is included with gcc -- what are these GNU people thinking?
- rm ${D}/usr/bin/c++filt ${D}/usr/share/man/man1/c++filt*
-
- #strip has a symlink going from /usr/${CHOST}/bin/strip to /usr/bin/strip; we should reverse
- #it:
-
- rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
- #the strip symlink gets created in the loop below
-
- #ar, as, ld, nm, ranlib and strip are in two places; create symlinks. This will reduce the
- #size of the tbz2 significantly. We also move all the stuff in /usr/bin to /usr/${CHOST}/bin
- #and create the appropriate symlinks. Things are cleaner that way.
- cd ${D}/usr/bin
- local x
- for x in * strip
- do
- if [ ! -e ../${CHOST}/bin/${x} ]
- then
- mv $x ../${CHOST}/bin/${x}
- else
- rm -f $x
- fi
- ln -s ../${CHOST}/bin/${x} ${x}
- done
- cd ${S}
- if [ -z "`use build`" ]
- then
- dodoc COPYING* README
- docinto bfd
- dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
- docinto binutils
- dodoc binutils/ChangeLog binutils/NEWS binutils/README
- docinto gas
- dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING \
- gas/NEWS gas/README*
- docinto gprof
- dodoc gprof/ChangeLog* gprof/NOTES gprof/TEST gprof/TODO
- docinto ld
- dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
- docinto libiberty
- dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
- docinto opcodes
- dodoc opcodes/ChangeLog*
- else
- rm -rf ${D}/usr/share/man
- fi
-
-}
-
-
-
diff --git a/sys-devel/binutils/binutils-2.11.90.0.31.ebuild b/sys-devel/binutils/binutils-2.11.90.0.31.ebuild
deleted file mode 100644
index a469900e9d8a..000000000000
--- a/sys-devel/binutils/binutils-2.11.90.0.31.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.11.90.0.31.ebuild,v 1.6 2002/07/11 06:30:56 drobbins Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="GNU development tools - necessary to build programs"
-SRC_URI="http://ftp.kernel.org/pub/linux/devel/binutils/${P}.tar.gz http://www.ibiblio.org/${PN}-manpages-${PV}.tar.bz2"
-LICENSE="GPL-2 LGPL-2 BINUTILS"
-SLOT="0"
-KEYWORDS="x86"
-HOMEPAGE="http://sources.redhat.com/binutils/"
-
-DEPEND="virtual/glibc"
-
-src_unpack() {
- unpack ${P}.tar.gz
-
- cd ${S}
- #man pages are tarred up seperately because building them depends on perl, which isn't installed at
- #Gentoo Linux bootstrap time.
- mkdir man; cd man
- tar xjf ${DISTDIR}/${PN}-manpages-${PV}.tar.bz2 || die
-}
-
-src_compile() {
- ./configure --enable-shared \
- --enable-64-bit-bfd \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --host=${CHOST} \
- --without-included-gettext || die
-
- if [ "`use static`" ]
- then
- emake -e LDFLAGS=-all-static || die
- else
- emake || die
- fi
-
- if [ -z "`use build`" ]
- then
- #make the info pages (makeinfo included with gcc is used)
- make info || die
- fi
-}
-
-src_install() {
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- install || die
-
- #c++filt is included with gcc -- what are these GNU people thinking?
- #but not the manpage, so leave that!
- rm -f ${D}/usr/bin/c++filt #${D}/usr/share/man/man1/c++filt*
-
- #strip has a symlink going from /usr/${CHOST}/bin/strip to /usr/bin/strip
- #we should reverse it:
-
- rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
- #the strip symlink gets created in the loop below
-
- #ar, as, ld, nm, ranlib and strip are in two places; create symlinks. This will reduce the
- #size of the tbz2 significantly. We also move all the stuff in /usr/bin to /usr/${CHOST}/bin
- #and create the appropriate symlinks. Things are cleaner that way.
- cd ${D}/usr/bin
- local x
- for x in * strip
- do
- if [ ! -e ../${CHOST}/bin/${x} ]
- then
- mv $x ../${CHOST}/bin/${x}
- else
- rm -f $x
- fi
- ln -s ../${CHOST}/bin/${x} ${x}
- done
-
- cd ${S}
- if [ -z "`use build`" ]
- then
- #install info pages
- make infodir=${D}/usr/share/info \
- install-info || die
-
- dodoc COPYING* README
- docinto bfd
- dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
- docinto binutils
- dodoc binutils/ChangeLog binutils/NEWS binutils/README
- docinto gas
- dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
- docinto gprof
- dodoc gprof/ChangeLog* gprof/TEST gprof/TODO
- docinto ld
- dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
- docinto libiberty
- dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
- docinto opcodes
- dodoc opcodes/ChangeLog*
- #install new updated manpages
- rm -f ${D}/usr/share/man/man1/*
- doman ${S}/man/*.1
- #next two is missing from the new manpages
- doman ${S}/ld/ld.1
- doman ${S}/gas/doc/as.1
- else
- rm -rf ${D}/usr/share/man
- fi
-}
-
-
-
diff --git a/sys-devel/binutils/binutils-2.11.90.0.7-r1.ebuild b/sys-devel/binutils/binutils-2.11.90.0.7-r1.ebuild
deleted file mode 100644
index b92fccaad9a2..000000000000
--- a/sys-devel/binutils/binutils-2.11.90.0.7-r1.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.11.90.0.7-r1.ebuild,v 1.6 2002/08/01 11:40:16 seemant Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Tools necessary to build programs"
-SRC_URI="http://ftp.kernel.org/pub/linux/devel/binutils/${P}.tar.gz http://www.ibiblio.org/${PN}-manpages-${PV}.tar.bz2"
-LICENSE="GPL-2 LGPL-2 BINUTILS"
-SLOT="0"
-KEYWORDS="x86"
-HOMEPAGE="http://sources.redhat.com/binutils/"
-
-DEPEND="virtual/glibc"
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd ${S}
- #man pages are tarred up seperately because building them depends on perl, which isn't installed at
- #Gentoo Linux bootstrap time.
- mkdir man; cd man
- tar xjf ${DISTDIR}/${PN}-manpages-${PV}.tar.bz2
-}
-
-src_compile() {
- ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} --without-included-gettext || die
- if [ "`use static`" ]
- then
- emake -e LDFLAGS=-all-static || die
- else
- emake || die
- fi
-}
-
-src_install() {
- make prefix=${D}/usr mandir=${D}/usr/share/man install || die
- #c++filt is included with gcc -- what are these GNU people thinking?
- rm ${D}/usr/bin/c++filt ${D}/usr/share/man/man1/c++filt*
-
- #strip has a symlink going from /usr/${CHOST}/bin/strip to /usr/bin/strip; we should reverse
- #it:
-
- rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
- #the strip symlink gets created in the loop below
-
- #ar, as, ld, nm, ranlib and strip are in two places; create symlinks. This will reduce the
- #size of the tbz2 significantly. We also move all the stuff in /usr/bin to /usr/${CHOST}/bin
- #and create the appropriate symlinks. Things are cleaner that way.
- cd ${D}/usr/bin
- local x
- for x in * strip
- do
- if [ ! -e ../${CHOST}/bin/${x} ]
- then
- mv $x ../${CHOST}/bin/${x}
- else
- rm -f $x
- fi
- ln -s ../${CHOST}/bin/${x} ${x}
- done
- cd ${S}
- if [ -z "`use build`" ]
- then
- dodoc COPYING* README
- docinto bfd
- dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
- docinto binutils
- dodoc binutils/ChangeLog binutils/NEWS binutils/README
- docinto gas
- dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
- docinto gprof
- dodoc gprof/ChangeLog* gprof/TEST gprof/TODO
- docinto ld
- dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
- docinto libiberty
- dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
- docinto opcodes
- dodoc opcodes/ChangeLog*
- rm -f ${D}/usr/share/man/man1/*
- doman ${S}/man/*.1
- else
- rm -rf ${D}/usr/share/man
- fi
-}
-
-
-
diff --git a/sys-devel/binutils/binutils-2.12.90.0.14.ebuild b/sys-devel/binutils/binutils-2.12.90.0.14.ebuild
deleted file mode 100644
index 8eca91dee578..000000000000
--- a/sys-devel/binutils/binutils-2.12.90.0.14.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.12.90.0.14.ebuild,v 1.4 2002/07/11 06:30:56 drobbins Exp $
-
-# NOTE to Maintainer: ChangeLog states that it no longer use perl to build
-# the manpages, but seems this is incorrect ....
-
-inherit libtool
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Tools necessary to build programs"
-SRC_URI="ftp://ftp.kernel.org/pub/linux/devel/binutils/${P}.tar.bz2"
-
-SLOT="0"
-LICENSE="GPL-2|LGPL-2"
-KEYWORDS="x86"
-HOMEPAGE="http://sources.redhat.com/binutils/"
-
-DEPEND="virtual/glibc
- nls? ( sys-devel/gettext )"
-
-[ -z "`use build`" ] && [ -z "`use bootstrap`" ] && \
- DEPEND="${DEPEND} sys-devel/perl"
-
-
-pkg_setup() {
-
- eerror
- eerror "Please do not use this release of binutils, as it"
- eerror "is very buggy (cannot even compile glibc)!!!"
- eerror
- die
-}
-
-src_unpack() {
-
- unpack ${A}
-
- cd ${S}
- # Some Mandrake/Suse patches to fixup build (fails with glibc among other
- # thigns).
- patch -p1 <${FILESDIR}/${P}-glibc21.patch || die
- patch -p1 <${FILESDIR}/${P}-x86_64-libpic.patch || die
-}
-
-src_compile() {
-
- local myconf=""
- use nls && \
- myconf="${myconf} --without-included-gettext" || \
- myconf="${myconf} --disable-nls"
-
- # DO NOT LIBTOOLIZE, AS BINUTILS COME WITH ITS OWN VERSION
- # OF LIBTOOL!!!!!!!
- elibtoolize --portage
-
- ./configure --enable-shared \
- --enable-64-bit-bfd \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --host=${CHOST} \
- ${myconf} || die
-
- if [ "`use static`" ]
- then
- make headers -C bfd CFLAGS=-O || die
- emake -e LDFLAGS=-all-static || die
- else
- make headers -C bfd CFLAGS=-O || die
- emake || die
- fi
-
- if [ -z "`use build`" ]
- then
- if [ -z "`use bootstrap`" ]
- then
- #nuke the manpages to recreate them (only use this if we have perl)
- find . -name '*.1' -exec rm {} ';'
- fi
- #make the info pages (makeinfo included with gcc is used)
- make info || die
- fi
-}
-
-src_install() {
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die
-
- insinto /usr/include
- doins include/libiberty.h
-
- #c++filt is included with gcc -- what are these GNU people thinking?
- #but not the manpage, so leave that!
- rm -f ${D}/usr/bin/c++filt #${D}/usr/share/man/man1/c++filt*
-
- #strip has a symlink going from /usr/${CHOST}/bin/strip to /usr/bin/strip
- #we should reverse it:
-
- rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
- #the strip symlink gets created in the loop below
-
- #ar, as, ld, nm, ranlib and strip are in two places; create symlinks. This will reduce the
- #size of the tbz2 significantly. We also move all the stuff in /usr/bin to /usr/${CHOST}/bin
- #and create the appropriate symlinks. Things are cleaner that way.
- cd ${D}/usr/bin
- local x
- for x in * strip
- do
- if [ ! -e ../${CHOST}/bin/${x} ]
- then
- mv $x ../${CHOST}/bin/${x}
- else
- rm -f $x
- fi
- ln -s ../${CHOST}/bin/${x} ${x}
- done
-
- cd ${S}
- if [ -z "`use build`" ]
- then
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install-info || die
-
- dodoc COPYING* README
- docinto bfd
- dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
- docinto binutils
- dodoc binutils/ChangeLog binutils/NEWS binutils/README
- docinto gas
- dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
- docinto gprof
- dodoc gprof/ChangeLog* gprof/TEST gprof/TODO
- docinto ld
- dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
- docinto libiberty
- dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
- docinto opcodes
- dodoc opcodes/ChangeLog*
- #install pre-generated manpages
- else
- rm -rf ${D}/usr/share/man
- fi
-}
-
diff --git a/sys-devel/binutils/binutils-2.12.90.0.7.ebuild b/sys-devel/binutils/binutils-2.12.90.0.7.ebuild
index 8b3b8a361217..0e5fea3e3f06 100644
--- a/sys-devel/binutils/binutils-2.12.90.0.7.ebuild
+++ b/sys-devel/binutils/binutils-2.12.90.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.12.90.0.7.ebuild,v 1.8 2002/08/01 19:38:49 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.12.90.0.7.ebuild,v 1.9 2002/08/01 20:16:19 azarah Exp $
# NOTE to Maintainer: ChangeLog states that it no longer use perl to build
# the manpages, but seems this is incorrect ....
@@ -17,12 +17,21 @@ KEYWORDS="x86 ppc"
HOMEPAGE="http://sources.redhat.com/binutils/"
DEPEND="virtual/glibc
- >=sys-apps/portage-2.0.21
- nls? ( sys-devel/gettext )
- || ( sys-devel/perl
- ( !build? ( sys-devel/perl ) )
- ( !bootstrap? ( sys-devel/perl ) )
- )"
+ nls? ( sys-devel/gettext )"
+
+if [ -z "`use build`" ] && [ -z "`use bootstrap`" ]
+then
+ DEPEND="${DEPEND}
+ sys-devel/perl"
+fi
+
+#DEPEND="virtual/glibc
+# >=sys-apps/portage-2.0.21
+# nls? ( sys-devel/gettext )
+# || ( sys-devel/perl
+# ( !build? ( sys-devel/perl ) )
+# ( !bootstrap? ( sys-devel/perl ) )
+# )"
# This is a hairy one. Basically depend on sys-devel/perl
# if "build" or "bootstrap" not in USE.
diff --git a/sys-devel/binutils/binutils-2.12.90.0.9.ebuild b/sys-devel/binutils/binutils-2.12.90.0.9.ebuild
deleted file mode 100644
index e93f77d6a326..000000000000
--- a/sys-devel/binutils/binutils-2.12.90.0.9.ebuild
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.12.90.0.9.ebuild,v 1.6 2002/07/11 06:30:56 drobbins Exp $
-
-# NOTE to Maintainer: ChangeLog states that it no longer use perl to build
-# the manpages, but seems this is incorrect ....
-
-inherit libtool
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Tools necessary to build programs"
-SRC_URI="ftp://ftp.kernel.org/pub/linux/devel/binutils/${P}.tar.bz2"
-LICENSE="GPL-2 LGPL-2 BINUTILS"
-KEYWORDS="x86"
-HOMEPAGE="http://sources.redhat.com/binutils/"
-
-SLOT="0"
-
-DEPEND="virtual/glibc
- nls? ( sys-devel/gettext )"
-
-[ -z "`use build`" ] && [ -z "`use bootstrap`" ] && \
- DEPEND="${DEPEND} sys-devel/perl"
-
-pkg_setup() {
-
- eerror
- eerror "Please do not use this release of binutils, as it"
- eerror "is very buggy (cannot even compile glibc)!!!"
- eerror
- die
-}
-
-src_compile() {
-
- local myconf=""
- use nls && \
- myconf="${myconf} --without-included-gettext" || \
- myconf="${myconf} --disable-nls"
-
- # DO NOT LIBTOOLIZE, AS BINUTILS COME WITH ITS OWN VERSION
- # OF LIBTOOL!!!!!!!
- elibtoolize --portage
-
- ./configure --enable-shared \
- --enable-64-bit-bfd \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --host=${CHOST} \
- ${myconf} || die
-
- if [ "`use static`" ]
- then
- make headers -C bfd CFLAGS=-O || die
- emake -e LDFLAGS=-all-static || die
- else
- make headers -C bfd CFLAGS=-O || die
- emake || die
- fi
-
- if [ -z "`use build`" ]
- then
- if [ -z "`use bootstrap`" ]
- then
- #nuke the manpages to recreate them (only use this if we have perl)
- find . -name '*.1' -exec rm {} ';'
- fi
- #make the info pages (makeinfo included with gcc is used)
- make info || die
- fi
-}
-
-src_install() {
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die
-
- insinto /usr/include
- doins include/libiberty.h
-
- #c++filt is included with gcc -- what are these GNU people thinking?
- #but not the manpage, so leave that!
- rm -f ${D}/usr/bin/c++filt #${D}/usr/share/man/man1/c++filt*
-
- #strip has a symlink going from /usr/${CHOST}/bin/strip to /usr/bin/strip
- #we should reverse it:
-
- rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
- #the strip symlink gets created in the loop below
-
- #ar, as, ld, nm, ranlib and strip are in two places; create symlinks. This will reduce the
- #size of the tbz2 significantly. We also move all the stuff in /usr/bin to /usr/${CHOST}/bin
- #and create the appropriate symlinks. Things are cleaner that way.
- cd ${D}/usr/bin
- local x
- for x in * strip
- do
- if [ ! -e ../${CHOST}/bin/${x} ]
- then
- mv $x ../${CHOST}/bin/${x}
- else
- rm -f $x
- fi
- ln -s ../${CHOST}/bin/${x} ${x}
- done
-
- cd ${S}
- if [ -z "`use build`" ]
- then
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install-info || die
-
- dodoc COPYING* README
- docinto bfd
- dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
- docinto binutils
- dodoc binutils/ChangeLog binutils/NEWS binutils/README
- docinto gas
- dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
- docinto gprof
- dodoc gprof/ChangeLog* gprof/TEST gprof/TODO
- docinto ld
- dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
- docinto libiberty
- dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
- docinto opcodes
- dodoc opcodes/ChangeLog*
- #install pre-generated manpages
- else
- rm -rf ${D}/usr/share/man
- fi
-}
-
diff --git a/sys-devel/binutils/files/digest-binutils-2.11.90.0.27 b/sys-devel/binutils/files/digest-binutils-2.11.90.0.27
deleted file mode 100644
index 3aead1258558..000000000000
--- a/sys-devel/binutils/files/digest-binutils-2.11.90.0.27
+++ /dev/null
@@ -1 +0,0 @@
-MD5 8466c723994f435f9ad18238a328b4ae binutils-2.11.90.0.27.tar.bz2 7672148
diff --git a/sys-devel/binutils/files/digest-binutils-2.11.90.0.31 b/sys-devel/binutils/files/digest-binutils-2.11.90.0.31
deleted file mode 100644
index ec43c6dae911..000000000000
--- a/sys-devel/binutils/files/digest-binutils-2.11.90.0.31
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 f08a8950d9e533f63716a391f5392477 binutils-2.11.90.0.31.tar.gz 9749973
-MD5 31256b397e8bd4fb85fbefa72d58aa7c binutils-manpages-2.11.90.0.31.tar.bz2 29799
diff --git a/sys-devel/binutils/files/digest-binutils-2.11.90.0.7-r1 b/sys-devel/binutils/files/digest-binutils-2.11.90.0.7-r1
deleted file mode 100644
index 4202470f009c..000000000000
--- a/sys-devel/binutils/files/digest-binutils-2.11.90.0.7-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 d80bb57a83a38d77daf40d45379053ed binutils-2.11.90.0.7.tar.gz 9508595
-MD5 344b61b80b1568e73c071254d65c8e38 binutils-manpages-2.11.90.0.7.tar.bz2 48999
diff --git a/sys-devel/binutils/files/digest-binutils-2.12.90.0.14 b/sys-devel/binutils/files/digest-binutils-2.12.90.0.14
deleted file mode 100644
index a4b0e72f5064..000000000000
--- a/sys-devel/binutils/files/digest-binutils-2.12.90.0.14
+++ /dev/null
@@ -1 +0,0 @@
-MD5 0e057e6b4580a588362bc9c1b47b461a binutils-2.12.90.0.14.tar.bz2 8929369
diff --git a/sys-devel/binutils/files/digest-binutils-2.12.90.0.9 b/sys-devel/binutils/files/digest-binutils-2.12.90.0.9
deleted file mode 100644
index 95e8205903d4..000000000000
--- a/sys-devel/binutils/files/digest-binutils-2.12.90.0.9
+++ /dev/null
@@ -1 +0,0 @@
-MD5 0ba37d013c4387d7feee0944235b23bf binutils-2.12.90.0.9.tar.bz2 8787239