summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-17 22:48:32 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-17 22:48:32 +0000
commita3ad71c9a15ddc44da0501169b908daca5b05590 (patch)
treedc3b8cfd6c488c4613245c39cd8624e296c3d1a9 /sys-devel
parentdev-php/php -> virtual/php #102845 by Jakub Moc (diff)
downloadgentoo-2-a3ad71c9a15ddc44da0501169b908daca5b05590.tar.gz
gentoo-2-a3ad71c9a15ddc44da0501169b908daca5b05590.tar.bz2
gentoo-2-a3ad71c9a15ddc44da0501169b908daca5b05590.zip
add support for msp430 targets
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/crossdev/ChangeLog9
-rw-r--r--sys-devel/crossdev/crossdev-0.9.9.ebuild21
-rwxr-xr-xsys-devel/crossdev/files/crossdev9
-rw-r--r--sys-devel/crossdev/files/digest-crossdev-0.9.90
4 files changed, 36 insertions, 3 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index d95f82349426..59fb869c1df8 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/crossdev
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.21 2005/07/25 23:00:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.22 2005/08/17 22:48:32 vapier Exp $
+
+*crossdev-0.9.9 (17 Aug 2005)
+
+ 17 Aug 2005; Mike Frysinger <vapier@gentoo.org> files/crossdev,
+ +crossdev-0.9.9.ebuild:
+ Add a help target so the user knows what crossdev supports, and add initial
+ support for msp430 targets.
*crossdev-0.9.8 (25 Jul 2005)
diff --git a/sys-devel/crossdev/crossdev-0.9.9.ebuild b/sys-devel/crossdev/crossdev-0.9.9.ebuild
new file mode 100644
index 000000000000..1270c2335c1e
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-0.9.9.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-0.9.9.ebuild,v 1.1 2005/08/17 22:48:32 vapier Exp $
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
+IUSE=""
+
+RDEPEND="sys-apps/portage
+ app-shells/bash
+ sys-apps/coreutils"
+
+src_install() {
+ dosbin "${FILESDIR}"/crossdev || die
+ dosed "s:GENTOO_PV:${PV}:" /usr/sbin/crossdev
+}
diff --git a/sys-devel/crossdev/files/crossdev b/sys-devel/crossdev/files/crossdev
index 5686c5b56cf5..325cd32b7c12 100755
--- a/sys-devel/crossdev/files/crossdev
+++ b/sys-devel/crossdev/files/crossdev
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.30 2005/08/06 20:50:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.31 2005/08/17 22:48:32 vapier Exp $
if [[ ${ROOT:-/} != "/" ]] ; then
echo "Sorry, but crossdev does not support ROOT."
@@ -97,6 +97,10 @@ parse_target() {
GVER="3.4.4"; BVER="2.16.1";
GUSE="-fortran -gtk -gcj -objc";;
+ msp430)
+ TARCH=${HARCH}; CPOST="";
+ STAGE=${STAGE_BINUTILS};;
+
ps2*) einfo "The ps2 target is really an alias for the ee/iop/dvp targets"
${CROSSDEV} -t ee || exit 1
${CROSSDEV} -t iop || exit 1
@@ -144,8 +148,9 @@ parse_target() {
Special Targets:
avr
+ msp430
ps2 (alias for the following 3 targets)
- ee / iop / dvp (playstation2 targets)
+ ee / iop / dvp (Playstation 2 targets)
EOF
exit 0
;;
diff --git a/sys-devel/crossdev/files/digest-crossdev-0.9.9 b/sys-devel/crossdev/files/digest-crossdev-0.9.9
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-devel/crossdev/files/digest-crossdev-0.9.9