summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-05-22 22:51:59 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-05-22 22:51:59 +0000
commitaed994c995f921c4a6c5dd0bf9841836f410a418 (patch)
treefbcb34e94b0f4618ef11dc2a0e925f87a05276a7 /sys-devel
parentmore fixes (diff)
downloadgentoo-2-aed994c995f921c4a6c5dd0bf9841836f410a418.tar.gz
gentoo-2-aed994c995f921c4a6c5dd0bf9841836f410a418.tar.bz2
gentoo-2-aed994c995f921c4a6c5dd0bf9841836f410a418.zip
new version
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/autoconf/ChangeLog10
-rw-r--r--sys-devel/autoconf/autoconf-2.53a.ebuild120
-rw-r--r--sys-devel/autoconf/files/digest-autoconf-2.53a2
3 files changed, 131 insertions, 1 deletions
diff --git a/sys-devel/autoconf/ChangeLog b/sys-devel/autoconf/ChangeLog
index c5b09d696649..49184b795a70 100644
--- a/sys-devel/autoconf/ChangeLog
+++ b/sys-devel/autoconf/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/autoconf
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.5 2002/05/19 17:45:33 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.6 2002/05/22 22:51:59 azarah Exp $
+
+autoconf-2.53a (22 May 2002)
+
+ 22 May 2002; M.Schlemmer <azarah@gentoo.org> autoconf-2.53a.ebuild :
+
+ Update in hope of fixing the gcc3 build problem (somewhere with
+ m4 version detection, bug #2929. I am not sure, as I could not
+ get feedback if working or not.
autoconf-2.53-r1 (19 May 2002)
diff --git a/sys-devel/autoconf/autoconf-2.53a.ebuild b/sys-devel/autoconf/autoconf-2.53a.ebuild
new file mode 100644
index 000000000000..e0d3fd1ebf4e
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.53a.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.53a.ebuild,v 1.1 2002/05/22 22:51:59 azarah Exp $
+
+OLD_PV=2.13
+OLD_P=${PN}-${OLD_PV}
+S=${WORKDIR}/${P}
+OLD_S=${WORKDIR}/${OLD_P}
+DESCRIPTION="Used to create autoconfiguration files"
+SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.bz2
+ ftp://ftp.gnu.org/gnu/${PN}/${OLD_P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
+
+DEPEND=">=sys-devel/m4-1.4p
+ sys-devel/perl"
+
+SLOT="2.5"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${OLD_S}
+ patch -p0 < ${FILESDIR}/${OLD_P}-configure-gentoo.diff || die
+ patch -p0 < ${FILESDIR}/${OLD_P}-configure.in-gentoo.diff || die
+}
+
+src_compile() {
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+ cd ${S}
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+ cd ${OLD_S}
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+}
+
+src_install() {
+
+ # install wrapper script for autodetecting the proper version
+ # to use.
+ exeinto /usr/lib/${PN}
+ doexe ${FILESDIR}/ac-wrapper.pl
+ dosed "s:2\.5x:${PV}:g" /usr/lib/${PN}/ac-wrapper.pl
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+
+ # need to use 'DESTDIR' here, else perl stuff puke
+ cd ${S}
+ make DESTDIR=${D} \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${PV}
+ done
+ # new in 2.5x
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/autom4te
+
+ mv ${D}/usr/share/info/autoconf.info ${D}/usr/share/info/autoconf-2.5.info
+
+ docinto ${PV}
+ dodoc COPYING AUTHORS BUGS NEWS README TODO THANKS
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+
+ # need to use 'prefix' here, else we get sandbox problems
+ cd ${OLD_S}
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${OLD_PV}
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/${x}
+ done
+
+ docinto ${OLD_PV}
+ dodoc COPYING AUTHORS NEWS README TODO
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1
+
+ # from binutils
+ rm -f ${D}/usr/share/info/standards.info*
+}
+
+pkg_preinst() {
+
+ # remove these to make sure symlinks install properly if old versions
+ # was binaries
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ if [ -e /usr/bin/${x} ]
+ then
+ rm -f /usr/bin/${x}
+ fi
+ done
+}
+
diff --git a/sys-devel/autoconf/files/digest-autoconf-2.53a b/sys-devel/autoconf/files/digest-autoconf-2.53a
new file mode 100644
index 000000000000..1ffbf3610c52
--- /dev/null
+++ b/sys-devel/autoconf/files/digest-autoconf-2.53a
@@ -0,0 +1,2 @@
+MD5 5545dca21a11cb21e69c86028e6cddbc autoconf-2.53a.tar.bz2 769045
+MD5 9de56d4a161a723228220b0f425dc711 autoconf-2.13.tar.gz 443844