summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-15 14:30:03 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-15 14:30:03 +0000
commitb1d163841c764e7c7a536d494bf66b6b3dcebbb5 (patch)
tree905748809eda0299dfaa0b8682cdfe0604130196 /sys-devel
parentkeyword ~ia64 wrt bug #487944 (diff)
downloadgentoo-2-b1d163841c764e7c7a536d494bf66b6b3dcebbb5.tar.gz
gentoo-2-b1d163841c764e7c7a536d494bf66b6b3dcebbb5.tar.bz2
gentoo-2-b1d163841c764e7c7a536d494bf66b6b3dcebbb5.zip
Restore the old clang patch as clang-3.3-gentoo-install.patch, and use it for version 3.3-r3. Bug #513346.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog7
-rw-r--r--sys-devel/llvm/files/clang-3.3-gentoo-install.patch4
-rw-r--r--sys-devel/llvm/llvm-3.3-r3.ebuild4
3 files changed, 10 insertions, 5 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 1a015aa6b8b2..994bab942270 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.199 2014/06/14 18:49:46 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.200 2014/06/15 14:30:03 mgorny Exp $
+
+ 15 Jun 2014; Michał Górny <mgorny@gentoo.org>
+ files/clang-3.3-gentoo-install.patch, llvm-3.3-r3.ebuild:
+ Restore the old clang patch as clang-3.3-gentoo-install.patch, and use it for
+ version 3.3-r3. Bug #513346.
*llvm-3.4.1-r2 (14 Jun 2014)
diff --git a/sys-devel/llvm/files/clang-3.3-gentoo-install.patch b/sys-devel/llvm/files/clang-3.3-gentoo-install.patch
index f7bcfc63f69b..5519fbc9132b 100644
--- a/sys-devel/llvm/files/clang-3.3-gentoo-install.patch
+++ b/sys-devel/llvm/files/clang-3.3-gentoo-install.patch
@@ -18,7 +18,7 @@ index e014980..6e60513 100644
// not supported by old linkers.
std::string ProfileRT =
- std::string(TC.getDriver().Dir) + "/../lib/libprofile_rt.a";
-+ "-l:llvm/libprofile_rt.a";
++ "-l:libprofile_rt.a";
CmdArgs.push_back(Args.MakeArgString(ProfileRT));
}
@@ -27,7 +27,7 @@ index e014980..6e60513 100644
if (D.IsUsingLTO(Args) || Args.hasArg(options::OPT_use_gold_plugin)) {
CmdArgs.push_back("-plugin");
- std::string Plugin = ToolChain.getDriver().Dir + "/../lib/LLVMgold.so";
-+ std::string Plugin = ToolChain.getDriver().Dir + "/../@libdir@/llvm/LLVMgold.so";
++ std::string Plugin = ToolChain.getDriver().Dir + "/../@libdir@/LLVMgold.so";
CmdArgs.push_back(Args.MakeArgString(Plugin));
// Try to pass driver level flags relevant to LTO code generation down to
diff --git a/sys-devel/llvm/llvm-3.3-r3.ebuild b/sys-devel/llvm/llvm-3.3-r3.ebuild
index 37aa1b637317..94a8b523a433 100644
--- a/sys-devel/llvm/llvm-3.3-r3.ebuild
+++ b/sys-devel/llvm/llvm-3.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.3-r3.ebuild,v 1.10 2014/05/01 15:09:30 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.3-r3.ebuild,v 1.11 2014/06/15 14:30:03 mgorny Exp $
EAPI=5
@@ -165,7 +165,7 @@ src_prepare() {
# Automatically select active system GCC's libraries, bugs #406163 and #417913
epatch "${FILESDIR}"/clang-3.1-gentoo-runtime-gcc-detection-v3.patch
- epatch "${FILESDIR}"/clang-3.4-gentoo-install.patch
+ epatch "${FILESDIR}"/clang-3.3-gentoo-install.patch
# backport support for g++-X.Y header location
epatch "${FILESDIR}"/clang-3.3-gcc-header-path.patch