summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-08-15 23:06:36 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-08-15 23:06:36 +0000
commitc39a641fce720cad3130eed56a5ea80dff4e4261 (patch)
tree14d47b5e10e19f9d99e58135d50f06b683e6d5b5 /sys-devel
parentfix0rs (diff)
downloadgentoo-2-c39a641fce720cad3130eed56a5ea80dff4e4261.tar.gz
gentoo-2-c39a641fce720cad3130eed56a5ea80dff4e4261.tar.bz2
gentoo-2-c39a641fce720cad3130eed56a5ea80dff4e4261.zip
fix0rs
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/distcc/ChangeLog9
-rw-r--r--sys-devel/distcc/Manifest4
-rw-r--r--sys-devel/distcc/distcc-2.10-r2.ebuild111
-rw-r--r--sys-devel/distcc/files/digest-distcc-2.10-r21
4 files changed, 122 insertions, 3 deletions
diff --git a/sys-devel/distcc/ChangeLog b/sys-devel/distcc/ChangeLog
index 8a616077116d..758e4bf66f96 100644
--- a/sys-devel/distcc/ChangeLog
+++ b/sys-devel/distcc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/distcc
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.70 2003/08/13 22:13:59 lisa Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.71 2003/08/15 23:06:33 seemant Exp $
+
+*distcc-2.10-r2 (15 Aug 2003)
+
+ 15 Aug 2003; Seemant Kulleen <seemant@gentoo.org> distcc-2.10-r2.ebuild:
+ fixed the distcc_log env installation on installation. Lisa gave me the fix to
+ commit while she has technical issues. So please don't think I'm maintaining
+ it, coz I'm not :)
*distcc-2.10-r1 (13 Aug 2003)
diff --git a/sys-devel/distcc/Manifest b/sys-devel/distcc/Manifest
index b42cdd211703..dbf5a2103bd0 100644
--- a/sys-devel/distcc/Manifest
+++ b/sys-devel/distcc/Manifest
@@ -3,8 +3,8 @@ MD5 ff26d9e0a5f8d639aa1f2810187d9012 distcc-2.10-r1.ebuild 3489
MD5 564b09fcdf279623746f23731af6cdef distcc-2.5-r1.ebuild 3209
MD5 8cfcda064781a10ddcddbc85f43b032a distcc-2.10.ebuild 3451
MD5 39b60fea6d5f9d0d931161848d6a550e distcc-2.9.ebuild 3446
-MD5 1d3cffe188ccdb494351eaca7d905e70 distcc-2.10-r2.ebuild 3505
-MD5 77e4db77f32b05a32e2d2ea7e1d2d0d1 ChangeLog 12132
+MD5 a64395143382132b1a82f6d87016e21e distcc-2.10-r2.ebuild 3508
+MD5 b55f9daa30af04becec3f957198cc0e3 ChangeLog 12423
MD5 70619e7eb5fa4fd0aa4f3588579cd50d metadata.xml 443
MD5 ade4e8cda892045944e204fc2c3df8bd files/digest-distcc-2.9 63
MD5 996b45704fdf266745dfc2e6038a1f76 files/digest-distcc-2.10-r1 64
diff --git a/sys-devel/distcc/distcc-2.10-r2.ebuild b/sys-devel/distcc/distcc-2.10-r2.ebuild
new file mode 100644
index 000000000000..a8ef198487c0
--- /dev/null
+++ b/sys-devel/distcc/distcc-2.10-r2.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-2.10-r2.ebuild,v 1.1 2003/08/15 23:06:33 seemant Exp $
+
+inherit eutils gcc flag-o-matic
+[ `gcc-major-version` -eq 2 ] && filter-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+
+HOMEPAGE="http://distcc.samba.org/"
+SRC_URI="http://distcc.samba.org/ftp/distcc/distcc-${PV}.tar.bz2"
+DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm"
+IUSE="gtk"
+
+DEPEND=">=sys-apps/portage-2.0.46-r11
+ >=sys-devel/gcc-config-1.3.1
+ sys-apps/shadow"
+
+RDEPEND="gtk? ( >=x11-libs/gtk+-2.2.1 )
+ selinux? ( sec-policy/selinux-distcc )"
+
+
+src_compile() {
+ local myconf="--with-included-popt "
+ #Here we use the built in parse-options package. It saves a dependancy
+
+ use gtk && myconf="--enable-gnome"
+
+ econf ${myconf} || die "econf ${myconf} failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D%/}" install
+
+ insinto /usr/share/doc/${PN}
+ doins "${S}/survey.txt"
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/${PV}/distcc-config"
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/${PV}/conf" distccd
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/${PV}/init" distccd
+
+ # create and keep the symlink dir
+ dodir /usr/lib/distcc/bin
+ keepdir /usr/lib/distcc/bin
+
+ # create the distccd pid directory
+ dodir /var/run/distccd
+ keepdir /var/run/distccd
+}
+
+pkg_preinst() {
+ # non-/ installs don't require us to do anything here
+ [ "${ROOT}" != "/" ] && return 0
+
+ # stop daemon since script is being updated
+ [ -n "$(pidof distccd)" -a -x /etc/init.d/distccd ] && \
+ /etc/init.d/distccd stop
+
+ # moved user creation and permissions to distcc-config script
+ # because of ROOT install requirements
+}
+
+pkg_postinst() {
+ # handle DISTCC_HOSTS upgrade better
+ local ENVFILE
+ ENVFILE="${ROOT}etc/env.d/02distcc"
+ [ ! -f "${ENVFILE}" ] && \
+ ENVFILE="${ROOT}etc/env.d/04distcc"
+ if [ -f "${ENVFILE}" ]
+ then
+ # save hosts to new file
+ ROOT="${ROOT}" ${ROOT}usr/bin/distcc-config --set-hosts \
+ $(egrep '^DISTCC_HOSTS' "${ENVFILE}" | sed 's,[^=]*=,,')
+ # now remove from the file
+ grep -v 'DISTCC_HOSTS' "${ENVFILE}" > "${ENVFILE}.new"
+ mv "${ENVFILE}.new" "${ENVFILE}"
+ fi
+
+ if [ "${ROOT}" = "/" ]; then
+ einfo "Installing links to native compilers..."
+ /usr/bin/distcc-config --install-user
+ /usr/bin/distcc-config --install-links
+ /usr/bin/distcc-config --install-links "${CHOST}"
+ /usr/bin/distcc-config --set-env DISTCC_DIR /tmp
+ else
+ # distcc-config can *almost* handle ROOT installs itself
+ # but for now, but user must finsh things off
+ ewarn "*** Installation is not complete ***"
+ ewarn "You must run the following as root:"
+ ewarn " /usr/bin/distcc-config --install"
+ ewarn "after booting or chrooting into ${ROOT}"
+ fi
+ einfo "Tips on using distcc with Gentoo can be found at"
+ einfo "http://www.gentoo.org/doc/en/distcc.xml"
+ echo ""
+ einfo "As of this release (2.10), you can specify where you want state"
+ einfo "files to go (these are for monitoring). You can specify this setting"
+ einfo "in /etc/make.conf by setting DISTCC_DIR to somewhere portage can write to"
+ einfo "such as /tmp, also, change it in /etc/conf.d/distccd."
+ echo ""
+ einfo "To use the distccmon programs with Gentoo you should use this command:"
+ einfo " sudo -H -u portage distccmon-text OR sudo -H -u portage distccmon-gnome"
+}
diff --git a/sys-devel/distcc/files/digest-distcc-2.10-r2 b/sys-devel/distcc/files/digest-distcc-2.10-r2
new file mode 100644
index 000000000000..0dbf80357d04
--- /dev/null
+++ b/sys-devel/distcc/files/digest-distcc-2.10-r2
@@ -0,0 +1 @@
+MD5 044474020e864123b01aaa1c06fc831a distcc-2.10.tar.bz2 239769