summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-12-16 18:45:53 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-12-16 18:45:53 +0000
commitde6bbc90802f5698926211710968d249e56642cf (patch)
tree654615022cc0bdf9a04abc7614253bff3a39be84 /sys-devel
parentfix /usr/lib/X11 symlink (diff)
downloadgentoo-2-de6bbc90802f5698926211710968d249e56642cf.tar.gz
gentoo-2-de6bbc90802f5698926211710968d249e56642cf.tar.bz2
gentoo-2-de6bbc90802f5698926211710968d249e56642cf.zip
add --list-profiles
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-config/files/cc3
-rw-r--r--sys-devel/gcc-config/files/cpp3
-rw-r--r--sys-devel/gcc-config/files/digest-gcc-config-1.2.10
-rw-r--r--sys-devel/gcc-config/files/digest-gcc-config-1.2.20
-rw-r--r--sys-devel/gcc-config/files/digest-gcc-config-1.2.4 (renamed from sys-devel/gcc-config/files/digest-gcc-config-1.2)0
-rw-r--r--sys-devel/gcc-config/files/gcc-config-1.2279
-rw-r--r--sys-devel/gcc-config/files/gcc-config-1.2.2282
-rw-r--r--sys-devel/gcc-config/files/gcc-config-1.2.4 (renamed from sys-devel/gcc-config/files/gcc-config-1.2.1)88
-rw-r--r--sys-devel/gcc-config/gcc-config-1.2.1.ebuild20
-rw-r--r--sys-devel/gcc-config/gcc-config-1.2.4.ebuild (renamed from sys-devel/gcc-config/gcc-config-1.2.2.ebuild)21
-rw-r--r--sys-devel/gcc-config/gcc-config-1.2.ebuild20
11 files changed, 76 insertions, 640 deletions
diff --git a/sys-devel/gcc-config/files/cc b/sys-devel/gcc-config/files/cc
deleted file mode 100644
index c1c24e1bd131..000000000000
--- a/sys-devel/gcc-config/files/cc
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-gcc "$@"
diff --git a/sys-devel/gcc-config/files/cpp b/sys-devel/gcc-config/files/cpp
deleted file mode 100644
index e4a91acae67a..000000000000
--- a/sys-devel/gcc-config/files/cpp
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-cpp "$@"
diff --git a/sys-devel/gcc-config/files/digest-gcc-config-1.2.1 b/sys-devel/gcc-config/files/digest-gcc-config-1.2.1
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/sys-devel/gcc-config/files/digest-gcc-config-1.2.1
+++ /dev/null
diff --git a/sys-devel/gcc-config/files/digest-gcc-config-1.2.2 b/sys-devel/gcc-config/files/digest-gcc-config-1.2.2
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/sys-devel/gcc-config/files/digest-gcc-config-1.2.2
+++ /dev/null
diff --git a/sys-devel/gcc-config/files/digest-gcc-config-1.2 b/sys-devel/gcc-config/files/digest-gcc-config-1.2.4
index e69de29bb2d1..e69de29bb2d1 100644
--- a/sys-devel/gcc-config/files/digest-gcc-config-1.2
+++ b/sys-devel/gcc-config/files/digest-gcc-config-1.2.4
diff --git a/sys-devel/gcc-config/files/gcc-config-1.2 b/sys-devel/gcc-config/files/gcc-config-1.2
deleted file mode 100644
index 9cdd450090d2..000000000000
--- a/sys-devel/gcc-config/files/gcc-config-1.2
+++ /dev/null
@@ -1,279 +0,0 @@
-#!/bin/bash
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author: Martin Schlemmer <azarah@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.2,v 1.1 2002/11/10 15:17:26 azarah Exp $
-
-
-source /etc/init.d/functions.sh || {
- echo "$0: Could not source /etc/init.d/functions.sh!"
- exit 1
-}
-
-if [ "$(id -u)" -ne 0 ]
-then
- eerror "$0: Must be root."
- exit 1
-fi
-
-usage() {
-cat << "USAGE_END"
-Usage: gcc-config [Option] <CHOST>-<gcc version>
-Options:
- [--use-old]
-
- Use the old profile if one was selected.
-
- [--use-portage-chost]
-
- Only set to given profile if its CHOST is the same as that
- set for portage in /etc/make.conf (or one of other portage
- config files...).
-
- [--get-current-profile]
-
- Print current used gcc profile.
-
- [--get-bin-path]
-
- Print path where binaries of given/current profile are located.
-
- [--get-lib-path]
-
- Print path where libraries of given/current profile are located.
-
- [--get-stdcxx-incdir]
-
- Print path to g++ include files of given/current profile.
-
-
-USAGE_END
-
- exit 1
-}
-
-if [ "$#" -lt 1 ]
-then
- usage
-fi
-
-find_path() {
- [ -z "$1" ] && return 0
-
- for x in /bin /sbin /usr/bin /usr/sbin
- do
- if [ -x ${x}/$1 -a -r ${x}/$1 ]
- then
- echo "${x}/$1"
- break
- fi
- done
-}
-
-GCC_COMP=""
-REAL_CHOST="$(/usr/bin/python -c 'import portage; print portage.settings["CHOST"];')"
-
-switch_profile() {
- local MY_LDPATH=""
- local GCC_PROFILES=""
-
- ebegin "Switching to ${GCC_COMP} compiler"
-
- # Sourcing /etc/env.d/gcc/${GCC_COMP} is going to mess up
- # PATH among things...
- CP="$(find_path cp)"
- RM="$(find_path rm)"
- MV="$(find_path mv)"
- LN="$(find_path ln)"
- AWK="$(find_path gawk)"
- GREP="$(find_path grep)"
- FIND="$(find_path find)"
- ENV_UPDATE="$(find_path env-update)"
-
- # Order our profiles to have the default first...
- # We do this so that we can have them ordered with default
- # first in /etc/ld.so.conf, as the logical is that all
- # compilers for default CHOST will be used to compile stuff,
- # and thus we want all their lib paths in /etc/ld.so.conf ...
- GCC_PROFILES="$(${FIND} /etc/env.d/gcc/ -name "${REAL_CHOST}-*")"
- GCC_PROFILES="${GCC_PROFILES/\/etc\/env.d\/gcc\/${GCC_COMP}}"
- GCC_PROFILES="/etc/env.d/gcc/${GCC_COMP} ${GCC_PROFILES}"
-
- # Extract all LDPATH's for our CHOST
- for x in ${GCC_PROFILES}
- do
- if [ -f ${x} ]
- then
- source ${x}
-
- if [ -z "${MY_LDPATH}" ]
- then
- MY_LDPATH="${LDPATH}"
- else
- MY_LDPATH="${MY_LDPATH}:${LDPATH}"
- fi
- fi
- done
-
- # Setup /etc/env.d/05gcc
- ${AWK} '!/STDCXX_INCDIR|LDPATH/ {print $0}' \
- /etc/env.d/gcc/${GCC_COMP} > /etc/env.d/05gcc
- echo "LDPATH=\"${MY_LDPATH}\"" >> /etc/env.d/05gcc
-
- source /etc/env.d/gcc/${GCC_COMP}
-
- if [ -d /usr/include/${STDCXX_INCDIR} -a ! -L /usr/include/${STDCXX_INCDIR} ]
- then
- ${MV} /usr/include/${STDCXX_INCDIR} /usr/include/${STDCXX_INCDIR}.orig
- elif [ -L /usr/include/${STDCXX_INCDIR} ]
- then
- ${RM} -f /usr/include/${STDCXX_INCDIR}
- fi
- ${LN} -snf ..${LDPATH/\/usr}/include/${STDCXX_INCDIR} /usr/include/${STDCXX_INCDIR}
-
- [ -L /lib/cpp -o -f /lib/cpp ] && ${RM} -f /lib/cpp
- ${LN} -snf ..${PATH}/cpp /lib/cpp
- [ -L /usr/bin/cc -o -f /usr/bin/cc ] && ${RM} -f /usr/bin/cc
- ${LN} -snf ../..${PATH}/gcc /usr/bin/cc
-
- echo "CURRENT=${GCC_COMP}" > /etc/env.d/gcc/config
-
- source /etc/profile
-
- ${ENV_UPDATE} &> /dev/null
-
- eend 0
-
- return 0
-}
-
-get_current_profile() {
- if [ ! -f /etc/env.d/gcc/config ]
- then
- eerror "$0: No gcc profile is active!"
- return 1
- fi
-
- source /etc/env.d/gcc/config
-
- if [ -z "${CURRENT}" ]
- then
- eerror "$0: No gcc profile is active!"
- return 1
- fi
-
- echo "${CURRENT}"
-
- return 0
-}
-
-get_bin_path() {
- source /etc/env.d/gcc/${GCC_COMP}
-
- echo "${PATH}"
-
- return 0
-}
-
-get_lib_path() {
- source /etc/env.d/gcc/${GCC_COMP}
-
- echo "${LDPATH}"
-
- return 0
-}
-
-get_stdcxx_incdir() {
- source /etc/env.d/gcc/${GCC_COMP}
-
- echo "${LDPATH}/include/${STDCXX_INCDIR}"
-
- return 0
-}
-
-NEED_ACTION="yes"
-DOIT="switch_profile"
-CHECK_CHOST="no"
-
-for x in $*
-do
- case ${x} in
- # Only use specified compiler if one is not already selected.
- --use-old)
- if get_current_profile &> /dev/null
- then
- GCC_COMP="$(get_current_profile)"
- fi
- ;;
- --use-portage-chost)
- CHECK_CHOST="yes"
- ;;
- --get-current-profile)
- if [ "${NEED_ACTION}" = "yes" ]
- then
- NEED_ACTION="no"
- DOIT="get_current_profile"
- fi
- ;;
- --get-bin-path)
- if [ "${NEED_ACTION}" = "yes" ]
- then
- NEED_ACTION="no"
- DOIT="get_bin_path"
- fi
- ;;
- --get-lib-path)
- if [ "${NEED_ACTION}" = "yes" ]
- then
- NEED_ACTION="no"
- DOIT="get_lib_path"
- fi
- ;;
- --get-stdcxx-incdir)
- if [ "${NEED_ACTION}" = "yes" ]
- then
- NEED_ACTION="no"
- DOIT="get_stdcxx_incdir"
- fi
- ;;
- *)
- if [ -z "${GCC_COMP}" ]
- then
- GCC_COMP="${x}"
- fi
- ;;
- esac
-done
-
-if [ "${DOIT}" = "switch_profile" -a -z "${GCC_COMP}" ]
-then
- usage
-fi
-
-if [ -z "${GCC_COMP}" ]
-then
- if get_current_profile &> /dev/null
- then
- GCC_COMP="$(get_current_profile)"
- else
- usage
- fi
-fi
-
-if [ ! -d /usr/lib/gcc-lib/${GCC_COMP%-*}/${GCC_COMP##*-} -o \
- ! -f /etc/env.d/gcc/${GCC_COMP} ]
-then
- usage
-fi
-
-# Chosen CHOST are not the same as the real CHOST according to make.conf,
-# and --use-portage-chost option was given, so do nothing ...
-if [ "${CHECK_CHOST}" = "yes" -a "${GCC_COMP%-*}" != "${REAL_CHOST}" ]
-then
- exit 0
-fi
-
-eval ${DOIT}
-
-
-# vim:ts=4
diff --git a/sys-devel/gcc-config/files/gcc-config-1.2.2 b/sys-devel/gcc-config/files/gcc-config-1.2.2
deleted file mode 100644
index ad7c9e76f565..000000000000
--- a/sys-devel/gcc-config/files/gcc-config-1.2.2
+++ /dev/null
@@ -1,282 +0,0 @@
-#!/bin/bash
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author: Martin Schlemmer <azarah@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.2.2,v 1.1 2002/12/16 04:19:05 azarah Exp $
-
-
-source /etc/init.d/functions.sh || {
- echo "$0: Could not source /etc/init.d/functions.sh!"
- exit 1
-}
-
-usage() {
-cat << "USAGE_END"
-Usage: gcc-config [Option] <CHOST>-<gcc version>
-Options:
- [--use-old]
-
- Use the old profile if one was selected.
-
- [--use-portage-chost]
-
- Only set to given profile if its CHOST is the same as that
- set for portage in /etc/make.conf (or one of other portage
- config files...).
-
- [--get-current-profile]
-
- Print current used gcc profile.
-
- [--get-bin-path]
-
- Print path where binaries of given/current profile are located.
-
- [--get-lib-path]
-
- Print path where libraries of given/current profile are located.
-
- [--get-stdcxx-incdir]
-
- Print path to g++ include files of given/current profile.
-
-
-USAGE_END
-
- exit 1
-}
-
-if [ "$#" -lt 1 ]
-then
- usage
-fi
-
-find_path() {
- [ -z "$1" ] && return 0
-
- for x in /bin /sbin /usr/bin /usr/sbin
- do
- if [ -x ${x}/$1 -a -r ${x}/$1 ]
- then
- echo "${x}/$1"
- break
- fi
- done
-}
-
-GCC_COMP=""
-REAL_CHOST="$(/usr/bin/python -c 'import portage; print portage.settings["CHOST"];')"
-
-switch_profile() {
- local MY_LDPATH=""
- local GCC_PROFILES=""
-
- if [ "$(id -u)" -ne 0 ]
- then
- eerror "$0: Must be root."
- exit 1
- fi
-
- ebegin "Switching to ${GCC_COMP} compiler"
-
- # Sourcing /etc/env.d/gcc/${GCC_COMP} is going to mess up
- # PATH among things...
- CP="$(find_path cp)"
- RM="$(find_path rm)"
- MV="$(find_path mv)"
- LN="$(find_path ln)"
- AWK="$(find_path gawk)"
- GREP="$(find_path grep)"
- FIND="$(find_path find)"
- ENV_UPDATE="$(find_path env-update)"
-
- # Order our profiles to have the default first...
- # We do this so that we can have them ordered with default
- # first in /etc/ld.so.conf, as the logical is that all
- # compilers for default CHOST will be used to compile stuff,
- # and thus we want all their lib paths in /etc/ld.so.conf ...
- GCC_PROFILES="$(${FIND} /etc/env.d/gcc/ -name "${REAL_CHOST}-*")"
- GCC_PROFILES="${GCC_PROFILES/\/etc\/env.d\/gcc\/${GCC_COMP}}"
- GCC_PROFILES="/etc/env.d/gcc/${GCC_COMP} ${GCC_PROFILES}"
-
- # Extract all LDPATH's for our CHOST
- for x in ${GCC_PROFILES}
- do
- if [ -f ${x} ]
- then
- source ${x}
-
- if [ -z "${MY_LDPATH}" ]
- then
- MY_LDPATH="${LDPATH}"
- else
- MY_LDPATH="${MY_LDPATH}:${LDPATH}"
- fi
- fi
- done
-
- # Setup /etc/env.d/05gcc
- ${AWK} '!/STDCXX_INCDIR|LDPATH/ {print $0}' \
- /etc/env.d/gcc/${GCC_COMP} > /etc/env.d/05gcc
- echo "LDPATH=\"${MY_LDPATH}\"" >> /etc/env.d/05gcc
-
- source /etc/env.d/gcc/${GCC_COMP}
-
-# These are in gcc's internal include dir, so no need for symlinks or other
-# hacks ...
-# if [ -d /usr/include/${STDCXX_INCDIR} -a ! -L /usr/include/${STDCXX_INCDIR} ]
-# then
-# ${MV} /usr/include/${STDCXX_INCDIR} /usr/include/${STDCXX_INCDIR}.orig
-# elif [ -L /usr/include/${STDCXX_INCDIR} ]
-# then
-# ${RM} -f /usr/include/${STDCXX_INCDIR}
-# fi
-# ${LN} -snf ..${LDPATH/\/usr}/include/${STDCXX_INCDIR} /usr/include/${STDCXX_INCDIR}
-
-# We use wrapper scripts from gcc-3.2.1-r6 ....
-# [ -L /lib/cpp -o -f /lib/cpp ] && ${RM} -f /lib/cpp
-# ${LN} -snf ..${PATH}/cpp /lib/cpp
-# [ -L /usr/bin/cc -o -f /usr/bin/cc ] && ${RM} -f /usr/bin/cc
-# ${LN} -snf ../..${PATH}/gcc /usr/bin/cc
-
- echo "CURRENT=${GCC_COMP}" > /etc/env.d/gcc/config
-
- source /etc/profile
-
- ${ENV_UPDATE} &> /dev/null
-
- eend 0
-
- return 0
-}
-
-get_current_profile() {
- if [ ! -f /etc/env.d/gcc/config ]
- then
- eerror "$0: No gcc profile is active!"
- return 1
- fi
-
- source /etc/env.d/gcc/config
-
- if [ -z "${CURRENT}" ]
- then
- eerror "$0: No gcc profile is active!"
- return 1
- fi
-
- echo "${CURRENT}"
-
- return 0
-}
-
-get_bin_path() {
- source /etc/env.d/gcc/${GCC_COMP}
-
- echo "${PATH}"
-
- return 0
-}
-
-get_lib_path() {
- source /etc/env.d/gcc/${GCC_COMP}
-
- echo "${LDPATH}"
-
- return 0
-}
-
-get_stdcxx_incdir() {
- source /etc/env.d/gcc/${GCC_COMP}
-
- echo "${LDPATH}/include/${STDCXX_INCDIR}"
-
- return 0
-}
-
-NEED_ACTION="yes"
-DOIT="switch_profile"
-CHECK_CHOST="no"
-
-for x in $*
-do
- case ${x} in
- # Only use specified compiler if one is not already selected.
- --use-old)
- if get_current_profile &> /dev/null
- then
- GCC_COMP="$(get_current_profile)"
- fi
- ;;
- --use-portage-chost)
- CHECK_CHOST="yes"
- ;;
- --get-current-profile)
- if [ "${NEED_ACTION}" = "yes" ]
- then
- NEED_ACTION="no"
- DOIT="get_current_profile"
- fi
- ;;
- --get-bin-path)
- if [ "${NEED_ACTION}" = "yes" ]
- then
- NEED_ACTION="no"
- DOIT="get_bin_path"
- fi
- ;;
- --get-lib-path)
- if [ "${NEED_ACTION}" = "yes" ]
- then
- NEED_ACTION="no"
- DOIT="get_lib_path"
- fi
- ;;
- --get-stdcxx-incdir)
- if [ "${NEED_ACTION}" = "yes" ]
- then
- NEED_ACTION="no"
- DOIT="get_stdcxx_incdir"
- fi
- ;;
- *)
- if [ -z "${GCC_COMP}" ]
- then
- GCC_COMP="${x}"
- fi
- ;;
- esac
-done
-
-if [ "${DOIT}" = "switch_profile" -a -z "${GCC_COMP}" ]
-then
- usage
-fi
-
-if [ -z "${GCC_COMP}" ]
-then
- if get_current_profile &> /dev/null
- then
- GCC_COMP="$(get_current_profile)"
- else
- usage
- fi
-fi
-
-if [ ! -d /usr/lib/gcc-lib/${GCC_COMP%-*}/${GCC_COMP##*-} -o \
- ! -f /etc/env.d/gcc/${GCC_COMP} ]
-then
- usage
-fi
-
-# Chosen CHOST are not the same as the real CHOST according to make.conf,
-# and --use-portage-chost option was given, so do nothing ...
-if [ "${CHECK_CHOST}" = "yes" -a "${GCC_COMP%-*}" != "${REAL_CHOST}" ]
-then
- exit 0
-fi
-
-eval ${DOIT}
-
-
-# vim:ts=4
diff --git a/sys-devel/gcc-config/files/gcc-config-1.2.1 b/sys-devel/gcc-config/files/gcc-config-1.2.4
index 18833d0b83e8..d274bf02ace5 100644
--- a/sys-devel/gcc-config/files/gcc-config-1.2.1
+++ b/sys-devel/gcc-config/files/gcc-config-1.2.4
@@ -2,7 +2,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author: Martin Schlemmer <azarah@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.2.1,v 1.1 2002/11/27 21:45:37 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.2.4,v 1.1 2002/12/16 18:45:53 azarah Exp $
source /etc/init.d/functions.sh || {
@@ -27,6 +27,10 @@ Options:
[--get-current-profile]
Print current used gcc profile.
+
+ [--list-profiles]
+
+ Print a list of available profiles.
[--get-bin-path]
@@ -51,6 +55,23 @@ then
usage
fi
+cmd_setup() {
+
+ # Sourcing /etc/env.d/gcc/${GCC_COMP} is going to mess up
+ # PATH among things...
+ CP="$(find_path cp)"
+ RM="$(find_path rm)"
+ MV="$(find_path mv)"
+ LN="$(find_path ln)"
+ CAT="$(find_path cat)"
+ AWK="$(find_path gawk)"
+ GREP="$(find_path grep)"
+ FIND="$(find_path find)"
+ CHMOD="$(find_path chmod)"
+ TOUCH="$(find_path touch)"
+ ENV_UPDATE="$(find_path env-update)"
+}
+
find_path() {
[ -z "$1" ] && return 0
@@ -64,6 +85,16 @@ find_path() {
done
}
+gen_wrapper() {
+ ${CAT} > $1 << END
+#!/bin/sh
+
+$2 "\$@"
+END
+
+ ${CHMOD} 0755 $1
+}
+
GCC_COMP=""
REAL_CHOST="$(/usr/bin/python -c 'import portage; print portage.settings["CHOST"];')"
@@ -81,14 +112,7 @@ switch_profile() {
# Sourcing /etc/env.d/gcc/${GCC_COMP} is going to mess up
# PATH among things...
- CP="$(find_path cp)"
- RM="$(find_path rm)"
- MV="$(find_path mv)"
- LN="$(find_path ln)"
- AWK="$(find_path gawk)"
- GREP="$(find_path grep)"
- FIND="$(find_path find)"
- ENV_UPDATE="$(find_path env-update)"
+ cmd_setup
# Order our profiles to have the default first...
# We do this so that we can have them ordered with default
@@ -122,19 +146,22 @@ switch_profile() {
source /etc/env.d/gcc/${GCC_COMP}
- if [ -d /usr/include/${STDCXX_INCDIR} -a ! -L /usr/include/${STDCXX_INCDIR} ]
+ # Create /lib/cpp if missing or a symlink
+ if [ -L /lib/cpp -o ! -f /lib/cpp ]
then
- ${MV} /usr/include/${STDCXX_INCDIR} /usr/include/${STDCXX_INCDIR}.orig
- elif [ -L /usr/include/${STDCXX_INCDIR} ]
+ ${RM} -f /lib/cpp
+ gen_wrapper /lib/cpp cpp
+ fi
+ # Make sure it are not unmerged by mistake
+ ${TOUCH} /lib/cpp
+ # Create /usr/bin/cc if missing for a symlink
+ if [ -L /usr/bin/cc -o ! -f /usr/bin/cc ]
then
- ${RM} -f /usr/include/${STDCXX_INCDIR}
+ ${RM} -f /usr/bin/cc
+ gen_wrapper /usr/bin/cc gcc
fi
- ${LN} -snf ..${LDPATH/\/usr}/include/${STDCXX_INCDIR} /usr/include/${STDCXX_INCDIR}
-
- [ -L /lib/cpp -o -f /lib/cpp ] && ${RM} -f /lib/cpp
- ${LN} -snf ..${PATH}/cpp /lib/cpp
- [ -L /usr/bin/cc -o -f /usr/bin/cc ] && ${RM} -f /usr/bin/cc
- ${LN} -snf ../..${PATH}/gcc /usr/bin/cc
+ # Make sure it are not unmerged by mistake
+ ${TOUCH} /usr/bin/cc
echo "CURRENT=${GCC_COMP}" > /etc/env.d/gcc/config
@@ -167,6 +194,22 @@ get_current_profile() {
return 0
}
+list_profiles() {
+ if [ ! -f /etc/env.d/gcc/config ]
+ then
+ eerror "$0: No gcc profile is active!"
+ return 1
+ fi
+
+ for x in /etc/env.d/gcc/*
+ do
+ if [ -f ${x} -a ${x} != "/etc/env.d/gcc/config" ]
+ then
+ echo "${x##*/}"
+ fi
+ done
+}
+
get_bin_path() {
source /etc/env.d/gcc/${GCC_COMP}
@@ -215,6 +258,13 @@ do
DOIT="get_current_profile"
fi
;;
+ --list-profiles)
+ if [ "${NEED_ACTION}" = "yes" ]
+ then
+ NEED_ACTION="no"
+ DOIT="list_profiles"
+ fi
+ ;;
--get-bin-path)
if [ "${NEED_ACTION}" = "yes" ]
then
diff --git a/sys-devel/gcc-config/gcc-config-1.2.1.ebuild b/sys-devel/gcc-config/gcc-config-1.2.1.ebuild
deleted file mode 100644
index 6dd6effabb03..000000000000
--- a/sys-devel/gcc-config/gcc-config-1.2.1.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.2.1.ebuild,v 1.3 2002/12/15 10:44:23 bjb Exp $
-
-S="${WORKDIR}/${P}"
-DESCRIPTION="Utility to change the gcc compiler being used."
-SRC_URI=""
-HOMEPAGE="http://www.gentoo.org/"
-
-KEYWORDS="x86 ppc sparc alpha"
-SLOT="0"
-LICENSE="GPL-2"
-
-DEPEND="virtual/glibc"
-
-
-src_install() {
- newsbin ${FILESDIR}/${PN}-${PV} ${PN}
-}
-
diff --git a/sys-devel/gcc-config/gcc-config-1.2.2.ebuild b/sys-devel/gcc-config/gcc-config-1.2.4.ebuild
index cdc77b0742f9..82110871c08b 100644
--- a/sys-devel/gcc-config/gcc-config-1.2.2.ebuild
+++ b/sys-devel/gcc-config/gcc-config-1.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.2.2.ebuild,v 1.1 2002/12/16 04:19:05 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.2.4.ebuild,v 1.1 2002/12/16 18:45:51 azarah Exp $
S="${WORKDIR}/${P}"
DESCRIPTION="Utility to change the gcc compiler being used."
@@ -15,20 +15,8 @@ DEPEND="virtual/glibc"
src_install() {
- newsbin ${FILESDIR}/${PN}-${PV} ${PN}
- # Install wrappers .. these are shared with the gcc ebuilds
- # currently .. will remove when the new gcc have propagated ...
- if [ -L ${ROOT}/lib/cpp ]
- then
- exeinto /lib
- doexe ${FILESDIR}/cpp
- fi
- if [ -L ${ROOT}/usr/bin/cc ]
- then
- exeinto /usr/bin
- doexe ${FILESDIR}/cc
- fi
+ newsbin ${FILESDIR}/${PN}-${PV} ${PN}
}
pkg_postinst() {
@@ -52,6 +40,11 @@ pkg_postinst() {
then
rm -f ${ROOT}/usr/include/g++-v3
fi
+
+ if [ ${ROOT} = "/" ]
+ then
+ /usr/sbin/gcc-config $(/usr/sbin/gcc-config --get-current-profile)
+ fi
fi
}
diff --git a/sys-devel/gcc-config/gcc-config-1.2.ebuild b/sys-devel/gcc-config/gcc-config-1.2.ebuild
deleted file mode 100644
index 5f585d387392..000000000000
--- a/sys-devel/gcc-config/gcc-config-1.2.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.2.ebuild,v 1.3 2002/12/15 10:44:23 bjb Exp $
-
-S="${WORKDIR}/${P}"
-DESCRIPTION="Utility to change the gcc compiler being used."
-SRC_URI=""
-HOMEPAGE="http://www.gentoo.org/"
-
-KEYWORDS="x86 ppc sparc alpha"
-SLOT="0"
-LICENSE="GPL-2"
-
-DEPEND="virtual/glibc"
-
-
-src_install() {
- newsbin ${FILESDIR}/${PN}-${PV} ${PN}
-}
-