summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-06-29 11:58:05 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-06-29 11:58:05 +0000
commite907a65cecfdec47a4f3a04735e14d3656cbc0fe (patch)
tree652fef124e1f151da5d766070df13bfbf6633589 /sys-devel
parentQuote RUBY_S and sub_S as the directory could contain spaces. (diff)
downloadgentoo-2-e907a65cecfdec47a4f3a04735e14d3656cbc0fe.tar.gz
gentoo-2-e907a65cecfdec47a4f3a04735e14d3656cbc0fe.tar.bz2
gentoo-2-e907a65cecfdec47a4f3a04735e14d3656cbc0fe.zip
Fix compilation with gcc 5.1, bug #550716 (3.6 and later include the fix)
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 00F7AB331B0F097F)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog6
-rw-r--r--sys-devel/llvm/files/llvm-3.5.2-gcc-5.1.patch14
-rw-r--r--sys-devel/llvm/llvm-3.5.2.ebuild3
3 files changed, 21 insertions, 2 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 679fcfb0ada7..0cebd06170ae 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.254 2015/06/18 12:40:13 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.255 2015/06/29 11:58:05 voyageur Exp $
+
+ 29 Jun 2015; Bernard Cafarelli <voyageur@gentoo.org> llvm-3.5.2.ebuild,
+ +files/llvm-3.5.2-gcc-5.1.patch:
+ Fix compilation with gcc 5.1, bug #550716 (3.6 and later include the fix)
18 Jun 2015; Bernard Cafarelli <voyageur@gentoo.org> llvm-2.8-r2.ebuild,
llvm-2.9-r2.ebuild, metadata.xml:
diff --git a/sys-devel/llvm/files/llvm-3.5.2-gcc-5.1.patch b/sys-devel/llvm/files/llvm-3.5.2-gcc-5.1.patch
new file mode 100644
index 000000000000..7cb2817561c1
--- /dev/null
+++ b/sys-devel/llvm/files/llvm-3.5.2-gcc-5.1.patch
@@ -0,0 +1,14 @@
+Index: include/llvm/ADT/IntrusiveRefCntPtr.h
+===================================================================
+--- include/llvm/ADT/IntrusiveRefCntPtr.h (revision 218294)
++++ include/llvm/ADT/IntrusiveRefCntPtr.h (revision 218295)
+@@ -197,6 +197,9 @@
+ private:
+ void retain() { if (Obj) IntrusiveRefCntPtrInfo<T>::retain(Obj); }
+ void release() { if (Obj) IntrusiveRefCntPtrInfo<T>::release(Obj); }
++
++ template <typename X>
++ friend class IntrusiveRefCntPtr;
+ };
+
+ template<class T, class U>
diff --git a/sys-devel/llvm/llvm-3.5.2.ebuild b/sys-devel/llvm/llvm-3.5.2.ebuild
index c2408c32d3f3..0884b7b5bd3e 100644
--- a/sys-devel/llvm/llvm-3.5.2.ebuild
+++ b/sys-devel/llvm/llvm-3.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.5.2.ebuild,v 1.4 2015/05/31 14:38:44 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.5.2.ebuild,v 1.5 2015/06/29 11:58:05 voyageur Exp $
EAPI=5
@@ -147,6 +147,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-3.2-nodoctargz.patch
epatch "${FILESDIR}"/${PN}-3.5-gcc-4.9.patch
epatch "${FILESDIR}"/${PN}-3.5-gentoo-install.patch
+ epatch "${FILESDIR}"/${P}-gcc-5.1.patch
# Make ocaml warnings non-fatal, bug #537308
sed -e "/RUN/s/-warn-error A//" -i test/Bindings/Ocaml/*ml || die