summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-11-17 13:47:19 +0000
committerMark Wright <gienah@gentoo.org>2014-11-17 13:47:19 +0000
commite225bb84594e70d6d405627595eeace961bc5d00 (patch)
tree63e8d2243ea7351f29358f5c1afc1aa3b42bf276 /sys-firmware/iwl7260-ucode
parentUpdate Intel 3160 7260 bluetooth microcode (diff)
downloadgentoo-2-e225bb84594e70d6d405627595eeace961bc5d00.tar.gz
gentoo-2-e225bb84594e70d6d405627595eeace961bc5d00.tar.bz2
gentoo-2-e225bb84594e70d6d405627595eeace961bc5d00.zip
Thanks to Julian Simioni and David Flogeras for providing the update to 25.228.9.0, testing and reporting. Fixes bug 528650.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'sys-firmware/iwl7260-ucode')
-rw-r--r--sys-firmware/iwl7260-ucode/ChangeLog8
-rw-r--r--sys-firmware/iwl7260-ucode/iwl7260-ucode-25.228.9.0.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/sys-firmware/iwl7260-ucode/ChangeLog b/sys-firmware/iwl7260-ucode/ChangeLog
index 6f30dc657c2f..a6de5429ac7e 100644
--- a/sys-firmware/iwl7260-ucode/ChangeLog
+++ b/sys-firmware/iwl7260-ucode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-firmware/iwl7260-ucode
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/iwl7260-ucode/ChangeLog,v 1.6 2014/06/16 14:07:54 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/iwl7260-ucode/ChangeLog,v 1.7 2014/11/17 13:47:19 gienah Exp $
+
+*iwl7260-ucode-25.228.9.0 (17 Nov 2014)
+
+ 17 Nov 2014; Mark Wright <gienah@gentoo.org> +iwl7260-ucode-25.228.9.0.ebuild:
+ Thanks to Julian Simioni and David Flogeras for providing the update to
+ 25.228.9.0, testing and reporting. Fixes bug 528650.
*iwl7260-ucode-23.214.9.0 (16 Jun 2014)
diff --git a/sys-firmware/iwl7260-ucode/iwl7260-ucode-25.228.9.0.ebuild b/sys-firmware/iwl7260-ucode/iwl7260-ucode-25.228.9.0.ebuild
new file mode 100644
index 000000000000..ab45bd925703
--- /dev/null
+++ b/sys-firmware/iwl7260-ucode/iwl7260-ucode-25.228.9.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/iwl7260-ucode/iwl7260-ucode-25.228.9.0.ebuild,v 1.1 2014/11/17 13:47:19 gienah Exp $
+
+EAPI=5
+inherit linux-info
+
+DEV_N="${PN:3:4}"
+MY_PN="iwlwifi-${DEV_N}-ucode"
+
+DESCRIPTION="Firmware for Intel (R) Dual Band Wireless-AC ${DEV_N}"
+HOMEPAGE="http://wireless.kernel.org/en/users/Drivers/iwlwifi"
+SRC_URI="http://wireless.kernel.org/en/users/Drivers/iwlwifi?action=AttachFile&do=get&target=${MY_PN}-${PV}.tgz -> ${P}.tgz"
+
+LICENSE="ipw3945"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth"
+
+DEPEND=""
+RDEPEND="bluetooth? ( sys-firmware/iwl3160-7260-bt-ucode )
+ !sys-kernel/linux-firmware[-savedconfig]"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+CONFIG_CHECK="IWLMVM"
+ERROR_IWLMVM="CONFIG_IWLMVM is required to be enabled in /usr/src/linux/.config for the kernel to be able to load the ${DEV_N} firmware"
+
+pkg_pretend() {
+ if kernel_is lt 3 14 9; then
+ ewarn "Your kernel version is ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}."
+ ewarn "This microcode image requires a kernel >= 3.14.9."
+ ewarn "For kernel versions < 3.14.9, you may install older SLOTS"
+ fi
+}
+
+src_install() {
+ insinto /lib/firmware
+ doins "${S}/iwlwifi-${DEV_N}-9.ucode"
+ dodoc README*
+}