summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-08-20 02:47:49 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-08-20 02:47:49 +0000
commit226c7bc86733acde783e97810b4aa2e44825f4bb (patch)
tree237886a60f8f1309612eb606e7789ea1cd55eaf0 /sys-firmware
parentmask seabios 1.7.3 and update the qemu mask to be more clear (diff)
downloadgentoo-2-226c7bc86733acde783e97810b4aa2e44825f4bb.tar.gz
gentoo-2-226c7bc86733acde783e97810b4aa2e44825f4bb.tar.bz2
gentoo-2-226c7bc86733acde783e97810b4aa2e44825f4bb.zip
Add initial SeaBIOS 1.7.3
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/seabios/ChangeLog8
-rw-r--r--sys-firmware/seabios/seabios-1.7.3.ebuild93
2 files changed, 100 insertions, 1 deletions
diff --git a/sys-firmware/seabios/ChangeLog b/sys-firmware/seabios/ChangeLog
index 4b30c6379a3c..8288a96867bb 100644
--- a/sys-firmware/seabios/ChangeLog
+++ b/sys-firmware/seabios/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-firmware/seabios
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/ChangeLog,v 1.20 2013/07/28 09:27:54 jcallen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/ChangeLog,v 1.21 2013/08/20 02:47:49 cardoe Exp $
+
+*seabios-1.7.3 (20 Aug 2013)
+
+ 20 Aug 2013; Doug Goldstein <cardoe@gentoo.org> +seabios-1.7.3.ebuild,
+ seabios-1.7.2.2.ebuild:
+ Add initial SeaBIOS 1.7.3
28 Jul 2013; Jonathan Callen <jcallen@gentoo.org> seabios-1.7.2.2.ebuild:
Add missing python dependency, switch to using python-any-r1 as it is usually
diff --git a/sys-firmware/seabios/seabios-1.7.3.ebuild b/sys-firmware/seabios/seabios-1.7.3.ebuild
new file mode 100644
index 000000000000..ae41bf4da641
--- /dev/null
+++ b/sys-firmware/seabios/seabios-1.7.3.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/seabios/seabios-1.7.3.ebuild,v 1.1 2013/08/20 02:47:49 cardoe Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils toolchain-funcs python-any-r1
+
+#BACKPORTS=1
+
+# SeaBIOS maintainers don't release stable tarballs or stable binaries
+# to generate the stable tarball the following is necessary:
+# git clone git://git.seabios.org/seabios.git && cd seabios
+# git archive --output seabios-${PV}.tar.gz --prefix seabios-${PV}/ rel-${PV}
+
+if [[ ${PV} = *9999* || ! -z "${EGIT_COMMIT}" ]]; then
+ EGIT_REPO_URI="git://git.seabios.org/seabios.git"
+ inherit git-2
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
+ SRC_URI="http://code.coreboot.org/p/seabios/downloads/get/${P}.tar.gz
+ http://code.coreboot.org/p/seabios/downloads/get/bios.bin-${PV}.gz
+ http://dev.gentoo.org/~cardoe/distfiles/${P}.tar.gz
+ http://dev.gentoo.org/~cardoe/distfiles/bios.bin-${PV}.gz
+ ${BACKPORTS:+http://dev.gentoo.org/~cardoe/distfiles/${P}-${BACKPORTS}.tar.xz}"
+fi
+
+DESCRIPTION="Open Source implementation of a 16-bit x86 BIOS"
+HOMEPAGE="http://www.seabios.org"
+
+LICENSE="LGPL-3 GPL-3"
+SLOT="0"
+IUSE="+binary"
+
+REQUIRED_USE="ppc? ( binary )
+ ppc64? ( binary )"
+
+DEPEND="!binary? ( >=sys-power/iasl-20060912 )
+ ${PYTHON_DEPS}"
+RDEPEND=""
+
+pkg_pretend() {
+ if ! use binary; then
+ ewarn "You have decided to compile your own SeaBIOS. This is not"
+ ewarn "supported by upstream unless you use their recommended"
+ ewarn "toolchain (which you are not)."
+ elog
+ ewarn "If you are intending to use this build with QEMU, realize"
+ ewarn "you will not receive any support if you have compiled your"
+ ewarn "own SeaBIOS. Virtual machines subtly fail based on changes"
+ ewarn "in SeaBIOS."
+ fi
+
+ local myld=$(tc-getLD)
+
+ ${myld} -v | grep -q "GNU gold" && \
+ ewarn "gold linker unable to handle 16-bit code using ld.bfd. bug #438058"
+}
+
+src_prepare() {
+ if [[ -z "${EGIT_COMMIT}" ]]; then
+ sed -e "s/VERSION=.*/VERSION=${PV}/" \
+ -i "${S}/Makefile"
+ else
+ sed -e "s/VERSION=.*/VERSION=${PV}_pre${EGIT_COMMIT}/" \
+ -i "${S}/Makefile"
+ fi
+
+ epatch_user
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ if ! use binary ; then
+ LANG=C emake out/bios.bin
+ fi
+}
+
+src_install() {
+ insinto /usr/share/seabios
+ if ! use binary ; then
+ doins out/bios.bin
+ else
+ newins ../bios.bin-${PV} bios.bin
+ fi
+}