summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJavier Villavicencio <the_paya@gentoo.org>2009-01-22 21:01:17 +0000
committerJavier Villavicencio <the_paya@gentoo.org>2009-01-22 21:01:17 +0000
commit7a457d4f3b6b1ea49de5a2e9b839820c55088c79 (patch)
treebde11742af92f067814859e11c42d64803877ec7 /sys-freebsd/freebsd-contrib
parentImport of the 7.1 ebuilds from gentoo-bsd overlay. (diff)
downloadgentoo-2-7a457d4f3b6b1ea49de5a2e9b839820c55088c79.tar.gz
gentoo-2-7a457d4f3b6b1ea49de5a2e9b839820c55088c79.tar.bz2
gentoo-2-7a457d4f3b6b1ea49de5a2e9b839820c55088c79.zip
Import of the 7.1 ebuilds from gentoo-bsd overlay.
(Portage version: 2.2_rc23/cvs/FreeBSD i386)
Diffstat (limited to 'sys-freebsd/freebsd-contrib')
-rw-r--r--sys-freebsd/freebsd-contrib/ChangeLog10
-rw-r--r--sys-freebsd/freebsd-contrib/freebsd-contrib-7.1.ebuild56
2 files changed, 64 insertions, 2 deletions
diff --git a/sys-freebsd/freebsd-contrib/ChangeLog b/sys-freebsd/freebsd-contrib/ChangeLog
index 6bdcc865d85b..a9bd7c532ed2 100644
--- a/sys-freebsd/freebsd-contrib/ChangeLog
+++ b/sys-freebsd/freebsd-contrib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-freebsd/freebsd-contrib
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/ChangeLog,v 1.23 2007/01/15 21:34:58 drizzt Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/ChangeLog,v 1.24 2009/01/22 21:01:17 the_paya Exp $
+
+*freebsd-contrib-7.1 (22 Jan 2009)
+
+ 22 Jan 2009; Javier Villavicencio <the_paya@gentoo.org>
+ +freebsd-contrib-7.1.ebuild:
+ Import 7.1 ebuilds from gentoo-bsd overlay.
*freebsd-contrib-6.2 (15 Jan 2007)
diff --git a/sys-freebsd/freebsd-contrib/freebsd-contrib-7.1.ebuild b/sys-freebsd/freebsd-contrib/freebsd-contrib-7.1.ebuild
new file mode 100644
index 000000000000..83f399c0a15d
--- /dev/null
+++ b/sys-freebsd/freebsd-contrib/freebsd-contrib-7.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/freebsd-contrib-7.1.ebuild,v 1.1 2009/01/22 21:01:17 the_paya Exp $
+
+inherit bsdmk freebsd flag-o-matic
+
+DESCRIPTION="Contributed sources for FreeBSD."
+SLOT="0"
+KEYWORDS="~sparc-fbsd ~x86-fbsd"
+LICENSE="BSD GPL-2 as-is"
+
+IUSE=""
+
+SRC_URI="mirror://gentoo/${GNU}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+
+RDEPEND=""
+DEPEND="=sys-freebsd/freebsd-sources-${RV}*
+ =sys-freebsd/freebsd-mk-defs-${RV}*"
+
+S="${WORKDIR}/gnu"
+
+src_unpack() {
+ echo ">>> Unpacking needed parts of ${GNU}.tar.bz2 to ${WORKDIR}"
+ tar -jxpf "${DISTDIR}/${GNU}.tar.bz2" gnu/lib/libdialog gnu/usr.bin/sort gnu/usr.bin/patch
+ echo ">>> Unpacking needed parts of ${CONTRIB}.tar.bz2 to ${WORKDIR}"
+ tar -jxpf "${DISTDIR}/${CONTRIB}.tar.bz2" contrib/gnu-sort
+
+ freebsd_do_patches
+ freebsd_rename_libraries
+}
+
+src_compile() {
+ cd "${S}/lib/libdialog"
+ freebsd_src_compile
+
+ cd "${S}/usr.bin/sort"
+ freebsd_src_compile
+
+ cd "${S}/usr.bin/patch"
+ freebsd_src_compile
+}
+
+src_install() {
+ use profile || mymakeopts="${mymakeopts} NO_PROFILE= "
+ mymakeopts="${mymakeopts} NO_MANCOMPRESS= NO_INFOCOMPRESS= "
+
+ cd "${S}/lib/libdialog"
+ mkinstall || die "libdialog install failed"
+
+ cd "${S}/usr.bin/sort"
+ mkinstall DESTDIR="${D}/bin/" || die "libdialog install failed"
+
+ cd "${S}/usr.bin/patch"
+ mkinstall DESTDIR="${D}/usr/bin/" || die "libdialog install failed"
+}