summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-06-18 22:26:23 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-06-18 22:26:23 +0000
commit834ca3684bc7c2d9b9b699f0dc9a775de8ea3761 (patch)
tree491766d49351dbeab011272d8963018018509e1b /sys-freebsd
parentMake a full bootstrap only when needed for multilib. (diff)
downloadgentoo-2-834ca3684bc7c2d9b9b699f0dc9a775de8ea3761.tar.gz
gentoo-2-834ca3684bc7c2d9b9b699f0dc9a775de8ea3761.tar.bz2
gentoo-2-834ca3684bc7c2d9b9b699f0dc9a775de8ea3761.zip
Simplify a bit get_subdirs and do not treat differently USE=build/-build for non-native ABIs since we bootstrap when needed anyway.
(Portage version: 2.2.0_alpha180/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-lib/ChangeLog6
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-9.1-r8.ebuild28
2 files changed, 15 insertions, 19 deletions
diff --git a/sys-freebsd/freebsd-lib/ChangeLog b/sys-freebsd/freebsd-lib/ChangeLog
index 18e3572e6b32..2c2c21192d35 100644
--- a/sys-freebsd/freebsd-lib/ChangeLog
+++ b/sys-freebsd/freebsd-lib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-freebsd/freebsd-lib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.180 2013/06/18 22:20:51 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.181 2013/06/18 22:26:23 aballier Exp $
+
+ 18 Jun 2013; Alexis Ballier <aballier@gentoo.org> freebsd-lib-9.1-r8.ebuild:
+ Simplify a bit get_subdirs and do not treat differently USE=build/-build for
+ non-native ABIs since we bootstrap when needed anyway.
18 Jun 2013; Alexis Ballier <aballier@gentoo.org> freebsd-lib-9.1-r8.ebuild:
Make a full bootstrap only when needed for multilib.
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-9.1-r8.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-9.1-r8.ebuild
index 2659d14b897a..9eb7a6aa773c 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-9.1-r8.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-9.1-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.1-r8.ebuild,v 1.2 2013/06/18 22:20:51 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.1-r8.ebuild,v 1.3 2013/06/18 22:26:23 aballier Exp $
EAPI=5
@@ -251,9 +251,12 @@ bootstrap_libgcc() {
append-ldflags "-L${MAKEOBJDIRPREFIX}/${WORKDIR}/gnu/lib/libgcc"
}
-# What to build for a non-native build: cross-compiler, non-native abi in
-# multilib. We also need the csu but this has to be handled separately.
-NON_NATIVE_SUBDIRS="lib/libc lib/msun gnu/lib/libssp/libssp_nonshared lib/libthr lib/libutil"
+# What to build for a cross-compiler.
+# We also need the csu but this has to be handled separately.
+CROSS_SUBDIRS="lib/libc lib/msun gnu/lib/libssp/libssp_nonshared lib/libthr lib/libutil"
+
+# What to build for non-default ABIs.
+NON_NATIVE_SUBDIRS="${CROSS_SUBDIRS} gnu/lib/csu lib/libcompiler_rt gnu/lib/libgcc lib/libmd lib/libcrypt"
# Subdirs for a native build:
NATIVE_SUBDIRS="lib gnu/lib/libssp/libssp_nonshared gnu/lib/libregex gnu/lib/csu gnu/lib/libgcc"
@@ -278,27 +281,16 @@ get_subdirs() {
ret="${NATIVE_SUBDIRS}"
elif is_crosscompile ; then
# With a cross-compiler we only build the very core parts.
- ret="${NON_NATIVE_SUBDIRS}"
+ ret="${CROSS_SUBDIRS}"
if [ "${EBUILD_PHASE}" = "install" ]; then
# Add the csu dir first when installing. We treat it separately for
# compiling.
ret="$(get_csudir $(tc-arch-kernel ${CTARGET})) ${ret}"
fi
- elif use build ; then
+ else
# For the non-native ABIs we only build the csu parts and very core
# libraries for now.
- ret="gnu/lib/libssp/libssp_nonshared gnu/lib/csu"
- if [ "${EBUILD_PHASE}" = "install" ]; then
- ret="$(get_csudir $(tc-arch-kernel ${CHOST})) ${ret}"
- fi
- else
- # Finally, with a non-native ABI without USE=build, we build the most
- # important libraries.
- ret="${NON_NATIVE_SUBDIRS} gnu/lib/csu lib/libcompiler_rt gnu/lib/libgcc lib/libmd lib/libcrypt"
-
- if [ "${EBUILD_PHASE}" = "install" ]; then
- ret="$(get_csudir $(tc-arch-kernel ${CHOST})) ${ret}"
- fi
+ ret="${NON_NATIVE_SUBDIRS} $(get_csudir $(tc-arch-kernel ${CHOST}))"
fi
echo "${ret}"
}