summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-06-18 23:14:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-06-18 23:14:29 +0000
commit88d6f88c35813bde6c0844cd4101cd16714d06e4 (patch)
tree3797f55895e9f9f895f63573f1aadc08d8ff043f /sys-freebsd
parentremove freebsd-8.0 profiles (diff)
downloadgentoo-2-88d6f88c35813bde6c0844cd4101cd16714d06e4.tar.gz
gentoo-2-88d6f88c35813bde6c0844cd4101cd16714d06e4.tar.bz2
gentoo-2-88d6f88c35813bde6c0844cd4101cd16714d06e4.zip
Build libstand here so that we can drop it from freebsd-lib.
(Portage version: 2.2.0_alpha180/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/boot0/ChangeLog5
-rw-r--r--sys-freebsd/boot0/boot0-9.1.ebuild10
2 files changed, 13 insertions, 2 deletions
diff --git a/sys-freebsd/boot0/ChangeLog b/sys-freebsd/boot0/ChangeLog
index de15d779c254..6bc59cda654f 100644
--- a/sys-freebsd/boot0/ChangeLog
+++ b/sys-freebsd/boot0/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-freebsd/boot0
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/ChangeLog,v 1.40 2013/01/27 22:17:12 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/ChangeLog,v 1.41 2013/06/18 23:14:29 aballier Exp $
+
+ 18 Jun 2013; Alexis Ballier <aballier@gentoo.org> boot0-9.1.ebuild:
+ Build libstand here so that we can drop it from freebsd-lib.
27 Jan 2013; Alexis Ballier <aballier@gentoo.org> -boot0-9.1_rc1.ebuild,
-boot0-9.1_rc2.ebuild, -boot0-9.1_rc3.ebuild:
diff --git a/sys-freebsd/boot0/boot0-9.1.ebuild b/sys-freebsd/boot0/boot0-9.1.ebuild
index 26caeb75626e..dcfb6d9d5a5d 100644
--- a/sys-freebsd/boot0/boot0-9.1.ebuild
+++ b/sys-freebsd/boot0/boot0-9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/boot0-9.1.ebuild,v 1.1 2013/01/27 21:23:47 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/boot0-9.1.ebuild,v 1.2 2013/06/18 23:14:29 aballier Exp $
EAPI=2
@@ -44,6 +44,14 @@ src_prepare() {
src_compile() {
strip-flags
append-flags "-fno-strict-aliasing"
+
+ cd "${WORKDIR}/lib/libstand" || die
+ freebsd_src_compile
+
+ cd "${S}"
+ CFLAGS="${CFLAGS} -I${WORKDIR}/lib/libstand"
+ LDFLAGS="${LDFLAGS} -L${WORKDIR}/lib/libstand"
+ export LIBSTAND="${WORKDIR}/lib/libstand/libstand.a"
NOFLAGSTRIP="yes" freebsd_src_compile
}