summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-11-07 12:38:02 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-11-07 12:38:02 +0000
commit97c92f5c4487b06f8dcab6b8156052f89c2507db (patch)
treef9fd6daef80b14a1323ece97a8388cd635e91265 /sys-freebsd
parentbump to 9.0_rc1 (diff)
downloadgentoo-2-97c92f5c4487b06f8dcab6b8156052f89c2507db.tar.gz
gentoo-2-97c92f5c4487b06f8dcab6b8156052f89c2507db.tar.bz2
gentoo-2-97c92f5c4487b06f8dcab6b8156052f89c2507db.zip
bump to 9.0_rc1
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-sources/ChangeLog8
-rw-r--r--sys-freebsd/freebsd-sources/files/freebsd-sources-9.0-gentoo.patch33
-rw-r--r--sys-freebsd/freebsd-sources/freebsd-sources-9.0_rc1.ebuild103
3 files changed, 143 insertions, 1 deletions
diff --git a/sys-freebsd/freebsd-sources/ChangeLog b/sys-freebsd/freebsd-sources/ChangeLog
index 1ab9046af946..a63a854fb51d 100644
--- a/sys-freebsd/freebsd-sources/ChangeLog
+++ b/sys-freebsd/freebsd-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-freebsd/freebsd-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/ChangeLog,v 1.58 2011/07/06 06:09:18 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/ChangeLog,v 1.59 2011/11/07 12:38:02 aballier Exp $
+
+*freebsd-sources-9.0_rc1 (07 Nov 2011)
+
+ 07 Nov 2011; Alexis Ballier <aballier@gentoo.org>
+ +freebsd-sources-9.0_rc1.ebuild, +files/freebsd-sources-9.0-gentoo.patch:
+ bump to 9.0_rc1
*freebsd-sources-8.2 (06 Jul 2011)
diff --git a/sys-freebsd/freebsd-sources/files/freebsd-sources-9.0-gentoo.patch b/sys-freebsd/freebsd-sources/files/freebsd-sources-9.0-gentoo.patch
new file mode 100644
index 000000000000..840af81736a9
--- /dev/null
+++ b/sys-freebsd/freebsd-sources/files/freebsd-sources-9.0-gentoo.patch
@@ -0,0 +1,33 @@
+diff -uNr sys.old/conf/kern.mk sys/conf/kern.mk
+--- sys.old/conf/kern.mk 2011-11-02 13:02:13.000000000 +0000
++++ sys/conf/kern.mk 2011-11-02 13:05:53.000000000 +0000
+@@ -5,7 +5,7 @@
+ #
+ CWARNFLAGS?= -Wall -Wredundant-decls -Wnested-externs -Wstrict-prototypes \
+ -Wmissing-prototypes -Wpointer-arith -Winline -Wcast-qual \
+- -Wundef -Wno-pointer-sign -fformat-extensions \
++ -Wundef -Wno-pointer-sign \
+ -Wmissing-include-dirs -fdiagnostics-show-option
+ #
+ # The following flags are next up for working on:
+@@ -32,7 +32,7 @@
+ #
+ .if ${MACHINE_CPUARCH} == "i386"
+ .if ${CC:T:Mclang} != "clang"
+-CFLAGS+= -mno-align-long-strings -mpreferred-stack-boundary=2 -mno-sse
++CFLAGS+= -mpreferred-stack-boundary=2 -mno-sse
+ .else
+ CFLAGS+= -mno-aes -mno-avx
+ .endif
+diff -uNr sys.old/dev/aic7xxx/aicasm/Makefile sys/dev/aic7xxx/aicasm/Makefile
+--- sys.old/dev/aic7xxx/aicasm/Makefile 2011-11-02 13:02:11.000000000 +0000
++++ sys/dev/aic7xxx/aicasm/Makefile 2011-11-02 13:06:24.000000000 +0000
+@@ -14,7 +14,7 @@
+ SRCS= ${GENHDRS} ${CSRCS} ${YSRCS} ${LSRCS}
+ CLEANFILES+= ${GENHDRS} ${YSRCS:R:C/(.*)/\1.output/g}
+ DPADD= ${LIBL}
+-LDADD= -ll
++LDADD= -lfl
+ WARNS?= 5
+
+ # Correct path for kernel builds
diff --git a/sys-freebsd/freebsd-sources/freebsd-sources-9.0_rc1.ebuild b/sys-freebsd/freebsd-sources/freebsd-sources-9.0_rc1.ebuild
new file mode 100644
index 000000000000..81494d4bd81d
--- /dev/null
+++ b/sys-freebsd/freebsd-sources/freebsd-sources-9.0_rc1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/freebsd-sources-9.0_rc1.ebuild,v 1.1 2011/11/07 12:38:02 aballier Exp $
+
+inherit bsdmk freebsd flag-o-matic
+
+DESCRIPTION="FreeBSD kernel sources"
+SLOT="${PVR}"
+KEYWORDS="~sparc-fbsd ~x86-fbsd"
+
+IUSE="symlink"
+
+SRC_URI="mirror://gentoo/${SYS}.tar.bz2"
+
+RDEPEND=">=sys-freebsd/freebsd-mk-defs-8.0"
+DEPEND=""
+
+RESTRICT="strip binchecks"
+
+S="${WORKDIR}/sys"
+
+MY_PVR="${PVR}"
+
+[[ ${MY_PVR} == "${RV}" ]] && MY_PVR="${MY_PVR}-r0"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # This replaces the gentoover patch, it doesn't need reapply every time.
+ sed -i -e 's:^REVISION=.*:REVISION="'${PVR}'":' \
+ -e 's:^BRANCH=.*:BRANCH="Gentoo":' \
+ -e 's:^VERSION=.*:VERSION="${TYPE} ${BRANCH} ${REVISION}":' \
+ "${S}/conf/newvers.sh"
+
+ # __FreeBSD_cc_version comes from FreeBSD's gcc.
+ # on 8.2-RELEASE it's 800001.
+ sed -e "s:-D_KERNEL:-D_KERNEL -D__FreeBSD_cc_version=800001:g" \
+ -i "${S}/conf/kern.pre.mk" \
+ -i "${S}/conf/kmod.mk" || die "Couldn't set __FreeBSD_cc_version"
+
+ # Remove -Werror
+ sed -e "s:-Werror:-Wno-error:g" \
+ -i "${S}/conf/kern.pre.mk" \
+ -i "${S}/conf/kmod.mk" || die
+
+ epatch "${FILESDIR}/${PN}-9.0-gentoo.patch"
+ epatch "${FILESDIR}/${PN}-6.0-flex-2.5.31.patch"
+ sed -e 's/elf64-sparc/elf64-sparc-freebsd/g' -i "${S}/conf/ldscript.sparc64" || die
+ epatch "${FILESDIR}/${PN}-6.1-ntfs.patch"
+ epatch "${FILESDIR}/${PN}-7.1-types.h-fix.patch"
+ epatch "${FILESDIR}/${PN}-8.0-subnet-route-pr40133.patch"
+ epatch "${FILESDIR}/${PN}-7.1-includes.patch"
+
+ # By adding -DGENTOO_LIVECD to CFLAGS activate this stub
+ # vop_whiteout to tmpfs, so it can be used as an overlay
+ # unionfs filesystem over the cd9660 readonly filesystem.
+ epatch "${FILESDIR}/${PN}-7.0-tmpfs_whiteout_stub.patch"
+
+ # See http://sourceware.org/bugzilla/show_bug.cgi?id=5391
+ # ld doesn't provide symbols constructed as the __start_set_(s) ones
+ # are on FreeBSD modules.
+ # This patch adds code to generate a list of these and adds them
+ # as undefined references to ld's commandline to get them.
+ # Without this kernel modules will not load.
+ #epatch "${FILESDIR}/${PN}-7.1-binutils_link.patch"
+}
+
+src_compile() {
+ einfo "Nothing to compile.."
+}
+
+src_install() {
+ insinto "/usr/src/sys-${MY_PVR}"
+ doins -r "${S}/"*
+}
+
+pkg_postinst() {
+ if [[ ! -L "${ROOT}/usr/src/sys" ]]; then
+ einfo "/usr/src/sys symlink doesn't exist; creating symlink to sys-${MY_PVR}..."
+ ln -sf "sys-${MY_PVR}" "${ROOT}/usr/src/sys" || \
+ eerror "Couldn't create ${ROOT}/usr/src/sys symlink."
+ # just in case...
+ [[ -L ""${ROOT}/usr/src/sys-${RV}"" ]] && rm "${ROOT}/usr/src/sys-${RV}"
+ ln -sf "sys-${MY_PVR}" "${ROOT}/usr/src/sys-${RV}" || \
+ eerror "Couldn't create ${ROOT}/usr/src/sys-${RV} symlink."
+ elif use symlink; then
+ einfo "Updating /usr/src/sys symlink to sys-${MY_PVR}..."
+ rm "${ROOT}/usr/src/sys" "${ROOT}/usr/src/sys-${RV}" || \
+ eerror "Couldn't remove previous symlinks, please fix manually."
+ ln -sf "sys-${MY_PVR}" "${ROOT}/usr/src/sys" || \
+ eerror "Couldn't create ${ROOT}/usr/src/sys symlink."
+ ln -sf "sys-${MY_PVR}" "${ROOT}/usr/src/sys-${RV}" || \
+ eerror "Couldn't create ${ROOT}/usr/src/sys-${RV} symlink."
+ fi
+
+ if use sparc-fbsd ; then
+ ewarn "WARNING: kldload currently causes kernel panics"
+ ewarn "on sparc64. This is probably a gcc-4.1 issue, but"
+ ewarn "we need gcc-4.1 to compile the kernel correctly :/"
+ ewarn "Please compile all modules you need into the kernel"
+ fi
+}