summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-26 20:42:14 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-26 20:42:14 +0000
commitaf6e7a4207880d02e02788274678ffbb200f0c6e (patch)
treeb46fd753669a4def67fe4b91019c00c12724ad3c /sys-freebsd
parentbump to rc3 (diff)
downloadgentoo-2-af6e7a4207880d02e02788274678ffbb200f0c6e.tar.gz
gentoo-2-af6e7a4207880d02e02788274678ffbb200f0c6e.tar.bz2
gentoo-2-af6e7a4207880d02e02788274678ffbb200f0c6e.zip
bump to rc3
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-contrib/ChangeLog8
-rw-r--r--sys-freebsd/freebsd-contrib/freebsd-contrib-9.2_rc3.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/sys-freebsd/freebsd-contrib/ChangeLog b/sys-freebsd/freebsd-contrib/ChangeLog
index 343dce9d6d2e..e9a05a455df3 100644
--- a/sys-freebsd/freebsd-contrib/ChangeLog
+++ b/sys-freebsd/freebsd-contrib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-freebsd/freebsd-contrib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/ChangeLog,v 1.47 2013/08/22 15:43:58 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/ChangeLog,v 1.48 2013/08/26 20:42:14 aballier Exp $
+
+*freebsd-contrib-9.2_rc3 (26 Aug 2013)
+
+ 26 Aug 2013; Alexis Ballier <aballier@gentoo.org>
+ +freebsd-contrib-9.2_rc3.ebuild:
+ bump to rc3
*freebsd-contrib-9.2_rc2 (22 Aug 2013)
diff --git a/sys-freebsd/freebsd-contrib/freebsd-contrib-9.2_rc3.ebuild b/sys-freebsd/freebsd-contrib/freebsd-contrib-9.2_rc3.ebuild
new file mode 100644
index 000000000000..330df2fe2aa9
--- /dev/null
+++ b/sys-freebsd/freebsd-contrib/freebsd-contrib-9.2_rc3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/freebsd-contrib-9.2_rc3.ebuild,v 1.1 2013/08/26 20:42:14 aballier Exp $
+
+inherit bsdmk freebsd flag-o-matic multilib
+
+DESCRIPTION="Contributed sources for FreeBSD."
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+ SRC_URI="mirror://gentoo/${GNU}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+fi
+LICENSE="BSD GPL-2+ libodialog"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="=sys-freebsd/freebsd-sources-${RV}*
+ =sys-freebsd/freebsd-mk-defs-${RV}*"
+
+S="${WORKDIR}/gnu"
+
+src_compile() {
+ cd "${S}/lib/libodialog"
+ freebsd_src_compile
+
+ cd "${S}/usr.bin/sort"
+ freebsd_src_compile
+
+ cd "${S}/usr.bin/patch"
+ freebsd_src_compile
+}
+
+src_install() {
+ use profile || mymakeopts="${mymakeopts} NO_PROFILE= "
+ mymakeopts="${mymakeopts} NO_MANCOMPRESS= NO_INFOCOMPRESS= "
+
+ cd "${S}/lib/libodialog"
+ mkinstall LIBDIR="/usr/$(get_libdir)" || die "libodialog install failed"
+
+ cd "${S}/usr.bin/sort"
+ mkinstall BINDIR="/bin/" || die "sort install failed"
+
+ cd "${S}/usr.bin/patch"
+ mkinstall BINDIR="/usr/bin/" || die "patch install failed"
+}