summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-14 09:17:22 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-14 09:17:22 +0000
commit917695ac174468f2048c937ec62854718f820f7d (patch)
tree69309ce367f6ec0b286d145b833811e398442618 /sys-fs/aufs-util
parent[sys-cluster/ceph] Version bump (diff)
downloadgentoo-2-917695ac174468f2048c937ec62854718f820f7d.tar.gz
gentoo-2-917695ac174468f2048c937ec62854718f820f7d.tar.bz2
gentoo-2-917695ac174468f2048c937ec62854718f820f7d.zip
sys-fs/aufs-util: Version Bump
(Portage version: 2.2.0_alpha151/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sys-fs/aufs-util')
-rw-r--r--sys-fs/aufs-util/ChangeLog10
-rw-r--r--sys-fs/aufs-util/aufs-util-3.6.ebuild6
-rw-r--r--sys-fs/aufs-util/aufs-util-3.7.ebuild45
3 files changed, 56 insertions, 5 deletions
diff --git a/sys-fs/aufs-util/ChangeLog b/sys-fs/aufs-util/ChangeLog
index fb2760e52456..02c8134b2e92 100644
--- a/sys-fs/aufs-util/ChangeLog
+++ b/sys-fs/aufs-util/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/aufs-util
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs-util/ChangeLog,v 1.4 2012/12/21 09:19:28 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs-util/ChangeLog,v 1.5 2013/01/14 09:17:22 jlec Exp $
+
+*aufs-util-3.7 (14 Jan 2013)
+
+ 14 Jan 2013; Justin Lecher <jlec@gentoo.org> aufs-util-3.6.ebuild,
+ +aufs-util-3.7.ebuild:
+ Version Bump
21 Dec 2012; Justin Lecher <jlec@gentoo.org> aufs-util-3.6.ebuild:
Add it kernel back
diff --git a/sys-fs/aufs-util/aufs-util-3.6.ebuild b/sys-fs/aufs-util/aufs-util-3.6.ebuild
index 6d23a3dbf649..236c60888a7b 100644
--- a/sys-fs/aufs-util/aufs-util-3.6.ebuild
+++ b/sys-fs/aufs-util/aufs-util-3.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs-util/aufs-util-3.6.ebuild,v 1.4 2012/12/21 09:19:28 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs-util/aufs-util-3.6.ebuild,v 1.5 2013/01/14 09:17:22 jlec Exp $
EAPI=5
@@ -11,7 +11,7 @@ HOMEPAGE="http://aufs.sourceforge.net/"
SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
# git archive -v --prefix=aufs-util-3.6/ \
# --remote=git://aufs.git.sourceforge.net/gitroot/aufs/aufs-util.git aufs3.0 \
-# -o aufs-util-3.6.tar.xz
+# -o aufs-util-3.6.tar && xz -ve9 aufs-util-3.6.tar
SLOT="0"
LICENSE="GPL-2"
diff --git a/sys-fs/aufs-util/aufs-util-3.7.ebuild b/sys-fs/aufs-util/aufs-util-3.7.ebuild
new file mode 100644
index 000000000000..f45e4a53b495
--- /dev/null
+++ b/sys-fs/aufs-util/aufs-util-3.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs-util/aufs-util-3.7.ebuild,v 1.1 2013/01/14 09:17:22 jlec Exp $
+
+EAPI=5
+
+inherit flag-o-matic linux-info multilib toolchain-funcs
+
+DESCRIPTION="Utilities are always necessary for aufs"
+HOMEPAGE="http://aufs.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+# git archive -v --prefix=aufs-util-3.7/ \
+# --remote=git://aufs.git.sourceforge.net/gitroot/aufs/aufs-util.git aufs3.0 \
+# -o aufs-util-3.7.tar && xz -ve9 aufs-util-3.7.tar
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ !sys-fs/aufs2
+ !sys-fs/aufs3
+ sys-kernel/aufs-sources"
+DEPEND="${RDEPEND}"
+
+CONFIG_CHECK="~AUFS_FS"
+ERROR_AUFS_FS="In order to mount aufs you need to enable CONFIG_AUFS_FS in your kernel"
+
+src_prepare() {
+ [[ -e "${KERNEL_DIR}"/include/uapi/linux/aufs_type.h ]] || \
+ die "Please select aufs-sources before building ${PN}"
+ append-cppflags -I"${KERNEL_DIR}/include"
+ sed \
+ -e "/LDFLAGS += -static -s/d" \
+ -e "/CFLAGS/s:-O::g" \
+ -i Makefile || die
+ sed \
+ -e "s:m 644 -s:m 644:g" \
+ -e "s:/usr/lib:/usr/$(get_libdir):g" \
+ -i libau/Makefile || die
+
+ tc-export CC AR
+ export HOSTCC=$(tc-getCC)
+}