summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-16 11:46:40 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-16 11:46:40 +0000
commit3f6edd4635e581053b74defe50f18e636ac6daa2 (patch)
tree4e819156a828233d80d7baefa6d3740ddbeddda5 /sys-fs/aufs3
parentsci-chemistry/ccpn: Todays python patches; fix for generic tcl/tk; drop unuse... (diff)
downloadgentoo-2-3f6edd4635e581053b74defe50f18e636ac6daa2.tar.gz
gentoo-2-3f6edd4635e581053b74defe50f18e636ac6daa2.tar.bz2
gentoo-2-3f6edd4635e581053b74defe50f18e636ac6daa2.zip
sys-fs/aufs3: Include suggestion made by Chema Alonso (nimiux), #451988
(Portage version: 2.2.0_alpha153/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sys-fs/aufs3')
-rw-r--r--sys-fs/aufs3/ChangeLog6
-rw-r--r--sys-fs/aufs3/aufs3-3_p20121210.ebuild12
-rw-r--r--sys-fs/aufs3/aufs3-3_p20130107.ebuild12
-rw-r--r--sys-fs/aufs3/aufs3-3_p20130114.ebuild12
4 files changed, 23 insertions, 19 deletions
diff --git a/sys-fs/aufs3/ChangeLog b/sys-fs/aufs3/ChangeLog
index 7c91a16e1e86..c2793ccd22cc 100644
--- a/sys-fs/aufs3/ChangeLog
+++ b/sys-fs/aufs3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/aufs3
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/ChangeLog,v 1.46 2013/01/16 09:29:32 nimiux Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/ChangeLog,v 1.47 2013/01/16 11:46:40 jlec Exp $
+
+ 16 Jan 2013; Justin Lecher <jlec@gentoo.org> aufs3-3_p20121210.ebuild,
+ aufs3-3_p20130107.ebuild, aufs3-3_p20130114.ebuild:
+ Include suggestion made by Chema Alonso (nimiux), #451988
16 Jan 2013; Chema Alonso <nimiux@gentoo.org> aufs3-3_p20121210.ebuild:
Marked stable for amd64 wrt bug #451988
diff --git a/sys-fs/aufs3/aufs3-3_p20121210.ebuild b/sys-fs/aufs3/aufs3-3_p20121210.ebuild
index 1664c759d53c..bf4b15baa8b3 100644
--- a/sys-fs/aufs3/aufs3-3_p20121210.ebuild
+++ b/sys-fs/aufs3/aufs3-3_p20121210.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/aufs3-3_p20121210.ebuild,v 1.3 2013/01/16 09:29:32 nimiux Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/aufs3-3_p20121210.ebuild,v 1.4 2013/01/16 11:46:40 jlec Exp $
EAPI=4
-inherit eutils flag-o-matic linux-mod multilib toolchain-funcs
+inherit eutils flag-o-matic linux-info linux-mod multilib toolchain-funcs
AUFS_VERSION="${PV%%_p*}"
# highest branch version
@@ -21,7 +21,7 @@ SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~x86"
-IUSE="debug doc fuse pax_kernel hfs inotify kernel-patch nfs ramfs"
+IUSE="debug doc fuse hfs inotify kernel-patch nfs pax_kernel ramfs"
DEPEND="dev-vcs/git"
RDEPEND="
@@ -116,7 +116,7 @@ src_prepare() {
sed -i "s:aufs.ko usr/include/linux/aufs_type.h:aufs.ko:g" Makefile || die
sed -i "s:__user::g" include/linux/aufs_type.h || die
- cd "${WORKDIR}"/${P}/${PN/3}-util
+ cd "${WORKDIR}"/${P}/${PN/3}-util || die
einfo "Using for utils building branch ${util_branch}"
git checkout -b local-gentoo ${util_branch} || die
@@ -129,7 +129,7 @@ src_compile() {
emake CC=$(tc-getCC) LD=$(tc-getLD) LDFLAGS="$(raw-ldflags)" ARCH=$(tc-arch-kernel) CONFIG_AUFS_FS=m KDIR=${KV_OUT_DIR}
- cd "${WORKDIR}"/${P}/${PN/3}-util
+ cd "${WORKDIR}"/${P}/${PN/3}-util || die
emake CC=$(tc-getCC) AR=$(tc-getAR) KDIR=${KV_OUT_DIR} C_INCLUDE_PATH="${S}"/include
}
@@ -142,7 +142,7 @@ src_install() {
dodoc Documentation/filesystems/aufs/README
- cd "${WORKDIR}"/${P}/${PN/3}-util
+ cd "${WORKDIR}"/${P}/${PN/3}-util || die
emake DESTDIR="${D}" KDIR=${KV_OUT_DIR} install
newdoc README README-utils
diff --git a/sys-fs/aufs3/aufs3-3_p20130107.ebuild b/sys-fs/aufs3/aufs3-3_p20130107.ebuild
index 95c113247360..8ecb2521637a 100644
--- a/sys-fs/aufs3/aufs3-3_p20130107.ebuild
+++ b/sys-fs/aufs3/aufs3-3_p20130107.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/aufs3-3_p20130107.ebuild,v 1.3 2013/01/12 15:19:03 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/aufs3-3_p20130107.ebuild,v 1.4 2013/01/16 11:46:40 jlec Exp $
EAPI=4
-inherit eutils flag-o-matic linux-mod multilib toolchain-funcs
+inherit eutils flag-o-matic linux-info linux-mod multilib toolchain-funcs
AUFS_VERSION="${PV%%_p*}"
# highest branch version
@@ -21,7 +21,7 @@ SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug doc fuse pax_kernel hfs inotify kernel-patch nfs ramfs"
+IUSE="debug doc fuse hfs inotify kernel-patch nfs pax_kernel ramfs"
DEPEND="dev-vcs/git"
RDEPEND="
@@ -120,7 +120,7 @@ src_prepare() {
sed -i "s:__user::g" include/uapi/linux/aufs_type.h || die
fi
- cd "${WORKDIR}"/${P}/${PN/3}-util
+ cd "${WORKDIR}"/${P}/${PN/3}-util || die
einfo "Using for utils building branch ${util_branch}"
git checkout -b local-gentoo ${util_branch} || die
@@ -133,7 +133,7 @@ src_compile() {
emake CC=$(tc-getCC) LD=$(tc-getLD) LDFLAGS="$(raw-ldflags)" ARCH=$(tc-arch-kernel) CONFIG_AUFS_FS=m KDIR=${KV_OUT_DIR}
- cd "${WORKDIR}"/${P}/${PN/3}-util
+ cd "${WORKDIR}"/${P}/${PN/3}-util || die
emake CC=$(tc-getCC) AR=$(tc-getAR) KDIR=${KV_OUT_DIR} C_INCLUDE_PATH="${S}"/include
}
@@ -146,7 +146,7 @@ src_install() {
dodoc Documentation/filesystems/aufs/README
- cd "${WORKDIR}"/${P}/${PN/3}-util
+ cd "${WORKDIR}"/${P}/${PN/3}-util || die
emake DESTDIR="${D}" KDIR=${KV_OUT_DIR} install
newdoc README README-utils
diff --git a/sys-fs/aufs3/aufs3-3_p20130114.ebuild b/sys-fs/aufs3/aufs3-3_p20130114.ebuild
index 337f3c3b2428..db8d5e782793 100644
--- a/sys-fs/aufs3/aufs3-3_p20130114.ebuild
+++ b/sys-fs/aufs3/aufs3-3_p20130114.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/aufs3-3_p20130114.ebuild,v 1.1 2013/01/14 08:55:06 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/aufs3-3_p20130114.ebuild,v 1.2 2013/01/16 11:46:40 jlec Exp $
EAPI=5
-inherit eutils flag-o-matic linux-mod multilib toolchain-funcs
+inherit eutils flag-o-matic linux-info linux-mod multilib toolchain-funcs
AUFS_VERSION="${PV%%_p*}"
# highest branch version
@@ -21,7 +21,7 @@ SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug doc fuse pax_kernel hfs inotify kernel-patch nfs ramfs"
+IUSE="debug doc fuse hfs inotify kernel-patch nfs pax_kernel ramfs"
DEPEND="
dev-util/patchutils
@@ -126,7 +126,7 @@ src_prepare() {
sed -i "s:__user::g" include/uapi/linux/aufs_type.h || die
fi
- cd "${WORKDIR}"/${P}/${PN/3}-util
+ cd "${WORKDIR}"/${P}/${PN/3}-util || die
einfo "Using for utils building branch ${util_branch}"
git checkout -b local-gentoo ${util_branch} || die
@@ -139,7 +139,7 @@ src_compile() {
emake CC=$(tc-getCC) LD=$(tc-getLD) LDFLAGS="$(raw-ldflags)" ARCH=$(tc-arch-kernel) CONFIG_AUFS_FS=m KDIR=${KV_OUT_DIR}
- cd "${WORKDIR}"/${P}/${PN/3}-util
+ cd "${WORKDIR}"/${P}/${PN/3}-util || die
emake CC=$(tc-getCC) AR=$(tc-getAR) KDIR=${KV_OUT_DIR} C_INCLUDE_PATH="${S}"/include
}
@@ -154,7 +154,7 @@ src_install() {
dodoc Documentation/filesystems/aufs/README
- cd "${WORKDIR}"/${P}/${PN/3}-util
+ cd "${WORKDIR}"/${P}/${PN/3}-util || die
emake DESTDIR="${D}" KDIR=${KV_OUT_DIR} install
newdoc README README-utils