summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Peterson <lavajoe@gentoo.org>2009-04-17 15:16:51 +0000
committerJoe Peterson <lavajoe@gentoo.org>2009-04-17 15:16:51 +0000
commit031fc0171f020596466ac8eca17842bb7b2b47d3 (patch)
treefdab120d47fb13b9163c1b06140970ca54858d4b /sys-fs/btrfs
parentFix bug 266497 (diff)
downloadgentoo-2-031fc0171f020596466ac8eca17842bb7b2b47d3.tar.gz
gentoo-2-031fc0171f020596466ac8eca17842bb7b2b47d3.tar.bz2
gentoo-2-031fc0171f020596466ac8eca17842bb7b2b47d3.zip
Add version 0.17 for kernels later than 2.6.27 (contributed by David ____); minor fixes
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/btrfs')
-rw-r--r--sys-fs/btrfs/ChangeLog9
-rw-r--r--sys-fs/btrfs/btrfs-0.16-r2.ebuild8
-rw-r--r--sys-fs/btrfs/btrfs-0.17.ebuild67
-rw-r--r--sys-fs/btrfs/btrfs-9999.ebuild6
4 files changed, 82 insertions, 8 deletions
diff --git a/sys-fs/btrfs/ChangeLog b/sys-fs/btrfs/ChangeLog
index c65f3e2e34ab..197d22ae15f8 100644
--- a/sys-fs/btrfs/ChangeLog
+++ b/sys-fs/btrfs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/btrfs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs/ChangeLog,v 1.18 2009/02/24 05:41:09 lavajoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs/ChangeLog,v 1.19 2009/04/17 15:16:51 lavajoe Exp $
+
+*btrfs-0.17 (17 Apr 2009)
+
+ 17 Apr 2009; Joe Peterson <lavajoe@gentoo.org> btrfs-0.16-r2.ebuild,
+ +btrfs-0.17.ebuild, btrfs-9999.ebuild:
+ Add version 0.17 for kernels later than 2.6.27 (contributed by David
+ ____); minor fixes
24 Feb 2009; Joe Peterson <lavajoe@gentoo.org> btrfs-0.16-r2.ebuild:
Do not allow 0.16 to build on kernels beyond 2.6.27; bug #259341
diff --git a/sys-fs/btrfs/btrfs-0.16-r2.ebuild b/sys-fs/btrfs/btrfs-0.16-r2.ebuild
index ab0bf7e59f0b..78306ca850fa 100644
--- a/sys-fs/btrfs/btrfs-0.16-r2.ebuild
+++ b/sys-fs/btrfs/btrfs-0.16-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs/btrfs-0.16-r2.ebuild,v 1.3 2009/02/24 05:41:09 lavajoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs/btrfs-0.16-r2.ebuild,v 1.4 2009/04/17 15:16:51 lavajoe Exp $
inherit eutils linux-mod
@@ -23,7 +23,7 @@ pkg_setup()
BUILD_TARGETS="all"
BUILD_PARAMS="KERNELDIR=${KV_OUT_DIR}"
- MODULE_NAMES="btrfs(fs:${S}/"
+ MODULE_NAMES="btrfs(fs:${S})"
if ! kernel_is 2 6; then
eerror "Need a 2.6 kernel to compile against!"
@@ -31,8 +31,8 @@ pkg_setup()
fi
if kernel_is gt 2 6 27; then
- eerror "Not compatible with kernels beyond 2.6.27 - use in-kernel version!"
- die "Not compatible with kernels beyond 2.6.27 - use in-kernel version!"
+ eerror "Not compatible with kernels beyond 2.6.27."
+ die "Not compatible with kernels beyond 2.6.27."
fi
if ! linux_chkconfig_present LIBCRC32C; then
diff --git a/sys-fs/btrfs/btrfs-0.17.ebuild b/sys-fs/btrfs/btrfs-0.17.ebuild
new file mode 100644
index 000000000000..5aa78f0ee857
--- /dev/null
+++ b/sys-fs/btrfs/btrfs-0.17.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs/btrfs-0.17.ebuild,v 1.1 2009/04/17 15:16:51 lavajoe Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="A checksumming copy-on-write filesystem"
+HOMEPAGE="http://btrfs.wiki.kernel.org/"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/people/mason/btrfs/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+pkg_setup()
+{
+ linux-mod_pkg_setup
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KERNELDIR=${KV_OUT_DIR}"
+ MODULE_NAMES="btrfs(fs:${S})"
+
+ if ! kernel_is 2 6; then
+ eerror "Need a 2.6 kernel to compile against!"
+ die "Need a 2.6 kernel to compile against!"
+ fi
+
+ if kernel_is lt 2 6 28; then
+ eerror "Not compatible with kernels earlier than 2.6.28."
+ die "Not compatible with kernels earlier than 2.6.28."
+ fi
+
+ if ! linux_chkconfig_present LIBCRC32C; then
+ eerror "You need to enable LIBCRC32C in your kernel!"
+ die "You need to enable LIBCRC32C in your kernel!"
+ fi
+
+ if ! linux_chkconfig_present ZLIB_INFLATE; then
+ eerror "You need to enable ZLIB_INFLATE in your kernel!"
+ die "You need to enable ZLIB_INFLATE in your kernel!"
+ fi
+
+ if ! linux_chkconfig_present ZLIB_DEFLATE; then
+ eerror "You need to enable ZLIB_DEFLATE in your kernel!"
+ die "You need to enable ZLIB_DEFLATE in your kernel!"
+ fi
+
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ ewarn "WARNING: Btrfs is under heavy development and is not suitable for"
+ ewarn " any uses other than benchmarking and review."
+ ewarn " The Btrfs disk format is not yet finalized."
+ ewarn
+ ewarn " Also, it is highly recommended that the versions of"
+ ewarn " btrfs and btrfs-progs match."
+ ewarn
+ ewarn "Note: THE DISK FORMAT HAS CHANGED!"
+ ewarn " You must backup your data and re-create your btrfs"
+ ewarn " filesystem(s) for use with this version."
+}
diff --git a/sys-fs/btrfs/btrfs-9999.ebuild b/sys-fs/btrfs/btrfs-9999.ebuild
index 47e79e15aa0c..be5ca855a13f 100644
--- a/sys-fs/btrfs/btrfs-9999.ebuild
+++ b/sys-fs/btrfs/btrfs-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs/btrfs-9999.ebuild,v 1.7 2008/12/12 09:58:53 lavajoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs/btrfs-9999.ebuild,v 1.8 2009/04/17 15:16:51 lavajoe Exp $
inherit eutils linux-mod git
@@ -25,7 +25,7 @@ pkg_setup()
BUILD_TARGETS="all"
BUILD_PARAMS="KERNELDIR=${KV_OUT_DIR}"
- MODULE_NAMES="btrfs(fs:${S}/"
+ MODULE_NAMES="btrfs(fs:${S})"
if ! kernel_is gt 2 6 26; then
eerror "Need a >=2.6.27 kernel to compile against!"