summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-02-28 18:23:51 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-02-28 18:23:51 +0000
commitf7f5c7905753db6800661ca8b6caa37f3204783e (patch)
tree34a32d64291dd9958a1dc74f667b7339b6e0c0eb /sys-fs/dazuko
parentversion bump, security bug 165555 (diff)
downloadgentoo-2-f7f5c7905753db6800661ca8b6caa37f3204783e.tar.gz
gentoo-2-f7f5c7905753db6800661ca8b6caa37f3204783e.tar.bz2
gentoo-2-f7f5c7905753db6800661ca8b6caa37f3204783e.zip
Version bump
(Portage version: 2.1.2-r12)
Diffstat (limited to 'sys-fs/dazuko')
-rw-r--r--sys-fs/dazuko/ChangeLog7
-rw-r--r--sys-fs/dazuko/dazuko-2.3.3_pre2.ebuild94
-rw-r--r--sys-fs/dazuko/files/digest-dazuko-2.3.3_pre23
3 files changed, 103 insertions, 1 deletions
diff --git a/sys-fs/dazuko/ChangeLog b/sys-fs/dazuko/ChangeLog
index 1cf7b4382e28..027a7f191700 100644
--- a/sys-fs/dazuko/ChangeLog
+++ b/sys-fs/dazuko/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/dazuko
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.22 2007/02/23 16:40:31 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.23 2007/02/28 18:23:51 alonbl Exp $
+
+*dazuko-2.3.3_pre2 (28 Feb 2007)
+
+ 28 Feb 2007; Alon Bar-Lev <alonbl@gentoo.org> +dazuko-2.3.3_pre2.ebuild:
+ Version bump
*dazuko-2.3.3_pre1-r1 (23 Feb 2007)
*dazuko-2.3.2-r4 (23 Feb 2007)
diff --git a/sys-fs/dazuko/dazuko-2.3.3_pre2.ebuild b/sys-fs/dazuko/dazuko-2.3.3_pre2.ebuild
new file mode 100644
index 000000000000..22e830fdd306
--- /dev/null
+++ b/sys-fs/dazuko/dazuko-2.3.3_pre2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.3.3_pre2.ebuild,v 1.1 2007/02/28 18:23:51 alonbl Exp $
+
+inherit linux-mod toolchain-funcs flag-o-matic
+
+DESCRIPTION="Linux kernel module and interface providing file access control"
+MY_P="${P/_/-}" # for -preN versions
+SRC_URI="http://www.dazuko.org/files/${MY_P}.tar.gz"
+HOMEPAGE="http://www.dazuko.org"
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND="kernel_linux? ( >=virtual/linux-sources-2.2 )"
+RDEPEND=${DEPEND}
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ [ "${KERNEL}" = "linux" ] && linux-mod_pkg_setup
+ # kernel settings
+ if [ "${KERNEL}" = "linux" ] && kernel_is le 2 4; then
+ BUILD_TARGETS="all"
+ else
+ CONFIG_CHECK="SECURITY_CAPABILITIES"
+ BUILD_TARGETS="dummy_rule"
+ fi
+ MODULE_NAMES="dazuko(misc:)"
+}
+
+src_compile() {
+ if [ "${KERNEL}" = "FreeBSD" ]; then
+ KERNEL_DIR=/usr/src/sys
+ KBUILD_OUTPUT=/boot/modules
+ MAKE=make
+ fi
+ ./configure \
+ --without-dep \
+ --disable-local-dpath \
+ --disable-chroot-support \
+ --kernelsrcdir="${KERNEL_DIR}" \
+ --kernelobjdir="${KBUILD_OUTPUT}" \
+ || die "configure failed"
+
+ if [ "${KERNEL}" = "linux" ]; then
+ convert_to_m Makefile
+ linux-mod_src_compile
+ else
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" LDFLAGS="$(raw-ldflags)" || die
+ fi
+
+ emake -C library CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ if [ "${KERNEL}" = "linux" ]; then
+ linux-mod_src_install
+ else
+ insinto /boot/modules
+ doins "${S}"/dazuko.kld
+ exeinto /boot/modules
+ doexe "${S}"/dazuko.ko
+ fi
+
+ dolib.a library/libdazuko.a
+ insinto /usr/include
+ doins dazukoio.h
+ doins dazuko_events.h
+
+ dodoc COPYING
+ dodoc README
+ dodoc README.linux26
+ dodoc README.trusted
+}
+
+src_test() {
+ if [ "${EUID}" != 0 ]; then
+ ewarn "Cannot test while not root"
+ else
+ emake test || die "Test failed"
+ fi
+}
+
+pkg_postinst() {
+ [ "${KERNEL}" = "linux" ] && linux-mod_pkg_postinst
+
+ einfo "Please note that chroot support is disabled due to incompatability "
+ einfo "with SMP kernels"
+}
+
+pkg_postrm() {
+ [ "${KERNEL}" = "linux" ] && linux-mod_pkg_postrm
+}
+
diff --git a/sys-fs/dazuko/files/digest-dazuko-2.3.3_pre2 b/sys-fs/dazuko/files/digest-dazuko-2.3.3_pre2
new file mode 100644
index 000000000000..989da646cb3b
--- /dev/null
+++ b/sys-fs/dazuko/files/digest-dazuko-2.3.3_pre2
@@ -0,0 +1,3 @@
+MD5 76b5fafa29137f58f291ac3ee097a4db dazuko-2.3.3-pre2.tar.gz 181599
+RMD160 a5e931af5d0b871625d80306817c66abfc635f76 dazuko-2.3.3-pre2.tar.gz 181599
+SHA256 dfc303818ef224139b548fd47a37e72c24ee2562f16aacfa9f0db6a65285fce4 dazuko-2.3.3-pre2.tar.gz 181599