summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2008-12-30 18:27:48 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2008-12-30 18:27:48 +0000
commit0f73b192d6c7b6bfaf213847c54834c1dd343ef8 (patch)
tree108b500e027c1a0998897855466752f5e36b15f3 /sys-fs/ddrescue
parentQA: Respect CFLAGS and CC (bug 243552) (diff)
downloadgentoo-2-0f73b192d6c7b6bfaf213847c54834c1dd343ef8.tar.gz
gentoo-2-0f73b192d6c7b6bfaf213847c54834c1dd343ef8.tar.bz2
gentoo-2-0f73b192d6c7b6bfaf213847c54834c1dd343ef8.zip
Version bump.
(Portage version: 2.2_rc19/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'sys-fs/ddrescue')
-rw-r--r--sys-fs/ddrescue/ChangeLog7
-rw-r--r--sys-fs/ddrescue/ddrescue-1.9.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/sys-fs/ddrescue/ChangeLog b/sys-fs/ddrescue/ChangeLog
index 18b7d79b8e9b..e2329723b5a8 100644
--- a/sys-fs/ddrescue/ChangeLog
+++ b/sys-fs/ddrescue/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/ddrescue
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ChangeLog,v 1.12 2008/04/21 18:21:11 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ChangeLog,v 1.13 2008/12/30 18:27:48 coldwind Exp $
+
+*ddrescue-1.9 (30 Dec 2008)
+
+ 30 Dec 2008; Santiago M. Mola <coldwind@gentoo.org> +ddrescue-1.9.ebuild:
+ Version bump.
21 Apr 2008; Raúl Porcel <armin76@gentoo.org> -ddrescue-1.6.ebuild,
ddrescue-1.8.ebuild:
diff --git a/sys-fs/ddrescue/ddrescue-1.9.ebuild b/sys-fs/ddrescue/ddrescue-1.9.ebuild
new file mode 100644
index 000000000000..bb251e9227de
--- /dev/null
+++ b/sys-fs/ddrescue/ddrescue-1.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ddrescue-1.9.ebuild,v 1.1 2008/12/30 18:27:48 coldwind Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Copies data from one file or block device (hard disk, cdrom, etc) to another, trying hard to rescue data in case of read errors"
+HOMEPAGE="http://www.gnu.org/software/ddrescue/ddrescue.html"
+SRC_URI="http://savannah.gnu.org/download/ddrescue/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+
+src_compile() {
+ # not a normal configure script
+ ./configure \
+ --prefix=/usr \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-man || die "make install failed"
+ dodoc ChangeLog INSTALL README NEWS AUTHORS TODO
+}