summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-11-24 01:28:54 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-11-24 01:28:54 +0000
commitb8ea4cec365c2e1227fa6deb6c9efc69d72c37ad (patch)
tree686123b3386240a1af978d9fd1d0762480edb702 /sys-fs/fuse
parentFix runtime issues with --as-needed and wxWidgets interface as reported by An... (diff)
downloadgentoo-2-b8ea4cec365c2e1227fa6deb6c9efc69d72c37ad.tar.gz
gentoo-2-b8ea4cec365c2e1227fa6deb6c9efc69d72c37ad.tar.bz2
gentoo-2-b8ea4cec365c2e1227fa6deb6c9efc69d72c37ad.zip
Add patch to avoid listing the same function in two versions to (partially) fix build with gold.
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/fuse')
-rw-r--r--sys-fs/fuse/ChangeLog7
-rw-r--r--sys-fs/fuse/files/fuse-2.8.5-double-version.patch23
-rw-r--r--sys-fs/fuse/fuse-2.8.5.ebuild4
3 files changed, 32 insertions, 2 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index fd62d53afc0a..fb2e84d39281 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.133 2010/10/07 22:11:09 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.134 2010/11/24 01:28:54 flameeyes Exp $
+
+ 24 Nov 2010; Diego E. Pettenò <flameeyes@gentoo.org> fuse-2.8.5.ebuild,
+ +files/fuse-2.8.5-double-version.patch:
+ Add patch to avoid listing the same function in two versions to (partially)
+ fix build with gold.
*fuse-2.8.5 (07 Oct 2010)
diff --git a/sys-fs/fuse/files/fuse-2.8.5-double-version.patch b/sys-fs/fuse/files/fuse-2.8.5-double-version.patch
new file mode 100644
index 000000000000..60f5c98f3840
--- /dev/null
+++ b/sys-fs/fuse/files/fuse-2.8.5-double-version.patch
@@ -0,0 +1,23 @@
+commit 824b4ce6acd676e13cfa216dfbb5dbf4380781a0
+Author: Miklos Szeredi <mszeredi@suse.cz>
+Date: Tue Sep 28 20:04:02 2010 +0200
+
+ Fix ambiguous symbol version for fuse_chan_new
+
+ fuse_versionscript included fuse_chan_new in both FUSE_2.4 and
+ FUSE_2.6. Remove the FUSE_2.4, which is invalid.
+
+ Reported by Raymes Khoury, who discovered this with the gold linker
+
+diff --git a/lib/fuse_versionscript b/lib/fuse_versionscript
+index bd0186d..860c403 100644
+--- a/lib/fuse_versionscript
++++ b/lib/fuse_versionscript
+@@ -27,7 +27,6 @@ FUSE_2.4 {
+ fuse_chan_data;
+ fuse_chan_destroy;
+ fuse_chan_fd;
+- fuse_chan_new;
+ fuse_chan_receive;
+ fuse_chan_send;
+ fuse_chan_session;
diff --git a/sys-fs/fuse/fuse-2.8.5.ebuild b/sys-fs/fuse/fuse-2.8.5.ebuild
index c06283134f1a..44e96d2c353e 100644
--- a/sys-fs/fuse/fuse-2.8.5.ebuild
+++ b/sys-fs/fuse/fuse-2.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.8.5.ebuild,v 1.1 2010/10/07 22:11:09 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.8.5.ebuild,v 1.2 2010/11/24 01:28:54 flameeyes Exp $
EAPI=2
inherit eutils libtool linux-info
@@ -28,6 +28,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}/${P}-double-version.patch"
+
elibtoolize
}