summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2008-02-05 03:09:46 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2008-02-05 03:09:46 +0000
commitde89d04d5ab2dc516ece824477472c4bfd25fdaa (patch)
tree2b4bd3959c848ee5113c643dfc2cc715cdfcf350 /sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
parentStable on amd64 wrt bug #208481. (diff)
downloadgentoo-2-de89d04d5ab2dc516ece824477472c4bfd25fdaa.tar.gz
gentoo-2-de89d04d5ab2dc516ece824477472c4bfd25fdaa.tar.bz2
gentoo-2-de89d04d5ab2dc516ece824477472c4bfd25fdaa.zip
QA cleanup: quoted variables, switched to autotools.eclass usage, and changed to using make DESTDIR="${D}" install.
(Portage version: 2.1.4)
Diffstat (limited to 'sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild')
-rw-r--r--sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild34
1 files changed, 8 insertions, 26 deletions
diff --git a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
index 462800fb8fc5..30961830276b 100644
--- a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
+++ b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild,v 1.15 2008/02/05 02:48:35 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild,v 1.16 2008/02/05 03:09:46 wolf31o2 Exp $
WANT_AUTOMAKE=1.6
inherit autotools eutils libtool
@@ -22,34 +22,16 @@ S=${WORKDIR}/hfsplus-${PV}
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-glob.patch
- epatch ${FILESDIR}/${P}-errno.patch
- epatch ${FILESDIR}/${P}-gcc4.patch
- epatch ${FILESDIR}/${P}-string.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-glob.patch"
+ epatch "${FILESDIR}/${P}-errno.patch"
+ epatch "${FILESDIR}/${P}-gcc4.patch"
+ epatch "${FILESDIR}/${P}-string.patch"
#let's avoid the Makefile.cvs since isn't working for us
- export WANT_AUTOCONF=2.5
- export WANT_AUTOMAKE=1.6
- aclocal
- autoconf
- autoheader
- automake -a
- libtoolize --force --copy
- elibtoolize
-}
-
-src_compile() {
- econf || die
- emake || die
+ AM_OPTS="-a" eautoreconf
}
src_install() {
- dodir /usr/bin /usr/lib /usr/share/man
- make \
- prefix=${D}/usr \
- libdir=${D}/usr/lib \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die
+ make DESTDIR="${D}" install || die "make install failed"
newman doc/man/hfsp.man hfsp.1
}