summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2007-02-27 10:32:12 +0000
committerWolfram Schlich <wschlich@gentoo.org>2007-02-27 10:32:12 +0000
commit4cd086248bdce6f30e2e4fefd6e1e20b019db2c2 (patch)
treea875ad04069293de5b287b78b23d97928b8b40f0 /sys-fs/mdadm/mdadm-2.6.1.ebuild
parentbuild libsdl with USE=opengl; bug 168335 (diff)
downloadgentoo-2-4cd086248bdce6f30e2e4fefd6e1e20b019db2c2.tar.gz
gentoo-2-4cd086248bdce6f30e2e4fefd6e1e20b019db2c2.tar.bz2
gentoo-2-4cd086248bdce6f30e2e4fefd6e1e20b019db2c2.zip
version bump
(Portage version: 2.1.2)
Diffstat (limited to 'sys-fs/mdadm/mdadm-2.6.1.ebuild')
-rw-r--r--sys-fs/mdadm/mdadm-2.6.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-fs/mdadm/mdadm-2.6.1.ebuild b/sys-fs/mdadm/mdadm-2.6.1.ebuild
new file mode 100644
index 000000000000..75cf202b6c8c
--- /dev/null
+++ b/sys-fs/mdadm/mdadm-2.6.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/mdadm-2.6.1.ebuild,v 1.1 2007/02/27 10:32:12 wschlich Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A useful tool for running RAID systems - it can be used as a replacement for the raidtools"
+HOMEPAGE="http://cgi.cse.unsw.edu.au/~neilb/mdadm"
+SRC_URI="mirror://kernel/linux/utils/raid/mdadm/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.9.0-dont-make-man.patch
+ epatch "${FILESDIR}"/${PN}-2.6-syslog-updates.patch
+ use static && append-ldflags -static
+}
+
+src_compile() {
+ emake \
+ CROSS_COMPILE=${CHOST}- \
+ CWFLAGS="-Wall" \
+ CXFLAGS="${CFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ exeinto /$(get_libdir)/rcscripts/addons
+ doexe "${FILESDIR}"/raid-{start,stop}.sh || die "addon failed"
+ dodoc INSTALL TODO "ANNOUNCE-${PV}"
+
+ insinto /etc
+ newins mdadm.conf-example mdadm.conf
+ newinitd "${FILESDIR}"/mdadm.rc mdadm || die
+ newconfd "${FILESDIR}"/mdadm.confd mdadm || die
+}