summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-10-08 21:07:07 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-10-08 21:07:07 +0000
commit8375e5f0df1798679b45db5f5986aea149d98f81 (patch)
treefba59d90276b90cba75dfe25db47a83a309cb098 /sys-fs/mdadm/mdadm-2.6.3-r4.ebuild
parentFixed lyx-installation; bug #193381. Make installation $ROOT-safe. (diff)
downloadgentoo-2-8375e5f0df1798679b45db5f5986aea149d98f81.tar.gz
gentoo-2-8375e5f0df1798679b45db5f5986aea149d98f81.tar.bz2
gentoo-2-8375e5f0df1798679b45db5f5986aea149d98f81.zip
Make sure RAID starts when /usr is a different partition that is not yet available, and ensure that RAID comes up after modules properly, fixing the circular rc script loop.
(Portage version: 2.1.3.12)
Diffstat (limited to 'sys-fs/mdadm/mdadm-2.6.3-r4.ebuild')
-rw-r--r--sys-fs/mdadm/mdadm-2.6.3-r4.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sys-fs/mdadm/mdadm-2.6.3-r4.ebuild b/sys-fs/mdadm/mdadm-2.6.3-r4.ebuild
new file mode 100644
index 000000000000..ba0835306d3a
--- /dev/null
+++ b/sys-fs/mdadm/mdadm-2.6.3-r4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/mdadm-2.6.3-r4.ebuild,v 1.1 2007/10/08 21:07:06 robbat2 Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A useful tool for running RAID systems - it can be used as a replacement for the raidtools"
+HOMEPAGE="http://cgi.cse.unsw.edu.au/~neilb/mdadm"
+SRC_URI="mirror://kernel/linux/utils/raid/mdadm/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.9.0-dont-make-man.patch
+ epatch "${FILESDIR}"/${PN}-2.6-syslog-updates.patch
+ use static && append-ldflags -static
+}
+
+src_compile() {
+ emake \
+ CROSS_COMPILE=${CHOST}- \
+ CWFLAGS="-Wall" \
+ CXFLAGS="${CFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ exeinto /$(get_libdir)/rcscripts/addons
+ newexe "${FILESDIR}"/raid-start.sh-2.6.3-r4 raid-start.sh || die "addon failed"
+ newexe "${FILESDIR}"/raid-stop.sh-2.6.3-r2 raid-stop.sh || die "addon failed"
+ dodoc INSTALL TODO "ANNOUNCE-${PV}"
+
+ insinto /etc
+ newins mdadm.conf-example mdadm.conf
+ newinitd "${FILESDIR}"/mdadm.rc mdadm || die "installing mdadm.rc failed"
+ newconfd "${FILESDIR}"/mdadm.confd mdadm || die "installing mdadm.confd failed"
+ newinitd "${FILESDIR}"/mdraid.rc-2.6.3-r4 mdraid || die "installing mdraid.rc failed"
+
+ insinto /etc/udev/rules.d/
+ newins "${FILESDIR}"/64-md-raid.rules-2.6.3-r2 64-md-raid.rules || die
+}
+
+pkg_postinst() {
+ elog "If using baselayout-2 and not relying on kernel auto-detect"
+ elog "of your RAID devices, you need to add 'mdraid' to your 'boot'"
+ elog "runlevel. Run the following command:"
+ elog "rc-update add mdraid boot"
+}