summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-06-19 18:11:26 +0000
committerMichael Weber <xmw@gentoo.org>2012-06-19 18:11:26 +0000
commita6f886298663e74e2f0faa330ecb6afeae154e48 (patch)
treeb738882174cc87a028835820c2b04deba1cb07b9 /sys-fs/mp3fs/mp3fs-0.32.ebuild
parentUse EAPI=4. Simplify dependencies. Reenable tests fixed by upstream thanks to... (diff)
downloadgentoo-2-a6f886298663e74e2f0faa330ecb6afeae154e48.tar.gz
gentoo-2-a6f886298663e74e2f0faa330ecb6afeae154e48.tar.bz2
gentoo-2-a6f886298663e74e2f0faa330ecb6afeae154e48.zip
Version bump
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/mp3fs/mp3fs-0.32.ebuild')
-rw-r--r--sys-fs/mp3fs/mp3fs-0.32.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-fs/mp3fs/mp3fs-0.32.ebuild b/sys-fs/mp3fs/mp3fs-0.32.ebuild
new file mode 100644
index 000000000000..29b9127f11cb
--- /dev/null
+++ b/sys-fs/mp3fs/mp3fs-0.32.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mp3fs/mp3fs-0.32.ebuild,v 1.1 2012/06/19 18:11:26 xmw Exp $
+
+DESCRIPTION="a read-only FUSE filesystem which transcodes FLAC audio files to MP3 when read"
+HOMEPAGE="http://khenriks.github.com/mp3fs/"
+SRC_URI="https://github.com/downloads/khenriks/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-fs/fuse
+ media-libs/libid3tag
+ media-libs/flac
+ media-sound/lame
+ media-libs/libogg"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README.rst
+}