summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2005-05-20 02:47:42 +0000
committerNed Ludd <solar@gentoo.org>2005-05-20 02:47:42 +0000
commitc25d39249ffea9ba9e01eebbeec446314566b33b (patch)
tree419c8f6e3897adb28daa5e8766513b2bac1751d3 /sys-fs/mtd/mtd-20050519.ebuild
parentMark 2.1.0 stable, plus new upstream release. (diff)
downloadgentoo-2-c25d39249ffea9ba9e01eebbeec446314566b33b.tar.gz
gentoo-2-c25d39249ffea9ba9e01eebbeec446314566b33b.tar.bz2
gentoo-2-c25d39249ffea9ba9e01eebbeec446314566b33b.zip
- new snapshot
Diffstat (limited to 'sys-fs/mtd/mtd-20050519.ebuild')
-rw-r--r--sys-fs/mtd/mtd-20050519.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-fs/mtd/mtd-20050519.ebuild b/sys-fs/mtd/mtd-20050519.ebuild
new file mode 100644
index 000000000000..2d07923c1775
--- /dev/null
+++ b/sys-fs/mtd/mtd-20050519.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd/mtd-20050519.ebuild,v 1.1 2005/05/20 02:47:42 solar Exp $
+
+DESCRIPTION="JFFS2 is a log-structured file system designed for use on flash devices in embedded systems."
+HOMEPAGE="http://sources.redhat.com/jffs2/"
+SRC_URI="ftp://ftp.uk.linux.org/pub/people/dwmw2/mtd/cvs/${PN}-snapshot-${PV}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~mips ~arm ~amd64 ~ppc"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+DEPEND="sys-libs/zlib
+ virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e s:'-O2 -Wall':"${CFLAGS}":g -e s:^MANDIR=.*:MANDIR=/usr/share/man: ${S}/util/Makefile || die
+}
+
+src_compile() {
+ cd ${S}/util
+ emake LINUXDIR=${ROOT}/usr/src/linux/ || die
+}
+
+src_install() {
+ cd ${S}/util
+ einstall DESTDIR=${D}
+}