summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-07 12:37:45 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-07 12:37:45 +0000
commit5817a801f8e7755d52b4953a4e0b329bebf9c1c3 (patch)
tree7b11874c97714ce72b78e44f7a3cdcd847a6559b /sys-fs/ncdu/ncdu-1.9.ebuild
parentkeyword ~amd64-linux and ~x86-linux (diff)
downloadgentoo-2-5817a801f8e7755d52b4953a4e0b329bebf9c1c3.tar.gz
gentoo-2-5817a801f8e7755d52b4953a4e0b329bebf9c1c3.tar.bz2
gentoo-2-5817a801f8e7755d52b4953a4e0b329bebf9c1c3.zip
sys-fs/ncdu: Add fix for building against ncurses[tinfo]
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sys-fs/ncdu/ncdu-1.9.ebuild')
-rw-r--r--sys-fs/ncdu/ncdu-1.9.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/sys-fs/ncdu/ncdu-1.9.ebuild b/sys-fs/ncdu/ncdu-1.9.ebuild
index 12c6c72cbecf..943f939d45c8 100644
--- a/sys-fs/ncdu/ncdu-1.9.ebuild
+++ b/sys-fs/ncdu/ncdu-1.9.ebuild
@@ -1,8 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ncdu/ncdu-1.9.ebuild,v 1.7 2013/03/07 12:29:33 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ncdu/ncdu-1.9.ebuild,v 1.8 2013/03/07 12:37:45 jlec Exp $
-EAPI=4
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
DESCRIPTION="NCurses Disk Usage"
HOMEPAGE="http://dev.yorhel.nl/ncdu/"
@@ -13,5 +17,8 @@ SLOT="0"
KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux ~x64-macos"
IUSE=""
-DEPEND="sys-libs/ncurses[unicode]"
-RDEPEND="${DEPEND}"
+RDEPEND="sys-libs/ncurses[unicode]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-pkgconfig.patch )