summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2013-01-15 01:36:53 +0000
committerPatrick McLean <chutzpah@gentoo.org>2013-01-15 01:36:53 +0000
commit34bc6de3e5fdbf7cea18bde6cb5b37cb37071085 (patch)
treecaa8173b71785d71662d45a47fade2a00f0230fc /sys-fs/ntfs3g
parentVersion bump. Add REQUIRED_USE block so conntrack can't be enabled on s390 to... (diff)
downloadgentoo-2-34bc6de3e5fdbf7cea18bde6cb5b37cb37071085.tar.gz
gentoo-2-34bc6de3e5fdbf7cea18bde6cb5b37cb37071085.tar.bz2
gentoo-2-34bc6de3e5fdbf7cea18bde6cb5b37cb37071085.zip
Version bump.
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xE3F69979BB4B8928DA78E3D17CBF44EF)
Diffstat (limited to 'sys-fs/ntfs3g')
-rw-r--r--sys-fs/ntfs3g/ChangeLog9
-rw-r--r--sys-fs/ntfs3g/ntfs3g-2013.1.13.ebuild76
2 files changed, 83 insertions, 2 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index 343f9aaa4f75..17522f818fcb 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/ntfs3g
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.143 2012/12/30 14:59:47 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.144 2013/01/15 01:36:53 chutzpah Exp $
+
+*ntfs3g-2013.1.13 (15 Jan 2013)
+
+ 15 Jan 2013; Patrick McLean <chutzpah@gentoo.org> +ntfs3g-2013.1.13.ebuild:
+ Version bump.
30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> ntfs3g-2012.1.15-r2.ebuild:
Stable for amd64, wrt bug #439832
diff --git a/sys-fs/ntfs3g/ntfs3g-2013.1.13.ebuild b/sys-fs/ntfs3g/ntfs3g-2013.1.13.ebuild
new file mode 100644
index 000000000000..d697002f8c4e
--- /dev/null
+++ b/sys-fs/ntfs3g/ntfs3g-2013.1.13.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2013.1.13.ebuild,v 1.1 2013/01/15 01:36:53 chutzpah Exp $
+
+EAPI=5
+inherit eutils linux-info udev
+
+MY_PN=${PN/3g/-3g}
+MY_P=${MY_PN}_ntfsprogs-${PV}
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.tuxera.com/community/ntfs-3g-download/"
+SRC_URI="http://tuxera.com/opensource/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="acl crypt debug +external-fuse +ntfsprogs static-libs suid xattr"
+
+RDEPEND="!<sys-apps/util-linux-2.20.1-r2
+ !sys-fs/ntfsprogs
+ crypt? (
+ >=dev-libs/libgcrypt-1.2.2
+ >=net-libs/gnutls-1.4.4
+ )
+ external-fuse? ( >=sys-fs/fuse-2.8.0 )"
+DEPEND="${RDEPEND}
+ sys-apps/attr
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS ChangeLog CREDITS README"
+
+pkg_setup() {
+ if use external-fuse && use kernel_linux; then
+ if kernel_is lt 2 6 9; then
+ die "Your kernel is too old."
+ fi
+ CONFIG_CHECK="~FUSE_FS"
+ FUSE_FS_WARNING="You need to have FUSE module built to use ntfs-3g"
+ linux-info_pkg_setup
+ fi
+}
+
+src_configure() {
+ econf \
+ --exec-prefix="${EPREFIX}"/usr \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable debug) \
+ --enable-ldscript \
+ --disable-ldconfig \
+ $(use_enable acl posix-acls) \
+ $(use_enable xattr xattr-mappings) \
+ $(use_enable crypt crypto) \
+ $(use_enable ntfsprogs) \
+ --without-uuid \
+ --enable-extras \
+ $(use_enable static-libs static) \
+ --with-fuse=$(usex external-fuse external internal)
+}
+
+src_install() {
+ default
+
+ use suid && fperms u+s /usr/bin/${MY_PN}
+ udev_dorules "${FILESDIR}"/99-ntfs3g.rules
+ prune_libtool_files
+
+ # http://bugs.gentoo.org/398069
+ dodir /usr/sbin
+ mv "${ED}"/sbin/* "${ED}"/usr/sbin || die
+ rm -r "${ED}"/sbin
+
+ dosym mount.ntfs-3g /usr/sbin/mount.ntfs #374197
+}