summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-03-09 22:45:02 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-03-09 22:45:02 +0000
commit4e4c2a7783e883479bd7e46c862def0e7732a52a (patch)
treee02b8b1c3c93d57173dda47ce5f8d0c14d656cb6 /sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8.ebuild
parentnew snapshot (diff)
downloadgentoo-2-4e4c2a7783e883479bd7e46c862def0e7732a52a.tar.gz
gentoo-2-4e4c2a7783e883479bd7e46c862def0e7732a52a.tar.bz2
gentoo-2-4e4c2a7783e883479bd7e46c862def0e7732a52a.zip
Fix bug #84598.
(Portage version: 2.0.51.16)
Diffstat (limited to 'sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8.ebuild')
-rw-r--r--sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8.ebuild b/sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8.ebuild
index 13408503ab3e..017a53de877a 100644
--- a/sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8.ebuild
+++ b/sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8.ebuild,v 1.4 2005/01/11 18:44:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8.ebuild,v 1.5 2005/03/09 22:45:02 robbat2 Exp $
inherit libtool flag-o-matic
-MY_P=${PN}-${PV/_/-}
-DESCRIPTION="library for accessing and manipulating reiserfs partitions"
+MY_P="${PN}-${PV/_/-}"
+DESCRIPTION="Library for accessing and manipulating reiserfs partitions"
HOMEPAGE="http://reiserfs.linux.kiev.ua/"
SRC_URI="http://reiserfs.linux.kiev.ua/snapshots/${MY_P}.tar.gz"
@@ -15,13 +15,16 @@ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="nls debug"
RDEPEND=""
-DEPEND="nls? ( sys-devel/gettext )"
+DEPEND="sys-fs/e2fsprogs
+ nls? ( sys-devel/gettext )"
S="${WORKDIR}/${MY_P}"
progsreiserfs_warning() {
ewarn "progsreiserfs has been proven dangerous in the past, generating bad"
ewarn "partitions and destroying data on resize/cpfs operations."
+ ewarn "Because of this, we do NOT provide their binaries, but only their"
+ ewarn "libraries instead, as these are needed for other applications."
}
src_compile() {