summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-03 10:29:12 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-03 10:29:12 +0000
commitdc8cddda0015f75b4be85af16240df8a57526f89 (patch)
tree480f1e388085af559591c682a605148c7240e8f6 /sys-fs/quota/quota-3.06.ebuild
parentmove quota stuff from sys-apps to sys-fs (diff)
downloadgentoo-2-dc8cddda0015f75b4be85af16240df8a57526f89.tar.gz
gentoo-2-dc8cddda0015f75b4be85af16240df8a57526f89.tar.bz2
gentoo-2-dc8cddda0015f75b4be85af16240df8a57526f89.zip
move from sys-apps
Diffstat (limited to 'sys-fs/quota/quota-3.06.ebuild')
-rw-r--r--sys-fs/quota/quota-3.06.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-fs/quota/quota-3.06.ebuild b/sys-fs/quota/quota-3.06.ebuild
new file mode 100644
index 000000000000..7e79fd36145a
--- /dev/null
+++ b/sys-fs/quota/quota-3.06.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.06.ebuild,v 1.1 2004/10/03 10:28:05 vapier Exp $
+
+inherit eutils
+
+S=${WORKDIR}/quota-tools
+DESCRIPTION="Linux quota tools"
+HOMEPAGE="http://sourceforge.net/projects/linuxquota/"
+SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
+
+RESTRICT="nomirror"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 amd64 ppc sparc alpha ~hppa ~mips ~ia64"
+IUSE=""
+
+DEPEND="virtual/libc
+ sys-apps/tcp-wrappers"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # patch to prevent quotactl.2 manpage from being installed
+ # that page is provided by man-pages instead
+ epatch ${FILESDIR}/${PN}-no-quotactl-manpage.patch
+}
+
+src_compile() {
+ econf || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ dodir {sbin,etc,usr/sbin,usr/bin,usr/share/man/man{1,2,3,8}}
+ make ROOTDIR=${D} install || die
+# install -m 644 warnquota.conf ${D}/etc
+ insinto /etc
+ insopts -m0644
+ doins warnquota.conf quotatab
+ dodoc doc/*
+}