summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-01-06 22:37:43 +0000
committerMike Frysinger <vapier@gentoo.org>2013-01-06 22:37:43 +0000
commit506ad089274f4a22fa0b9bc51332093e9e6da07a (patch)
tree84f2cb672487d51d31b67a4f8525230e4131bb46 /sys-fs/quota
parentRemove net-nntp/sabnzbd mask, fix already released and updated in tree. (diff)
downloadgentoo-2-506ad089274f4a22fa0b9bc51332093e9e6da07a.tar.gz
gentoo-2-506ad089274f4a22fa0b9bc51332093e9e6da07a.tar.bz2
gentoo-2-506ad089274f4a22fa0b9bc51332093e9e6da07a.zip
Version bump #450614 by Agostino Sarubbo.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-fs/quota')
-rw-r--r--sys-fs/quota/ChangeLog10
-rw-r--r--sys-fs/quota/files/quota-4.01-mnt.patch13
-rw-r--r--sys-fs/quota/quota-4.01.ebuild71
3 files changed, 92 insertions, 2 deletions
diff --git a/sys-fs/quota/ChangeLog b/sys-fs/quota/ChangeLog
index 1dbbe9cc9f2a..eacebd45e4f1 100644
--- a/sys-fs/quota/ChangeLog
+++ b/sys-fs/quota/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/quota
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/ChangeLog,v 1.63 2012/12/24 02:29:19 vapier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/ChangeLog,v 1.64 2013/01/06 22:37:43 vapier Exp $
+
+*quota-4.01 (06 Jan 2013)
+
+ 06 Jan 2013; Mike Frysinger <vapier@gentoo.org> +files/quota-4.01-mnt.patch,
+ +quota-4.01.ebuild:
+ Version bump #450614 by Agostino Sarubbo.
24 Dec 2012; Mike Frysinger <vapier@gentoo.org> quota-4.00.ebuild:
Use CC from configure #446277 by Julian Ospald.
diff --git a/sys-fs/quota/files/quota-4.01-mnt.patch b/sys-fs/quota/files/quota-4.01-mnt.patch
new file mode 100644
index 000000000000..1aa1590accb8
--- /dev/null
+++ b/sys-fs/quota/files/quota-4.01-mnt.patch
@@ -0,0 +1,13 @@
+https://sourceforge.net/tracker/?func=detail&aid=3599717&group_id=18136&atid=318136
+
+--- a/quotasys.c
++++ b/quotasys.c
+@@ -642,7 +642,7 @@
+ die(2, _("Cannot initialize mountpoint scan.\n"));
+ while ((mnt = get_next_mount())) {
+ #ifndef RPC
+- if (nfs_fstype(mnt->mnt_type))
++ if (nfs_fstype(mnt->me_type))
+ continue;
+ #endif
+ if (fmt == -1 || count) {
diff --git a/sys-fs/quota/quota-4.01.ebuild b/sys-fs/quota/quota-4.01.ebuild
new file mode 100644
index 000000000000..621fbc4171e1
--- /dev/null
+++ b/sys-fs/quota/quota-4.01.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-4.01.ebuild,v 1.1 2013/01/06 22:37:43 vapier Exp $
+
+EAPI="4"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Linux quota tools"
+HOMEPAGE="http://sourceforge.net/projects/linuxquota/"
+SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ldap netlink nls rpc tcpd"
+
+RDEPEND="ldap? ( >=net-nds/openldap-2.3.35 )
+ netlink? (
+ sys-apps/dbus
+ dev-libs/libnl:1.1
+ )
+ rpc? ( net-nds/rpcbind )
+ tcpd? ( sys-apps/tcp-wrappers )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/quota-tools
+
+src_prepare() {
+ sed -i '1iCC = @CC@' Makefile.in || die #446277
+ epatch "${FILESDIR}"/${PN}-4.01-mnt.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable ldap ldapmail) \
+ $(use_enable netlink) \
+ $(use_enable rpc) \
+ $(use_enable rpc rpcsetquota)
+}
+
+src_install() {
+ emake STRIP="" ROOTDIR="${D}" install
+ dodoc doc/* README.* Changelog
+ rm -r "${D}"/usr/include || die #70938
+
+ insinto /etc
+ insopts -m0644
+ doins warnquota.conf quotatab
+
+ newinitd "${FILESDIR}"/quota.rc7 quota
+ newconfd "${FILESDIR}"/quota.confd quota
+
+ if use rpc ; then
+ newinitd "${FILESDIR}"/rpc.rquotad.initd rpc.rquotad
+ else
+ rm -f "${D}"/usr/sbin/rpc.rquotad
+ fi
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ insopts -m0644
+ doins ldap-scripts/quota.schema
+
+ exeinto /usr/share/quota/ldap-scripts
+ doexe ldap-scripts/*.pl
+ doexe ldap-scripts/edquota_editor
+ fi
+}