summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-26 06:22:59 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-26 06:22:59 +0000
commitf06c299b14a2b441762e5ab1c3a1c320d34dbd9e (patch)
treeab387bc00c1075f1ec4a3418fd419e86d356bb1b /sys-fs/reiser4progs
parentstablize (diff)
downloadgentoo-2-f06c299b14a2b441762e5ab1c3a1c320d34dbd9e.tar.gz
gentoo-2-f06c299b14a2b441762e5ab1c3a1c320d34dbd9e.tar.bz2
gentoo-2-f06c299b14a2b441762e5ab1c3a1c320d34dbd9e.zip
Add upstream patch for newer kernel support #97048 by Sander Sweers.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-fs/reiser4progs')
-rw-r--r--sys-fs/reiser4progs/ChangeLog6
-rw-r--r--sys-fs/reiser4progs/files/reiser4progs-1.0.4.pset.patch97
-rw-r--r--sys-fs/reiser4progs/reiser4progs-1.0.4.ebuild13
3 files changed, 109 insertions, 7 deletions
diff --git a/sys-fs/reiser4progs/ChangeLog b/sys-fs/reiser4progs/ChangeLog
index d7c375c39cd6..536290fc9f28 100644
--- a/sys-fs/reiser4progs/ChangeLog
+++ b/sys-fs/reiser4progs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/reiser4progs
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiser4progs/ChangeLog,v 1.21 2005/05/22 06:57:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiser4progs/ChangeLog,v 1.22 2005/06/26 06:22:59 vapier Exp $
+
+ 26 Jun 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/reiser4progs-1.0.4.pset.patch, reiser4progs-1.0.4.ebuild:
+ Add upstream patch for newer kernel support #97048 by Sander Sweers.
22 May 2005; Mike Frysinger <vapier@gentoo.org> reiser4progs-1.0.4.ebuild:
Add fix for broken libtool relinking by Simone Gotti #74817.
diff --git a/sys-fs/reiser4progs/files/reiser4progs-1.0.4.pset.patch b/sys-fs/reiser4progs/files/reiser4progs-1.0.4.pset.patch
new file mode 100644
index 000000000000..daaef251328b
--- /dev/null
+++ b/sys-fs/reiser4progs/files/reiser4progs-1.0.4.pset.patch
@@ -0,0 +1,97 @@
+===== include/reiser4/plugin.h 1.739 vs edited =====
+--- 1.739/include/reiser4/plugin.h 2005-01-30 15:57:02 +03:00
++++ edited/include/reiser4/plugin.h 2005-06-18 16:53:14 +04:00
+@@ -285,20 +285,23 @@ enum reiser4_opset_id {
+ OPSET_DIRITEM = 0x7,
+ OPSET_CRYPTO = 0x8,
+ OPSET_DIGEST = 0x9,
+- OPSET_COMPRES = 0xa,
++ OPSET_CPRESS = 0xa,
++ OPSET_CPRESS_MODE = 0xb,
++ OPSET_CLUSTER = 0xc,
++ OPSET_REGULAR = 0xd,
+
+- OPSET_STORE_LAST = (OPSET_COMPRES + 1),
++ OPSET_STORE_LAST,
+
+ /* These are not stored on disk in the current implementation. */
+- OPSET_CREATE = 0xb,
+- OPSET_MKDIR = 0xc,
+- OPSET_SYMLINK = 0xd,
+- OPSET_MKNODE = 0xe,
++ OPSET_CREATE = OPSET_STORE_LAST + 1,
++ OPSET_MKDIR = OPSET_STORE_LAST + 2,
++ OPSET_SYMLINK = OPSET_STORE_LAST + 3,
++ OPSET_MKNODE = OPSET_STORE_LAST + 4,
+
+ #ifndef ENABLE_MINIMAL
+- OPSET_TAIL = 0xf,
+- OPSET_EXTENT = 0x10,
+- OPSET_ACL = 0x11,
++ OPSET_TAIL = OPSET_STORE_LAST + 5,
++ OPSET_EXTENT = OPSET_STORE_LAST + 6,
++ OPSET_ACL = OPSET_STORE_LAST + 7,
+ #endif
+ OPSET_LAST
+ };
+===== libreiser4/pset.c 1.19 vs edited =====
+--- 1.19/libreiser4/pset.c 2004-11-24 12:09:22 +03:00
++++ edited/libreiser4/pset.c 2005-06-18 17:00:27 +04:00
+@@ -111,7 +111,7 @@ opset_member_t opset_prof[OPSET_LAST] =
+ .ess = 1,
+ #endif
+ },
+- [OPSET_COMPRES] = {
++ [OPSET_CPRESS] = {
+ .type = INVAL_TYPE,
+ #ifndef ENABLE_MINIMAL
+ .group = INVAL_PID,
+@@ -119,7 +119,31 @@ opset_member_t opset_prof[OPSET_LAST] =
+ .ess = 1,
+ #endif
+ },
+-
++ [OPSET_CPRESS_MODE] = {
++ .type = INVAL_TYPE,
++#ifndef ENABLE_MINIMAL
++ .group = INVAL_PID,
++ .prof = INVAL_PID,
++ .ess = 1,
++#endif
++ },
++ [OPSET_CLUSTER] = {
++ .type = INVAL_TYPE,
++#ifndef ENABLE_MINIMAL
++ .group = INVAL_PID,
++ .prof = INVAL_PID,
++ .ess = 1,
++#endif
++ },
++ [OPSET_REGULAR] = {
++ .type = INVAL_TYPE,
++#ifndef ENABLE_MINIMAL
++ .group = INVAL_PID,
++ .prof = INVAL_PID,
++ .ess = 1,
++#endif
++ },
++
+ /* Note, plugins below are not stored on-disk. */
+
+ /* The 4 plugins below needs to be splited -- for now they are used for
+===== plugin/sdext/sdext_plug/sdext_plug_repair.c 1.10 vs edited =====
+--- 1.10/plugin/sdext/sdext_plug/sdext_plug_repair.c 2004-09-22 18:21:08 +04:00
++++ edited/plugin/sdext/sdext_plug/sdext_plug_repair.c 2005-06-18 17:00:16 +04:00
+@@ -22,7 +22,10 @@ char *opset_name[OPSET_STORE_LAST] = {
+ [OPSET_DIRITEM] = "diritem",
+ [OPSET_CRYPTO] = "crypto",
+ [OPSET_DIGEST] = "digest",
+- [OPSET_COMPRES] = "compress"
++ [OPSET_CPRESS] = "compress",
++ [OPSET_CPRESS_MODE] = "compress mode",
++ [OPSET_CLUSTER] = "cluster",
++ [OPSET_REGULAR] = "regular"
+ };
+
+ errno_t sdext_plug_check_struct(stat_entity_t *stat, repair_hint_t *hint) {
+
diff --git a/sys-fs/reiser4progs/reiser4progs-1.0.4.ebuild b/sys-fs/reiser4progs/reiser4progs-1.0.4.ebuild
index d90fbf2fe2a3..523a7437b248 100644
--- a/sys-fs/reiser4progs/reiser4progs-1.0.4.ebuild
+++ b/sys-fs/reiser4progs/reiser4progs-1.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiser4progs/reiser4progs-1.0.4.ebuild,v 1.5 2005/05/22 06:58:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiser4progs/reiser4progs-1.0.4.ebuild,v 1.6 2005/06/26 06:22:59 vapier Exp $
inherit eutils
@@ -10,7 +10,7 @@ SRC_URI="ftp://ftp.namesys.com/pub/reiser4progs/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 -sparc x86"
+KEYWORDS="amd64 ppc ~ppc64 -sparc x86"
IUSE="static debug readline"
DEPEND=">=sys-libs/libaal-${PV}
@@ -22,10 +22,11 @@ src_unpack() {
# bundled libtool sucks, so rebuild autotools #74817
aclocal && libtoolize -c -f && autoconf && automake || die "autotools failed"
epatch "${FILESDIR}"/${P}-gcc4.patch
- cat << EOF > run-ldconfig
-#!/bin/sh
-true
-EOF
+ epatch "${FILESDIR}"/${P}.pset.patch
+ cat <<-EOF > run-ldconfig
+ #!/bin/sh
+ true
+ EOF
}
src_compile() {