summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-04-26 10:58:20 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-04-26 10:58:20 +0000
commitb31dc177cf6a46b19ec5463f5fabff1b59bc506c (patch)
tree9797c99bfa7a70f127695be308d42186d8d26c8c /sys-fs/safecopy/safecopy-1.7.ebuild
parentRemove systemd mask from polkit on supported archs (diff)
downloadgentoo-2-b31dc177cf6a46b19ec5463f5fabff1b59bc506c.tar.gz
gentoo-2-b31dc177cf6a46b19ec5463f5fabff1b59bc506c.tar.bz2
gentoo-2-b31dc177cf6a46b19ec5463f5fabff1b59bc506c.zip
Version bump to latest.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/safecopy/safecopy-1.7.ebuild')
-rw-r--r--sys-fs/safecopy/safecopy-1.7.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-fs/safecopy/safecopy-1.7.ebuild b/sys-fs/safecopy/safecopy-1.7.ebuild
new file mode 100644
index 000000000000..eb5860dd8941
--- /dev/null
+++ b/sys-fs/safecopy/safecopy-1.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/safecopy/safecopy-1.7.ebuild,v 1.1 2012/04/26 10:58:20 scarabeus Exp $
+
+EAPI=4
+
+inherit base
+
+DESCRIPTION="Data recovery tool to fault-tolerantly extract data from damaged (io-errors) devices or files."
+HOMEPAGE="http://safecopy.sourceforge.net"
+SRC_URI="mirror://sourceforge/safecopy/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND=""
+
+DOCS=( README )
+
+src_prepare() {
+ base_src_prepare
+ sed -e 's:bin/sh:bin/bash:' \
+ -i "${S}"/test/test.sh || die
+}
+
+src_configure() {
+ econf
+ if use test; then
+ cd "${S}"/simulator
+ econf
+ fi
+}
+
+src_compile() {
+ emake
+ if use test; then
+ cd "${S}"/simulator
+ emake
+ fi
+}
+
+src_test() {
+ cd "${S}"/test
+ ./test.sh || die
+}