summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-06-04 08:49:18 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-06-04 08:49:18 +0000
commitb6deedd63aa50aabcd9c6617597dc2d3f94ba532 (patch)
treefdc072b5f6e6d92937329e7bae1e47c8be0092cd /sys-fs/squashfs-tools/squashfs-tools-2.0_alpha.ebuild
parentversion bump (Manifest recommit) (diff)
downloadgentoo-2-b6deedd63aa50aabcd9c6617597dc2d3f94ba532.tar.gz
gentoo-2-b6deedd63aa50aabcd9c6617597dc2d3f94ba532.tar.bz2
gentoo-2-b6deedd63aa50aabcd9c6617597dc2d3f94ba532.zip
version bump
Diffstat (limited to 'sys-fs/squashfs-tools/squashfs-tools-2.0_alpha.ebuild')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-2.0_alpha.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-2.0_alpha.ebuild b/sys-fs/squashfs-tools/squashfs-tools-2.0_alpha.ebuild
new file mode 100644
index 000000000000..eac5bc96bc69
--- /dev/null
+++ b/sys-fs/squashfs-tools/squashfs-tools-2.0_alpha.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-2.0_alpha.ebuild,v 1.1 2004/06/04 08:49:18 dragonheart Exp $
+
+MY_PV=${PV/_alpha/-ALPHA}
+DESCRIPTION="Tool for creating compressed filesystem type squashfs"
+HOMEPAGE="http://squashfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
+IUSE=""
+
+DEPEND="virtual/glibc
+ sys-libs/zlib"
+
+S=${WORKDIR}/squashfs${PV/_alpha}/squashfs-tools
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "s:-O2:${CFLAGS}:" Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dobin mksquashfs || die
+ cd ..
+ dodoc README ACKNOWLEDGEMENTS CHANGES
+}