summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2007-12-30 19:00:04 +0000
committerNed Ludd <solar@gentoo.org>2007-12-30 19:00:04 +0000
commitcce2121ff1ea5afbeaff88c6a64dbe4f9928954c (patch)
tree77e6f603e547bf64bf402eb4e5f8bf657cb1d703 /sys-fs/squashfs-tools
parentStable on ppc wrt bug 203661 (diff)
downloadgentoo-2-cce2121ff1ea5afbeaff88c6a64dbe4f9928954c.tar.gz
gentoo-2-cce2121ff1ea5afbeaff88c6a64dbe4f9928954c.tar.bz2
gentoo-2-cce2121ff1ea5afbeaff88c6a64dbe4f9928954c.zip
- Version bump.. get_nprocs() is a glibc only function and there is no reason to use it when sysconf(_SC_NPROCESSORS_CONF) exists. Also fixed some format mistakes.
(Portage version: 2.1.3.9)
Diffstat (limited to 'sys-fs/squashfs-tools')
-rw-r--r--sys-fs/squashfs-tools/ChangeLog10
-rw-r--r--sys-fs/squashfs-tools/files/digest-squashfs-tools-3.33
-rw-r--r--sys-fs/squashfs-tools/files/squashfs-tools-3.3-posix.patch46
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-3.3.ebuild36
4 files changed, 94 insertions, 1 deletions
diff --git a/sys-fs/squashfs-tools/ChangeLog b/sys-fs/squashfs-tools/ChangeLog
index 0228391f0d93..2b27fbce2862 100644
--- a/sys-fs/squashfs-tools/ChangeLog
+++ b/sys-fs/squashfs-tools/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/squashfs-tools
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.51 2007/11/06 22:54:24 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.52 2007/12/30 19:00:03 solar Exp $
+
+*squashfs-tools-3.3 (30 Dec 2007)
+
+ 30 Dec 2007; <solar@gentoo.org> +files/squashfs-tools-3.3-posix.patch,
+ +squashfs-tools-3.3.ebuild:
+ - Version bump.. get_nprocs() is a glibc only function and there is no
+ reason to use it when sysconf(_SC_NPROCESSORS_CONF) exists. Also fixed some
+ format mistakes.
06 Nov 2007; Chris Gianelloni <wolf31o2@gentoo.org>
squashfs-tools-3.2_p2.ebuild:
diff --git a/sys-fs/squashfs-tools/files/digest-squashfs-tools-3.3 b/sys-fs/squashfs-tools/files/digest-squashfs-tools-3.3
new file mode 100644
index 000000000000..54c54a56a10b
--- /dev/null
+++ b/sys-fs/squashfs-tools/files/digest-squashfs-tools-3.3
@@ -0,0 +1,3 @@
+MD5 62d3ff7c067a5aa82f57711b3a4ab86a squashfs3.3.tar.gz 323279
+RMD160 d324b6dd779820c2b54eddf087860096c0dbb68c squashfs3.3.tar.gz 323279
+SHA256 496049c7e5fd361d8fec814ee05005591380bbcb03a565957b78161cdefe84e5 squashfs3.3.tar.gz 323279
diff --git a/sys-fs/squashfs-tools/files/squashfs-tools-3.3-posix.patch b/sys-fs/squashfs-tools/files/squashfs-tools-3.3-posix.patch
new file mode 100644
index 000000000000..735cecb14a9c
--- /dev/null
+++ b/sys-fs/squashfs-tools/files/squashfs-tools-3.3-posix.patch
@@ -0,0 +1,46 @@
+--- squashfs-tools/mksquashfs.c 2007-11-01 06:48:13 +0000
++++ squashfs-tools/mksquashfs.c 2007-12-30 18:47:28 +0000
+@@ -991,12 +991,12 @@
+ char buff[65536];
+
+ if((byte = readlink(filename, buff, 65536)) == -1) {
+- ERROR("Failed to read symlink %d, creating empty symlink\n", filename);
++ ERROR("Failed to read symlink %s, creating empty symlink\n", filename);
+ byte = 0;
+ }
+
+ if(byte == 65536) {
+- ERROR("Symlink %d is greater than 65536 bytes! Creating empty symlink\n", filename);
++ ERROR("Symlink %s is greater than 65536 bytes! Creating empty symlink\n", filename);
+ byte = 0;
+ }
+
+@@ -1022,7 +1022,7 @@
+ SQUASHFS_SWAP_IPC_INODE_HEADER(ipc, inode);
+ TRACE("ipc inode, type %s, nlink %d\n", type == SQUASHFS_FIFO_TYPE ? "fifo" : "socket", nlink);
+ } else
+- BAD_ERROR("Unrecognised inode %d in create_inode\n");
++ BAD_ERROR("Unrecognised inode in create_inode\n");
+
+ *i_no = MKINODE(inode);
+ inode_count ++;
+@@ -2845,7 +2845,7 @@
+ processors = 1;
+ }
+ #else
+- processors = get_nprocs();
++ processors = sysconf(_SC_NPROCESSORS_CONF);
+ #endif
+ }
+
+--- squashfs-tools/unsquashfs.c 2007-11-01 06:53:46 +0000
++++ squashfs-tools/unsquashfs.c 2007-12-30 18:47:31 +0000
+@@ -921,7 +921,7 @@
+ set_attributes(pathname, i->mode, i->uid, i->gid, i->time, TRUE);
+ dev_count ++;
+ } else
+- ERROR("create_inode: could not create %s device %s, because you're not superuser!\n",
++ ERROR("create_inode: could not create %s device %s, because you're not superuser! %s\n",
+ chrdev ? "character" : "block", pathname, strerror(errno));
+ break;
+ }
diff --git a/sys-fs/squashfs-tools/squashfs-tools-3.3.ebuild b/sys-fs/squashfs-tools/squashfs-tools-3.3.ebuild
new file mode 100644
index 000000000000..bcd9065428a5
--- /dev/null
+++ b/sys-fs/squashfs-tools/squashfs-tools-3.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-3.3.ebuild,v 1.1 2007/12/30 19:00:03 solar Exp $
+
+inherit eutils toolchain-funcs
+
+MY_PV=${PV/_p/-r}
+DESCRIPTION="Tool for creating compressed filesystem type squashfs"
+HOMEPAGE="http://squashfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+
+S=${WORKDIR}/squashfs${PV/_p/-r}/squashfs-tools
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i "s:-O2:${CFLAGS}:" Makefile
+ epatch "${FILESDIR}"/squashfs-tools-3.3-posix.patch || die patching failed
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin mksquashfs unsquashfs || die
+ cd ..
+ dodoc README ACKNOWLEDGEMENTS CHANGES PERFORMANCE.README README-3.3
+}