summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-24 05:11:32 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-24 05:11:32 +0000
commit79095fbb6537cdb1a2d2b34dcc496322bd28226b (patch)
treec994f9b0a17e1f27e667f59f745ed034b607b94c /sys-fs/xfsprogs
parentAdd fixes from upstream. (diff)
downloadgentoo-2-79095fbb6537cdb1a2d2b34dcc496322bd28226b.tar.gz
gentoo-2-79095fbb6537cdb1a2d2b34dcc496322bd28226b.tar.bz2
gentoo-2-79095fbb6537cdb1a2d2b34dcc496322bd28226b.zip
Fix parallel build failures #260005 by Gilles Dartiguelongue.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/xfsprogs')
-rw-r--r--sys-fs/xfsprogs/ChangeLog6
-rw-r--r--sys-fs/xfsprogs/files/xfsprogs-3.0.0-parallel-build.patch30
-rw-r--r--sys-fs/xfsprogs/xfsprogs-3.0.0.ebuild3
3 files changed, 37 insertions, 2 deletions
diff --git a/sys-fs/xfsprogs/ChangeLog b/sys-fs/xfsprogs/ChangeLog
index e538874f5ebe..5ccd6644de34 100644
--- a/sys-fs/xfsprogs/ChangeLog
+++ b/sys-fs/xfsprogs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/xfsprogs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/ChangeLog,v 1.114 2009/02/24 03:49:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/ChangeLog,v 1.115 2009/02/24 05:11:32 vapier Exp $
+
+ 24 Feb 2009; Mike Frysinger <vapier@gentoo.org>
+ +files/xfsprogs-3.0.0-parallel-build.patch, xfsprogs-3.0.0.ebuild:
+ Fix parallel build failures #260005 by Gilles Dartiguelongue.
24 Feb 2009; Mike Frysinger <vapier@gentoo.org> xfsprogs-3.0.0.ebuild:
Apply blocker as some binaries have moved from xfsdump to xfsprogs #259966
diff --git a/sys-fs/xfsprogs/files/xfsprogs-3.0.0-parallel-build.patch b/sys-fs/xfsprogs/files/xfsprogs-3.0.0-parallel-build.patch
new file mode 100644
index 000000000000..612719b35aa6
--- /dev/null
+++ b/sys-fs/xfsprogs/files/xfsprogs-3.0.0-parallel-build.patch
@@ -0,0 +1,30 @@
+http://bugs.gentoo.org/260005
+
+--- a/Makefile
++++ b/Makefile
+@@ -15,11 +15,11 @@
+ LDIRT = config.log .dep config.status config.cache confdefs.h conftest* \
+ Logs/* built .census install.* install-dev.* *.gz
+
+-LIB_SUBDIRS = include libxfs libxlog libxcmd libhandle libdisk
++LIB_SUBDIRS = libxfs libxlog libxcmd libhandle libdisk
+ TOOL_SUBDIRS = copy db estimate fsck fsr growfs io logprint mkfs quota \
+ mdrestore repair rtcp m4 man doc po debian build
+
+-SUBDIRS = $(LIB_SUBDIRS) $(TOOL_SUBDIRS)
++SUBDIRS = include $(LIB_SUBDIRS) $(TOOL_SUBDIRS)
+
+ default: include/builddefs include/platform_defs.h
+ ifeq ($(HAVE_BUILDDEFS), no)
+@@ -29,9 +29,10 @@
+ endif
+
+ # tool/lib dependencies
+-libxcmd: include
++$(LIB_SUBDIRS) $(TOOL_SUBDIRS): include
+ copy mdrestore: libxfs
+ db logprint: libxfs libxlog
++fsr: libhandle
+ growfs: libxfs libxcmd
+ io: libxcmd libhandle
+ mkfs: libxfs libdisk
diff --git a/sys-fs/xfsprogs/xfsprogs-3.0.0.ebuild b/sys-fs/xfsprogs/xfsprogs-3.0.0.ebuild
index 6baa0b83e69a..5388bdadfb69 100644
--- a/sys-fs/xfsprogs/xfsprogs-3.0.0.ebuild
+++ b/sys-fs/xfsprogs/xfsprogs-3.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-3.0.0.ebuild,v 1.3 2009/02/24 03:49:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-3.0.0.ebuild,v 1.4 2009/02/24 05:11:32 vapier Exp $
inherit eutils toolchain-funcs autotools
@@ -22,6 +22,7 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-parallel-build.patch #260005
sed -i \
-e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
include/builddefs.in \