summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Parpart <trapni@gentoo.org>2007-12-25 17:40:18 +0000
committerChristian Parpart <trapni@gentoo.org>2007-12-25 17:40:18 +0000
commitc5d9065d7aef7d1b6b29b1133ec28dc6b35752ad (patch)
tree0f87005bf5dcae72458a7bcc1ef7d581d1153bcb /sys-fs/zfs-fuse
parentRemoving seemant from metadata.xml as per #202469. (diff)
downloadgentoo-2-c5d9065d7aef7d1b6b29b1133ec28dc6b35752ad.tar.gz
gentoo-2-c5d9065d7aef7d1b6b29b1133ec28dc6b35752ad.tar.bz2
gentoo-2-c5d9065d7aef7d1b6b29b1133ec28dc6b35752ad.zip
ebuild (install path / rc script) improvements
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'sys-fs/zfs-fuse')
-rw-r--r--sys-fs/zfs-fuse/ChangeLog8
-rw-r--r--sys-fs/zfs-fuse/files/digest-zfs-fuse-0.4.0_beta1-r23
-rw-r--r--sys-fs/zfs-fuse/files/zfs-fuse.rc-r139
-rw-r--r--sys-fs/zfs-fuse/zfs-fuse-0.4.0_beta1-r2.ebuild93
4 files changed, 142 insertions, 1 deletions
diff --git a/sys-fs/zfs-fuse/ChangeLog b/sys-fs/zfs-fuse/ChangeLog
index 40d1b98871af..b79f3675939a 100644
--- a/sys-fs/zfs-fuse/ChangeLog
+++ b/sys-fs/zfs-fuse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/zfs-fuse
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-fuse/ChangeLog,v 1.2 2007/09/02 07:43:34 trapni Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-fuse/ChangeLog,v 1.3 2007/12/25 17:40:17 trapni Exp $
+
+*zfs-fuse-0.4.0_beta1-r2 (25 Dec 2007)
+
+ 25 Dec 2007; Christian Parpart <trapni@gentoo.org> +files/zfs-fuse.rc-r1,
+ +zfs-fuse-0.4.0_beta1-r2.ebuild:
+ improved init script and install paths
*zfs-fuse-0.4.0_beta1-r1 (02 Sep 2007)
diff --git a/sys-fs/zfs-fuse/files/digest-zfs-fuse-0.4.0_beta1-r2 b/sys-fs/zfs-fuse/files/digest-zfs-fuse-0.4.0_beta1-r2
new file mode 100644
index 000000000000..b459b7a8a37e
--- /dev/null
+++ b/sys-fs/zfs-fuse/files/digest-zfs-fuse-0.4.0_beta1-r2
@@ -0,0 +1,3 @@
+MD5 994329d660aa5dce7429eaee86426010 zfs-fuse-0.4.0_beta1.tar.bz2 606593
+RMD160 93c4aea550f3b55d39c2657f90e863abf89b5f79 zfs-fuse-0.4.0_beta1.tar.bz2 606593
+SHA256 0904b7a031ad0b8ae591d3aefa9a62b83d973392c6a8f8426d17d9b37d9974bb zfs-fuse-0.4.0_beta1.tar.bz2 606593
diff --git a/sys-fs/zfs-fuse/files/zfs-fuse.rc-r1 b/sys-fs/zfs-fuse/files/zfs-fuse.rc-r1
new file mode 100644
index 000000000000..c5b2f2170f6c
--- /dev/null
+++ b/sys-fs/zfs-fuse/files/zfs-fuse.rc-r1
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-fuse/files/zfs-fuse.rc-r1,v 1.1 2007/12/25 17:40:18 trapni Exp $
+
+depend() {
+ need localmount
+ before net
+}
+
+PIDFILE="/var/run/zfs-fuse.pid"
+EXEFILE="/usr/sbin/zfs-fuse"
+
+checksystem() {
+ return 0 # TODO
+}
+
+start() {
+ ebegin "Starting ZFS-FUSE"
+ checksystem || return 1
+ start-stop-daemon --start --background --make-pidfile --pidfile ${PIDFILE} \
+ --exec ${EXEFILE} --user daemon --group disk
+ rv=$?
+ eend $rv
+
+ if [[ $rv -eq 0 ]]; then
+ ebegin "Mounting ZFS filesystems"
+ zfs mount -a
+ eend $?
+ fi
+}
+
+stop() {
+ ebegin "Stopping ZFS-FUSE"
+ checksystem || return 2
+ start-stop-daemon --stop --pidfile ${PIDFILE} \
+ --exec ${EXEFILE} --retry TERM/1/TERM/2/TERM/4/TERM/8/KILL
+ eend $?
+}
diff --git a/sys-fs/zfs-fuse/zfs-fuse-0.4.0_beta1-r2.ebuild b/sys-fs/zfs-fuse/zfs-fuse-0.4.0_beta1-r2.ebuild
new file mode 100644
index 000000000000..91f925b6d14a
--- /dev/null
+++ b/sys-fs/zfs-fuse/zfs-fuse-0.4.0_beta1-r2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-fuse/zfs-fuse-0.4.0_beta1-r2.ebuild,v 1.1 2007/12/25 17:40:17 trapni Exp $
+
+IUSE="doc debug"
+
+inherit eutils
+
+DESCRIPTION="An implementation of the ZFS filesystem for FUSE/Linux"
+HOMEPAGE="http://www.wizy.org/wiki/ZFS_on_FUSE"
+SRC_URI="http://download.berlios.de/zfs-fuse/zfs-fuse-${PV}.tar.bz2"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND=">=sys-libs/glibc-2.3.3
+ >=dev-util/scons-0.96.1
+ >=sys-fs/fuse-2.6.1"
+
+RDEPEND=">=sys-fs/fuse-2.6.1"
+
+S=${WORKDIR}/${P}/src
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-fix_zdb_path.patch"
+ epatch "${FILESDIR}/${P}-fix_zfs-fuse_path.patch"
+ epatch "${FILESDIR}/${P}-fix_ztest_path.patch"
+}
+
+src_compile() {
+ scons || die "Make failed"
+}
+
+src_install() {
+ if useq debug; then
+ mv cmd/ztest/ztest cmd/ztest/run-ztest || die
+ mv cmd/ztest/runtest.sh cmd/ztest/ztest || die
+ dosbin cmd/ztest/run-ztest || die
+ fi
+ dosbin cmd/ztest/ztest || die
+
+ if useq debug; then
+ mv zfs-fuse/zfs-fuse zfs-fuse/run-zfs-fuse || die
+ mv zfs-fuse/run.sh zfs-fuse/zfs-fuse || die
+ dobin zfs-fuse/run-zfs-fuse || die
+ fi
+ dosbin "zfs-fuse/zfs-fuse" || die
+
+ dosbin "cmd/zfs/zfs" || die
+ dosbin "cmd/zpool/zpool" || die
+ dosbin "cmd/zdb/zdb" || die
+
+ newinitd "${FILESDIR}/zfs-fuse.rc-r1" "zfs-fuse" || die
+
+ cd "${WORKDIR}/${P}" || die
+
+ dodoc CHANGES || die
+
+ if use doc; then
+ dodoc {INSTALL,TODO,STATUS,TESTING,HACKING,BUGS} || die
+ fi
+}
+
+pkg_postinst() {
+ echo
+ einfo "To debug and play with ZFS-FUSE make sure you have a recent 2.6.xx"
+ einfo "series kernel with the FUSE module compiled in OR built as a"
+ einfo "kernel module."
+ einfo
+ einfo "You can start the ZFS-FUSE daemon by running"
+ einfo
+ einfo " /etc/init.d/zfs-fuse start"
+ einfo
+ einfo "as root from the command line. "
+ einfo
+ einfo "And don't forget to add it permanently, if you want to:"
+ einfo
+ einfo " rc-update add zfs-fuse boot"
+ einfo
+ einfo "For additional ZFS related commands I recommend the ZFS admin"
+ einfo "guide. http://opensolaris.org/os/community/zfs/docs/zfsadmin.pdf"
+ einfo
+ einfo "Don't forget this is an beta-quality release. Testing has been"
+ einfo "very limited so please make sure you backup any important data."
+ einfo
+ einfo "If you have any problems with zfs-fuse please visit the ZFS-FUSE."
+ einfo "website at http://developer.berlios.de/projects/zfs-fuse/"
+ echo
+}