summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-01-28 03:03:15 +0000
committerMike Gilbert <floppym@gentoo.org>2012-01-28 03:03:15 +0000
commit488bc3fa7927261aa26e031fde0ae7c653a1f56c (patch)
tree78c2764138907e71b20c4f85c1356cceb4e201ab /sys-fs/zfs
parentInitial import. (diff)
downloadgentoo-2-488bc3fa7927261aa26e031fde0ae7c653a1f56c.tar.gz
gentoo-2-488bc3fa7927261aa26e031fde0ae7c653a1f56c.tar.bz2
gentoo-2-488bc3fa7927261aa26e031fde0ae7c653a1f56c.zip
Migrate to autotools-utils for la file handling and add IUSE=static-libs.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/zfs')
-rw-r--r--sys-fs/zfs/ChangeLog5
-rw-r--r--sys-fs/zfs/zfs-9999.ebuild31
2 files changed, 16 insertions, 20 deletions
diff --git a/sys-fs/zfs/ChangeLog b/sys-fs/zfs/ChangeLog
index e4beab980700..3687e68fabda 100644
--- a/sys-fs/zfs/ChangeLog
+++ b/sys-fs/zfs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/zfs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/ChangeLog,v 1.2 2012/01/27 23:05:16 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/ChangeLog,v 1.3 2012/01/28 03:03:15 floppym Exp $
+
+ 28 Jan 2012; Mike Gilbert <floppym@gentoo.org> zfs-9999.ebuild:
+ Migrate to autotools-utils for la file handling and add IUSE=static-libs.
27 Jan 2012; Mike Gilbert <floppym@gentoo.org> -files/zfs.initd,
zfs-9999.ebuild:
diff --git a/sys-fs/zfs/zfs-9999.ebuild b/sys-fs/zfs/zfs-9999.ebuild
index 9b1babb01ef3..523b46703e80 100644
--- a/sys-fs/zfs/zfs-9999.ebuild
+++ b/sys-fs/zfs/zfs-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/zfs-9999.ebuild,v 1.2 2012/01/27 23:05:16 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/zfs-9999.ebuild,v 1.3 2012/01/28 03:03:15 floppym Exp $
EAPI="4"
-inherit autotools git-2 linux-mod
+inherit git-2 linux-mod autotools-utils
DESCRIPTION="Native ZFS for Linux"
HOMEPAGE="http://zfsonlinux.org/"
@@ -14,35 +14,28 @@ EGIT_REPO_URI="git://github.com/zfsonlinux/zfs.git"
LICENSE="CDDL GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE=""
+IUSE="static-libs"
DEPEND=">=sys-kernel/spl-${PV}"
RDEPEND="${DEPEND}
!sys-fs/zfs-fuse"
+AT_M4DIR="config"
+AUTOTOOLS_AUTORECONF="1"
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+
pkg_setup() {
CONFIG_CHECK="!PREEMPT !DEBUG_LOCK_ALLOC"
kernel_is ge 2 6 32 || die "Linux 2.6.32 or newer required"
check_extra_config
}
-src_prepare() {
- AT_M4DIR="config"
- eautoreconf
-}
-
src_configure() {
set_arch_to_kernel
- econf \
- --with-config=all \
- --with-linux="${KV_DIR}" \
+ local myeconfargs=(
+ --with-config=all
+ --with-linux="${KV_DIR}"
--with-linux-obj="${KV_OUT}"
-}
-
-src_compile() {
- default
-}
-
-src_install() {
- default
+ )
+ autotools-utils_src_configure
}