summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2012-09-22 15:21:42 +0000
committerWilliam Hubbs <williamh@gentoo.org>2012-09-22 15:21:42 +0000
commit02ead901b2b1546c804426ef5cb5a4be4f3b5be4 (patch)
treed7e55e8444ab91bb4762dcf3ff496fd59f5a7de4 /sys-fs
parentFix upgrade warning when upgrading from 2.x to 3.x, bug 435816. (diff)
downloadgentoo-2-02ead901b2b1546c804426ef5cb5a4be4f3b5be4.tar.gz
gentoo-2-02ead901b2b1546c804426ef5cb5a4be4f3b5be4.tar.bz2
gentoo-2-02ead901b2b1546c804426ef5cb5a4be4f3b5be4.zip
version bump
(Portage version: 2.2.0_alpha131/cvs/Linux i686)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/udev/ChangeLog7
-rw-r--r--sys-fs/udev/udev-191.ebuild417
2 files changed, 423 insertions, 1 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index 46964af77501..6f0fbe8005b1 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/udev
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.722 2012/09/21 20:34:55 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.723 2012/09/22 15:21:42 williamh Exp $
+
+*udev-191 (22 Sep 2012)
+
+ 22 Sep 2012; William Hubbs <williamh@gentoo.org> +udev-191.ebuild:
+ version bump
*udev-190 (21 Sep 2012)
diff --git a/sys-fs/udev/udev-191.ebuild b/sys-fs/udev/udev-191.ebuild
new file mode 100644
index 000000000000..9354d6374b06
--- /dev/null
+++ b/sys-fs/udev/udev-191.ebuild
@@ -0,0 +1,417 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-191.ebuild,v 1.1 2012/09/22 15:21:42 williamh Exp $
+
+EAPI=4
+
+KV_min=2.6.39
+
+inherit autotools eutils linux-info
+
+if [[ ${PV} = 9999* ]]
+then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/systemd/systemd"
+ inherit git-2
+else
+ patchset=1
+ SRC_URI="http://www.freedesktop.org/software/systemd/systemd-${PV}.tar.xz"
+ if [[ -n "${patchset}" ]]
+ then
+ SRC_URI="${SRC_URI}
+ http://dev.gentoo.org/~williamh/dist/${P}-patches-${patchset}.tar.bz2"
+ fi
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="Linux dynamic and persistent device naming support (aka userspace devfs)"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
+
+LICENSE="LGPL-2.1 MIT GPL-2"
+SLOT="0"
+IUSE="acl doc gudev hwdb introspection keymap +openrc selinux static-libs"
+
+RESTRICT="test"
+
+COMMON_DEPEND="acl? ( sys-apps/acl )
+ gudev? ( dev-libs/glib:2 )
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1 )
+ selinux? ( sys-libs/libselinux )
+ >=sys-apps/kmod-5
+ >=sys-apps/util-linux-2.20
+ !<sys-libs/glibc-2.11"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/gperf
+ >=dev-util/intltool-0.40.0
+ virtual/pkgconfig
+ virtual/os-headers
+ !<sys-kernel/linux-headers-${KV_min}
+ doc? ( dev-util/gtk-doc )"
+
+if [[ ${PV} = 9999* ]]
+then
+ DEPEND="${DEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt"
+fi
+
+RDEPEND="${COMMON_DEPEND}
+ hwdb? ( sys-apps/hwids )
+ openrc? ( >=sys-fs/udev-init-scripts-16
+ !<sys-apps/openrc-0.9.9 )
+ !sys-apps/coldplug
+ !=sys-apps/systemd-188
+ !<sys-fs/lvm2-2.02.45
+ !sys-fs/device-mapper
+ !<sys-fs/udev-init-scripts-16
+ !<sys-kernel/dracut-017-r1
+ !<sys-kernel/genkernel-3.4.25"
+
+S="${WORKDIR}/systemd-${PV}"
+
+udev_check_KV()
+{
+ if kernel_is lt ${KV_min//./ }
+ then
+ return 1
+ fi
+ return 0
+}
+
+check_default_rules()
+{
+ # Make sure there are no sudden changes to upstream rules file
+ # (more for my own needs than anything else ...)
+ local udev_rules_md5=18843fc4a8dd1d8074b98a583454cb9e
+ MD5=$(md5sum < "${S}/rules/50-udev-default.rules")
+ MD5=${MD5/ -/}
+ if [[ ${MD5} != ${udev_rules_md5} ]]
+ then
+ eerror "50-udev-default.rules has been updated, please validate!"
+ eerror "md5sum: ${MD5}"
+ die "50-udev-default.rules has been updated, please validate!"
+ fi
+}
+
+pkg_setup()
+{
+ # required kernel options
+ CONFIG_CHECK="~DEVTMPFS"
+ ERROR_DEVTMPFS="DEVTMPFS is not set in this kernel. Udev will not run."
+
+ linux-info_pkg_setup
+
+ if ! udev_check_KV
+ then
+ eerror "Your kernel version (${KV_FULL}) is too old to run ${P}"
+ eerror "It must be at least ${KV_min}!"
+ fi
+
+ KV_FULL_SRC=${KV_FULL}
+ get_running_version
+ if ! udev_check_KV
+ then
+ eerror
+ eerror "Your running kernel version (${KV_FULL}) is too old"
+ eerror "for this version of udev."
+ eerror "You must upgrade your kernel or downgrade udev."
+ fi
+}
+
+src_prepare()
+{
+ # backport some patches
+ if [[ -n "${patchset}" ]]
+ then
+ EPATCH_SUFFIX=patch EPATCH_FORCE=yes epatch
+ fi
+
+ # change rules back to group uucp instead of dialout for now
+ sed -e 's/GROUP="dialout"/GROUP="uucp"/' \
+ -i rules/*.rules \
+ || die "failed to change group dialout to uucp"
+
+ if [[ ! -e configure ]]
+ then
+ if use doc
+ then
+ gtkdocize --docdir docs || die "gtkdocize failed"
+ else
+ echo 'EXTRA_DIST =' > docs/gtk-doc.make
+ fi
+ eautoreconf
+ else
+ check_default_rules
+ elibtoolize
+ fi
+}
+
+src_configure()
+{
+ local econf_args
+
+ econf_args=(
+ ac_cv_search_cap_init=
+ ac_cv_header_sys_capability_h=yes
+ DBUS_CFLAGS=' '
+ DBUS_LIBS=' '
+ --docdir=/usr/share/doc/${PF}
+ --libdir=/usr/$(get_libdir)
+ --with-distro=gentoo
+ --with-firmware-path=/usr/lib/firmware/updates:/usr/lib/firmware:/lib/firmware/updates:/lib/firmware
+ --with-html-dir=/usr/share/doc/${PF}/html
+ --with-pci-ids-path=/usr/share/misc/pci.ids
+ --with-rootlibdir=/usr/$(get_libdir)
+ --with-rootprefix=/usr
+ --with-usb-ids-path=/usr/share/misc/usb.ids
+ --disable-audit
+ --disable-coredump
+ --disable-hostnamed
+ --disable-ima
+ --disable-libcryptsetup
+ --disable-localed
+ --disable-logind
+ --disable-nls
+ --disable-pam
+ --disable-quotacheck
+ --disable-readahead
+ --enable-split-usr
+ --disable-tcpwrap
+ --disable-timedated
+ --disable-xz
+ $(use_enable acl)
+ $(use_enable doc gtk-doc)
+ $(use_enable gudev)
+ $(use_enable introspection)
+ $(use_enable keymap)
+ $(use_enable selinux)
+ $(use_enable static-libs static)
+ )
+ econf "${econf_args[@]}"
+}
+
+src_compile()
+{
+ echo 'BUILT_SOURCES: $(BUILT_SOURCES)' > "${T}"/Makefile.extra
+ emake -f Makefile -f "${T}"/Makefile.extra BUILT_SOURCES
+ local targets=(
+ systemd-udevd
+ udevadm
+ libudev.la
+ ata_id
+ cdrom_id
+ collect
+ scsi_id
+ v4l_id
+ accelerometer
+ mtd_probe
+ man/udev.7
+ man/udevadm.8
+ man/systemd-udevd.8
+ man/systemd-udevd.service.8
+ )
+ use keymap && targets+=( keymap )
+ use gudev && targets+=( libgudev-1.0.la )
+
+ emake "${targets[@]}"
+ if use doc
+ then
+ emake -C docs/libudev
+ use gudev && emake -C docs/gudev
+ fi
+}
+
+src_install()
+{
+ local lib_LTLIBRARIES=libudev.la \
+ pkgconfiglib_DATA=src/libudev/libudev.pc
+
+ local targets=(
+ install-libLTLIBRARIES
+ install-includeHEADERS
+ install-libgudev_includeHEADERS
+ install-binPROGRAMS
+ install-rootlibexecPROGRAMS
+ install-udevlibexecPROGRAMS
+ install-dist_systemunitDATA
+ install-dist_udevconfDATA
+ install-dist_udevhomeSCRIPTS
+ install-dist_udevkeymapDATA
+ install-dist_udevkeymapforcerelDATA
+ install-dist_udevrulesDATA
+ install-girDATA
+ install-man7
+ install-man8
+ install-nodist_systemunitDATA
+ install-pkgconfiglibDATA
+ install-sharepkgconfigDATA
+ install-typelibsDATA
+ install-dist_docDATA
+ udev-confdirs
+ systemd-install-hook
+ )
+
+ if use gudev
+ then
+ lib_LTLIBRARIES+=" libgudev-1.0.la"
+ pkgconfiglib_DATA+=" src/gudev/gudev-1.0.pc"
+ fi
+
+ # add final values of variables:
+ targets+=(
+ rootlibexec_PROGRAMS=systemd-udevd
+ bin_PROGRAMS=udevadm
+ lib_LTLIBRARIES="${lib_LTLIBRARIES}"
+ MANPAGES="man/udev.7 man/udevadm.8 man/systemd-udevd.service.8"
+ MANPAGES_ALIAS="man/systemd-udevd.8"
+ dist_systemunit_DATA="units/systemd-udevd-control.socket \
+ units/systemd-udevd-kernel.socket"
+ nodist_systemunit_DATA="units/systemd-udevd.service \
+ units/systemd-udev-trigger.service \
+ units/systemd-udev-settle.service"
+ pkgconfiglib_DATA="${pkgconfiglib_DATA}"
+ )
+ emake DESTDIR="${D}" "${targets[@]}"
+ if use doc
+ then
+ emake -C docs/libudev DESTDIR="${D}" install
+ use gudev && emake -C docs/gudev DESTDIR="${D}" install
+ fi
+ dodoc TODO
+
+ prune_libtool_files --all
+ rm -f "${D}"/usr/lib/udev/rules.d/99-systemd.rules
+ rm -rf "${D}"/usr/share/doc/${PF}/LICENSE.*
+
+ # install gentoo-specific rules
+ insinto /usr/lib/udev/rules.d
+ doins "${FILESDIR}"/40-gentoo.rules
+
+ # install udevadm symlink
+ dosym ../usr/bin/udevadm /sbin/udevadm
+}
+
+pkg_preinst()
+{
+ local htmldir
+ for htmldir in gudev libudev; do
+ if [[ -d ${ROOT}usr/share/gtk-doc/html/${htmldir} ]]
+ then
+ rm -rf "${ROOT}"usr/share/gtk-doc/html/${htmldir}
+ fi
+ if [[ -d ${D}/usr/share/doc/${PF}/html/${htmldir} ]]
+ then
+ dosym ../../doc/${PF}/html/${htmldir} \
+ /usr/share/gtk-doc/html/${htmldir}
+ fi
+ done
+ preserve_old_lib /$(get_libdir)/libudev.so.0
+}
+
+# This function determines if a directory is a mount point.
+# It was lifted from dracut.
+ismounted()
+{
+ while read a m a; do
+ [[ $m = $1 ]] && return 0
+ done < "${ROOT}"/proc/mounts
+ return 1
+}
+
+pkg_postinst()
+{
+ mkdir -p "${ROOT}"/run
+
+ # "losetup -f" is confused if there is an empty /dev/loop/, Bug #338766
+ # So try to remove it here (will only work if empty).
+ rmdir "${ROOT}"/dev/loop 2>/dev/null
+ if [[ -d ${ROOT}/dev/loop ]]
+ then
+ ewarn "Please make sure your remove /dev/loop,"
+ ewarn "else losetup may be confused when looking for unused devices."
+ fi
+
+ # people want reminders, I'll give them reminders. Odds are they will
+ # just ignore them anyway...
+
+ # 64-device-mapper.rules now gets installed by sys-fs/device-mapper
+ # remove it if user don't has sys-fs/device-mapper installed, 27 Jun 2007
+ if [[ -f ${ROOT}/etc/udev/rules.d/64-device-mapper.rules ]] &&
+ ! has_version sys-fs/device-mapper
+ then
+ rm -f "${ROOT}"/etc/udev/rules.d/64-device-mapper.rules
+ einfo "Removed unneeded file 64-device-mapper.rules"
+ fi
+
+ ewarn
+ ewarn "If you build an initramfs including udev, please make sure the"
+ ewarn "/usr/bin/udevadm binary gets included, Also, change your scripts to"
+ ewarn "use it,as it replaces the old udevinfo and udevtrigger helpers."
+
+ ewarn
+ ewarn "mount options for /dev are no longer set in /etc/udev/udev.conf."
+ ewarn "Instead, /etc/fstab should be used. This matches other mount points."
+
+ ewarn
+ ewarn "Rules for /dev/hd* devices have been removed."
+ ewarn "Please migrate to libata."
+
+ ewarn
+ ewarn "action_modeswitch has been removed by upstream."
+ ewarn "Please use sys-apps/usb_modeswitch."
+
+ if ismounted /usr
+ then
+ ewarn
+ ewarn "Your system has /usr on a separate partition. This means"
+ ewarn "you will need to use an initramfs to pre-mount /usr before"
+ ewarn "udev runs."
+ ewarn "This must be set up before your next reboot, or you may"
+ ewarn "experience failures which are very difficult to troubleshoot."
+ ewarn "For a more detailed explanation, see the following URL:"
+ ewarn "http://www.freedesktop.org/wiki/Software/systemd/separate-usr-is-broken"
+ ewarn
+ ewarn "For more information on setting up an initramfs, see the"
+ ewarn "following URL:"
+ ewarn "http://www.gentoo.org/doc/en/initramfs-guide.xml"
+ fi
+
+ if use acl; then
+ ewarn
+ ewarn "The udev-acl functionality has been moved."
+ ewarn "If you are not using systemd, this is handled by consolekit."
+ ewarn "Otherwise, you need to make sure that systemd is emerged with"
+ ewarn "the acl use flag active."
+ fi
+
+ if [[ -d ${ROOT}lib/udev ]]
+ then
+ ewarn
+ ewarn "This version of udev moves the files which were installed in"
+ ewarn "/lib/udev to /usr/lib/udev. We include a backward compatibility"
+ ewarn "patch for gentoo to allow the rules in /lib/udev/rules.d to be"
+ ewarn "read; however, bugs should be filed against packages which are"
+ ewarn "installing things in /lib/udev so they can be fixed."
+ fi
+
+ ewarn
+ ewarn "You need to restart udev as soon as possible to make the upgrade go"
+ ewarn "into affect."
+ ewarn "The method you use to do this depends on your init system."
+
+ ewarn
+ ewarn "Upstream has removed the persistent-net and persistent-cd rules"
+ ewarn "generator. If you need persistent names for these devices,"
+ ewarn "place udev rules for them in ${ROOT}etc/udev/rules.d."
+ ewarn "Be aware that you cannot directly swap device names, so persistent"
+ ewarn "rules for network devices should be like the ones at the following"
+ ewarn "URL:"
+ ewarn "http://bugs.gentoo.org/show_bug.cgi?id=433746#C1"
+
+ preserve_old_lib_notify /$(get_libdir)/libudev.so.0
+
+ elog
+ elog "For more information on udev on Gentoo, writing udev rules, and"
+ elog " fixing known issues visit:"
+ elog " http://www.gentoo.org/doc/en/udev-guide.xml"
+}