summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2006-01-20 14:42:11 +0000
committerDaniel Drake <dsd@gentoo.org>2006-01-20 14:42:11 +0000
commit08640a13786372c66604c6b1c9074331a9bcb8cf (patch)
tree2d3636cfac342380c57d1de226e51117e2e18566 /sys-fs
parentRemoved virtual/x11 as we don't actually require any portions of X. (diff)
downloadgentoo-2-08640a13786372c66604c6b1c9074331a9bcb8cf.tar.gz
gentoo-2-08640a13786372c66604c6b1c9074331a9bcb8cf.tar.bz2
gentoo-2-08640a13786372c66604c6b1c9074331a9bcb8cf.zip
Readd build-on-demand support now that the eclass is fixed. Reported by Derk W te Bokkel in bug #117834
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse/ChangeLog7
-rw-r--r--sys-fs/fuse/fuse-2.4.2.ebuild7
-rw-r--r--sys-fs/fuse/fuse-2.5.0.ebuild7
3 files changed, 16 insertions, 5 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index b291d2e88a75..92effd5cb161 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.37 2006/01/16 15:10:48 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.38 2006/01/20 14:42:11 dsd Exp $
+
+ 20 Jan 2006; Daniel Drake <dsd@gentoo.org> fuse-2.4.2.ebuild,
+ fuse-2.5.0.ebuild:
+ Readd build-on-demand support now that the eclass is fixed. Reported by Derk
+ W te Bokkel in bug #117834
*fuse-2.5.0 (16 Jan 2006)
diff --git a/sys-fs/fuse/fuse-2.4.2.ebuild b/sys-fs/fuse/fuse-2.4.2.ebuild
index 656aa6b99e29..3f61580a3df3 100644
--- a/sys-fs/fuse/fuse-2.4.2.ebuild
+++ b/sys-fs/fuse/fuse-2.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.4.2.ebuild,v 1.3 2006/01/07 21:11:10 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.4.2.ebuild,v 1.4 2006/01/20 14:42:11 dsd Exp $
inherit linux-mod eutils
@@ -14,10 +14,13 @@ IUSE=""
S=${WORKDIR}/${MY_P}
MODULE_NAMES="fuse(fs:${S}/kernel)"
+CONFIG_CHECK="@FUSE_FS:fuse"
BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
fusemoduledir=${ROOT}/lib/modules/${KV_FULL}/fs"
BUILD_TARGETS="all"
-ECONF_PARAMS="--with-kernel=${KV_OUT_DIR} --enable-kernel-module"
+ECONF_PARAMS="--with-kernel=${KV_OUT_DIR}"
+FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
+We will continue, but we wont build the module this time."
src_unpack() {
unpack ${A}
diff --git a/sys-fs/fuse/fuse-2.5.0.ebuild b/sys-fs/fuse/fuse-2.5.0.ebuild
index 60ae12e2c7fe..644cff595375 100644
--- a/sys-fs/fuse/fuse-2.5.0.ebuild
+++ b/sys-fs/fuse/fuse-2.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.5.0.ebuild,v 1.1 2006/01/16 15:10:48 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.5.0.ebuild,v 1.2 2006/01/20 14:42:11 dsd Exp $
inherit linux-mod eutils
@@ -14,10 +14,13 @@ IUSE=""
S=${WORKDIR}/${MY_P}
MODULE_NAMES="fuse(fs:${S}/kernel)"
+CONFIG_CHECK="@FUSE_FS:fuse"
BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
fusemoduledir=${ROOT}/lib/modules/${KV_FULL}/fs"
BUILD_TARGETS="all"
-ECONF_PARAMS="--with-kernel=${KV_OUT_DIR} --enable-kernel-module"
+ECONF_PARAMS="--with-kernel=${KV_OUT_DIR}"
+FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
+We will continue, but we wont build the module this time."
src_unpack() {
unpack ${A}