summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-03-22 10:51:13 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-03-22 10:51:13 +0000
commit1ca866090be0100d0dd8351d06240cb3cbe6bdbf (patch)
tree88f817bbf5335d15f71c26e1e873b9bf29de4844 /sys-fs
parentRemove mask for tcsh-6.14-r32 which is no longer in the tree. (diff)
downloadgentoo-2-1ca866090be0100d0dd8351d06240cb3cbe6bdbf.tar.gz
gentoo-2-1ca866090be0100d0dd8351d06240cb3cbe6bdbf.tar.bz2
gentoo-2-1ca866090be0100d0dd8351d06240cb3cbe6bdbf.zip
Do not install run_directory, it is marked as strongly deprecated. No need for /dev/console redirect fix, Bug #151414. Do not call dmsetup from udev-start, as rules already do this. Use by-id method for usb and firewire cdrom persistence. Use higher priority for device-mapper persistent symlinks to overwrite symlinks of multipath base devices.
(Portage version: 2.1.2.2)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/udev/ChangeLog13
-rw-r--r--sys-fs/udev/files/64-device-mapper.rules-10728
-rw-r--r--sys-fs/udev/files/digest-udev-1073
-rw-r--r--sys-fs/udev/files/udev-107-usbcd-by-id.patch21
-rw-r--r--sys-fs/udev/files/udev-start-107.sh144
-rw-r--r--sys-fs/udev/udev-106-r5.ebuild4
-rw-r--r--sys-fs/udev/udev-107.ebuild292
7 files changed, 502 insertions, 3 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index 77d6c66a4f43..6cf5221d8f79 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sys-fs/udev
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.289 2007/03/21 13:51:45 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.290 2007/03/22 10:51:13 zzam Exp $
+
+*udev-107 (22 Mar 2007)
+
+ 22 Mar 2007; Matthias Schwarzott <zzam@gentoo.org>
+ +files/64-device-mapper.rules-107, +files/udev-107-usbcd-by-id.patch,
+ +files/udev-start-107.sh, udev-106-r5.ebuild, +udev-107.ebuild:
+ Do not install run_directory, it is marked as strongly deprecated. No need
+ for /dev/console redirect fix, Bug #151414. Do not call dmsetup from
+ udev-start, as rules already do this. Use by-id method for usb and firewire
+ cdrom persistence. Use higher priority for device-mapper persistent symlinks
+ to overwrite symlinks of multipath base devices.
21 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org> udev-104-r12.ebuild:
Stable on alpha wrt bug #159871.
diff --git a/sys-fs/udev/files/64-device-mapper.rules-107 b/sys-fs/udev/files/64-device-mapper.rules-107
new file mode 100644
index 000000000000..ad75792c5e04
--- /dev/null
+++ b/sys-fs/udev/files/64-device-mapper.rules-107
@@ -0,0 +1,28 @@
+# device mapper links hook into "change" events, when the dm table
+# becomes available; some table-types must be ignored
+
+KERNEL=="device-mapper", NAME="mapper/control"
+
+KERNEL=="dm-*", ACTION=="add|change", GOTO="device_mapper_do"
+GOTO="device_mapper_end"
+LABEL="device_mapper_do"
+
+# lookup device name
+# use dmsetup, until devmap_name is provided by sys-fs/device-mapper
+PROGRAM=="/sbin/dmsetup -j %M -m %m --noopencount --noheadings -c -o name info",
+ ENV{ID_DM_NAME}="%c"
+
+# do not do anything if dmsetup does not provide a name
+ENV{ID_DM_NAME}=="", NAME="", OPTIONS="ignore_device"
+
+# use queried name
+ENV{ID_DM_NAME}=="?*", NAME="mapper/$env{ID_DM_NAME}"
+
+PROGRAM!="/sbin/dmsetup status -j %M -m %m", GOTO="device_mapper_end"
+RESULT=="|*snapshot*|*error*", GOTO="device_mapper_end"
+
+IMPORT{program}="vol_id --export $tempnode"
+ENV{ID_FS_USAGE}=="filesystem|other|crypto", ENV{ID_FS_UUID}=="?*", SYMLINK+="disk/by-uuid/$env{ID_FS_UUID}", OPTIONS="link_priority=50"
+ENV{ID_FS_USAGE}=="filesystem|other", ENV{ID_FS_LABEL_SAFE}=="?*", SYMLINK+="disk/by-label/$env{ID_FS_LABEL_SAFE}", OPTIONS="link_priority=50"
+
+LABEL="device_mapper_end"
diff --git a/sys-fs/udev/files/digest-udev-107 b/sys-fs/udev/files/digest-udev-107
new file mode 100644
index 000000000000..991f2f0e4cf1
--- /dev/null
+++ b/sys-fs/udev/files/digest-udev-107
@@ -0,0 +1,3 @@
+MD5 b90dcb9d6d164fa34fe6632c506ce867 udev-107.tar.bz2 189101
+RMD160 ebc2722e0306aea3f3c0cd828861a61021609ac7 udev-107.tar.bz2 189101
+SHA256 49c45315ba640547939b2e2949f9478af2279a3296e97328ee8f6a4b08f2eae9 udev-107.tar.bz2 189101
diff --git a/sys-fs/udev/files/udev-107-usbcd-by-id.patch b/sys-fs/udev/files/udev-107-usbcd-by-id.patch
new file mode 100644
index 000000000000..4edfbf4214f9
--- /dev/null
+++ b/sys-fs/udev/files/udev-107-usbcd-by-id.patch
@@ -0,0 +1,21 @@
+diff --git a/extras/rule_generator/write_cd_rules b/extras/rule_generator/write_cd_rules
+index 1dbe6b7..bd951c5 100644
+--- a/extras/rule_generator/write_cd_rules
++++ b/extras/rule_generator/write_cd_rules
+@@ -53,7 +53,15 @@ fi
+ if [ "$1" ]; then
+ METHOD="$1"
+ else
+- METHOD='by-path'
++ case "$ID_BUS" in
++ usb|ieee1394)
++ METHOD='by-id'
++ ;;
++
++ *)
++ METHOD='by-path'
++ ;;
++ esac
+ fi
+
+ case "$METHOD" in
diff --git a/sys-fs/udev/files/udev-start-107.sh b/sys-fs/udev/files/udev-start-107.sh
new file mode 100644
index 000000000000..87094cf0d444
--- /dev/null
+++ b/sys-fs/udev/files/udev-start-107.sh
@@ -0,0 +1,144 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+populate_udev() {
+ # populate /dev with devices already found by the kernel
+
+ # tell modprobe.sh to be verbose to $CONSOLE
+ echo CONSOLE=${CONSOLE} > /dev/.udev_populate
+
+ if get_bootparam "nocoldplug" ; then
+ RC_COLDPLUG="no"
+ ewarn "Skipping udev coldplug as requested in kernel cmdline"
+ fi
+
+ if [ $(get_KV) -gt $(KV_to_int '2.6.14') ] ; then
+ ebegin "Populating /dev with existing devices through uevents"
+ local opts=
+ [ ${RC_COLDPLUG} != "yes" ] && opts="--attr-match=dev"
+ /sbin/udevtrigger ${opts}
+ eend $?
+ else
+ ebegin "Populating /dev with existing devices with udevstart"
+ /sbin/udevstart
+ eend $?
+ fi
+
+ # loop until everything is finished
+ # there's gotta be a better way...
+ ebegin "Letting udev process events"
+ /sbin/udevsettle --timeout=60
+ eend $?
+
+ rm -f /dev/.udev_populate
+ return 0
+}
+
+seed_dev() {
+ # Seed /dev with some things that we know we need
+ ebegin "Seeding /dev with needed nodes"
+
+ # creating /dev/console and /dev/tty1 to be able to write
+ # to $CONSOLE with/without bootsplash before udevd creates it
+ [ ! -c /dev/console ] && mknod /dev/console c 5 1
+ [ ! -c /dev/tty1 ] && mknod /dev/tty1 c 4 1
+
+ # udevd will dup its stdin/stdout/stderr to /dev/null
+ # and we do not want a file which gets buffered in ram
+ [ ! -c /dev/null ] && mknod /dev/null c 1 3
+
+ # copy over any persistant things
+ if [ -d /lib/udev/devices ] ; then
+ cp --preserve=all --recursive --update /lib/udev/devices/* /dev 2>/dev/null
+ fi
+
+ # Not provided by sysfs but needed
+ ln -snf /proc/self/fd /dev/fd
+ ln -snf fd/0 /dev/stdin
+ ln -snf fd/1 /dev/stdout
+ ln -snf fd/2 /dev/stderr
+ [ -e /proc/kcore ] && ln -snf /proc/kcore /dev/core
+
+ # Create problematic directories
+ mkdir -p /dev/pts /dev/shm
+ eend 0
+}
+
+unpack_device_tarball() {
+ # Actually get udev rolling
+ if [ "${RC_DEVICE_TARBALL}" = "yes" ] && \
+ [ -s /lib/udev/state/devices.tar.bz2 ] ; then
+ ebegin "Populating /dev with saved device nodes"
+ try tar -jxpf /lib/udev/state/devices.tar.bz2 -C /dev
+ eend $?
+ fi
+}
+
+main() {
+ # Setup temporary storage for /dev
+ ebegin "Mounting /dev for udev"
+ if [ "${RC_USE_FSTAB}" = "yes" ] ; then
+ mntcmd=$(get_mount_fstab /dev)
+ else
+ unset mntcmd
+ fi
+ if [ -n "${mntcmd}" ] ; then
+ try mount -n ${mntcmd}
+ else
+ if grep -Eq "[[:space:]]+tmpfs$" /proc/filesystems ; then
+ mntcmd="tmpfs"
+ else
+ mntcmd="ramfs"
+ fi
+ # many video drivers require exec access in /dev #92921
+ try mount -n -t "${mntcmd}" -o exec,nosuid,mode=0755 udev /dev
+ fi
+ eend $?
+
+ # Create a file so that our rc system knows it's still in sysinit.
+ # Existance means init scripts will not directly run.
+ # rc will remove the file when done with sysinit.
+ touch /dev/.rcsysinit
+
+ # Selinux lovin; /selinux should be mounted by selinux-patched init
+ if [ -x /sbin/restorecon ] && [ -c /selinux/null ] ; then
+ restorecon /dev > /selinux/null
+ fi
+
+ unpack_device_tarball
+ seed_dev
+
+ # Setup hotplugging (if possible)
+ if [ -e /proc/sys/kernel/hotplug ] ; then
+ ebegin "Setting up proper hotplug agent"
+ eindent
+ if [ $(get_KV) -gt $(KV_to_int '2.6.14') ] ; then
+ einfo "Using netlink for hotplug events..."
+ echo "" > /proc/sys/kernel/hotplug
+ else
+ einfo "Setting /sbin/udevsend as hotplug agent ..."
+ echo "/sbin/udevsend" > /proc/sys/kernel/hotplug
+ fi
+ eoutdent
+ eend 0
+ fi
+
+ ebegin "Starting udevd"
+ /sbin/udevd --daemon
+ eend $?
+
+ populate_udev
+
+ # Create nodes that udev can't
+ ebegin "Finalizing udev configuration"
+ [ -x /sbin/lvm ] && \
+ /sbin/lvm vgscan -P --mknodes --ignorelockingfailure &>/dev/null
+ # Running evms_activate on a LiveCD causes lots of headaches
+ [ -z "${CDBOOT}" ] && [ -x /sbin/evms_activate ] && \
+ /sbin/evms_activate -q &>/dev/null
+ eend 0
+}
+
+main
+
+# vim:ts=4
diff --git a/sys-fs/udev/udev-106-r5.ebuild b/sys-fs/udev/udev-106-r5.ebuild
index 5dbd7c8e9fd8..322e0fdec681 100644
--- a/sys-fs/udev/udev-106-r5.ebuild
+++ b/sys-fs/udev/udev-106-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-106-r5.ebuild,v 1.1 2007/03/19 18:49:00 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-106-r5.ebuild,v 1.2 2007/03/22 10:51:13 zzam Exp $
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -288,7 +288,7 @@ pkg_postinst() {
rm -f ${ROOT}/etc/udev/rules.d/95-net.rules
fi
fi
-
+
einfo
einfo "For more information on udev on Gentoo, writing udev rules, and"
einfo " fixing known issues visit:"
diff --git a/sys-fs/udev/udev-107.ebuild b/sys-fs/udev/udev-107.ebuild
new file mode 100644
index 000000000000..0d3d5346987b
--- /dev/null
+++ b/sys-fs/udev/udev-107.ebuild
@@ -0,0 +1,292 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-107.ebuild,v 1.1 2007/03/22 10:51:13 zzam Exp $
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Linux dynamic and persistent device naming support (aka userspace devfs)"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html"
+SRC_URI="mirror://kernel/linux/utils/kernel/hotplug/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="selinux"
+
+DEPEND="selinux? ( sys-libs/libselinux )"
+RDEPEND="!sys-apps/coldplug"
+RDEPEND="${DEPEND} ${RDEPEND}
+ >=sys-apps/baselayout-1.12.5"
+# We need the lib/rcscripts/addon support
+PROVIDE="virtual/dev-manager"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # patches go here...
+ #epatch ${FILESDIR}/${P}-udev_volume_id.patch
+ epatch ${FILESDIR}/${PN}-104-peristent-net-disable-xen.patch
+ epatch ${FILESDIR}/udev-107-usbcd-by-id.patch
+
+ # No need to clutter the logs ...
+ sed -ie '/^DEBUG/ c\DEBUG = false' Makefile
+ # Do not use optimization flags from the package
+ sed -ie 's|$(OPTIMIZATION)||g' Makefile
+
+ # Make sure there is no sudden changes to udev.rules.gentoo
+ # (more for my own needs than anything else ...)
+ MD5=`md5sum < "${S}/etc/udev/gentoo/udev.rules"`
+ MD5=${MD5/ -/}
+ if [ "${MD5}" != "34b1f1695b339d0d9e7b9db27f87e938" ]
+ then
+ echo
+ eerror "gentoo/udev.rules has been updated, please validate!"
+ die "gentoo/udev.rules has been updated, please validate!"
+ fi
+}
+
+src_compile() {
+ filter-flags -fprefetch-loop-arrays
+ local myconf=
+ local extras="extras/ata_id \
+ extras/cdrom_id \
+ extras/edd_id \
+ extras/firmware \
+ extras/floppy \
+ extras/path_id \
+ extras/scsi_id \
+ extras/usb_id \
+ extras/volume_id \
+ extras/rule_generator"
+
+ use selinux && myconf="${myconf} USE_SELINUX=true"
+
+ # Not everyone has full $CHOST-{ld,ar,etc...} yet
+ local mycross=""
+ type -p ${CHOST}-ar && mycross=${CHOST}-
+
+ echo "get_libdir = $(get_libdir)"
+ # Do not work with emake
+ make \
+ EXTRAS="${extras}" \
+ udevdir="/dev/" \
+ CROSS_COMPILE=${mycross} \
+ ${myconf} || die
+}
+
+src_install() {
+ # we install everything by "hand" and don't rely on the udev Makefile to do
+ # it for us (why? it's easier that way...)
+ dobin udevinfo || die "Required binary not installed properly"
+ dobin udevtest || die "Required binary not installed properly"
+ dobin udevmonitor || die "Required binary not installed properly"
+ into /
+ dosbin udevd || die "Required binary not installed properly"
+ dosbin udevstart || die "Required binary not installed properly"
+ dosbin udevtrigger || die "Required binary not installed properly"
+ dosbin udevcontrol || die "Required binary not installed properly"
+ dosbin udevsettle || die "Required binary not installed properly"
+
+ # Helpers
+ exeinto /lib/udev
+ doexe extras/ata_id/ata_id || die "Required helper not installed properly"
+ doexe extras/volume_id/vol_id || die "Required helper not installed properly"
+ doexe extras/scsi_id/scsi_id || die "Required helper not installed properly"
+ doexe extras/usb_id/usb_id || die "Required helper not installed properly"
+ doexe extras/path_id/path_id || die "Required helper not installed properly"
+ doexe extras/cdrom_id/cdrom_id || die "Required helper not installed properly"
+ doexe extras/edd_id/edd_id || die "Required helper not installed properly"
+ doexe extras/rule_generator/write_cd_rules || die "Required helper not installed properly"
+ doexe extras/rule_generator/write_net_rules || die "Required helper not installed properly"
+ doexe extras/rule_generator/rule_generator.functions || die "Required helper not installed properly"
+ keepdir /lib/udev/state
+ keepdir /lib/udev/devices
+
+ # create symlinks for these utilities to /sbin
+ # where multipath-tools expect them to be (Bug #168588)
+ dosym ../lib/udev/vol_id /sbin/vol_id
+ dosym ../lib/udev/scsi_id /sbin/scsi_id
+
+ # vol_id library (needed by mount and HAL)
+ dolib extras/volume_id/lib/*.a extras/volume_id/lib/*.so*
+ # move the .a files to /usr/lib
+ dodir /usr/$(get_libdir)
+ mv -f "${D}"/$(get_libdir)/*.a "${D}"/usr/$(get_libdir)/
+
+ # handle static linking bug #4411
+ gen_usr_ldscript libvolume_id.so
+
+ # save pkgconfig info
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins extras/volume_id/lib/*.pc
+
+ #exeinto /etc/udev/scripts
+ exeinto /lib/udev
+ #doexe extras/ide-devfs.sh
+ #doexe extras/scsi-devfs.sh
+ #doexe extras/raid-devfs.sh
+ doexe extras/floppy/create_floppy_devices || die "Required binary not installed properly"
+ doexe extras/firmware/firmware.sh || die "Required binary not installed properly"
+ newexe ${FILESDIR}/net-104-r10.sh net.sh || die "Required binary not installed properly"
+ newexe ${FILESDIR}/modprobe-105.sh modprobe.sh || die "Required binary not installed properly"
+ doexe extras/eventrecorder.sh || die "Required binary not installed properly"
+
+ # Our udev config file
+ insinto /etc/udev
+ newins ${FILESDIR}/udev.conf.post_081 udev.conf
+
+ # Our rules files
+ insinto /etc/udev/rules.d/
+ newins etc/udev/gentoo/udev.rules 50-udev.rules
+ newins ${FILESDIR}/udev.rules-106-r5 50-udev.rules
+ newins ${FILESDIR}/05-udev-early.rules-106-r5 05-udev-early.rules
+ doins ${FILESDIR}/95-udev-late.rules
+ # Use upstream's persistent rules for devices
+ doins etc/udev/rules.d/60-*.rules
+ doins extras/rule_generator/75-*.rules || die "rules not installed properly"
+ # Special rules for device-mapper
+ newins ${FILESDIR}/64-device-mapper.rules-107 64-device-mapper.rules
+
+ # scsi_id configuration
+ insinto /etc
+ doins extras/scsi_id/scsi_id.config
+
+ # set up the /etc/dev.d directory tree
+ keepdir /etc/dev.d
+
+ # all of the man pages
+ doman *.7
+ doman *.8
+ doman extras/ata_id/ata_id.8
+ doman extras/edd_id/edd_id.8
+ doman extras/scsi_id/scsi_id.8
+ doman extras/volume_id/vol_id.8
+ doman extras/cdrom_id/cdrom_id.8
+ # create a extra symlink for udevcontrol
+ dosym udevd.8 /usr/share/man/man8/udevcontrol.8
+
+ # our udev hooks into the rc system
+ insinto /lib/rcscripts/addons
+ newins "${FILESDIR}"/udev-start-107.sh udev-start.sh
+ newins "${FILESDIR}"/udev-stop-105.sh udev-stop.sh
+
+ # needed to compile latest Hal
+ insinto /usr/include
+ doins extras/volume_id/lib/libvolume_id.h
+
+ dodoc ChangeLog FAQ README TODO RELEASE-NOTES
+ dodoc docs/{overview,udev_vs_devfs}
+ dodoc docs/writing_udev_rules/*
+
+ newdoc extras/volume_id/README README_volume_id
+
+ insinto /etc/modprobe.d
+ doins ${FILESDIR}/blacklist ${FILESDIR}/pnp-aliases
+
+ if use s390; then
+ # s390 does not has persistent mac addresses
+ # and we only have persistence rules for mac.
+ # For now just remove the rules file.
+ rm ${D}/etc/udev/rules.d/75-persistent-net-generator.rules
+ fi
+
+}
+
+pkg_preinst() {
+ if [[ -d ${ROOT}/lib/udev-state ]] ; then
+ mv -f "${ROOT}"/lib/udev-state/* "${D}"/lib/udev/state/
+ rm -r "${ROOT}"/lib/udev-state
+ fi
+
+ if [ -f "${ROOT}/etc/udev/udev.config" -a \
+ ! -f "${ROOT}/etc/udev/udev.rules" ]
+ then
+ mv -f ${ROOT}/etc/udev/udev.config ${ROOT}/etc/udev/udev.rules
+ fi
+
+ # delete the old udev.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/udev.hotplug" ]
+ then
+ rm -f ${ROOT}/etc/hotplug.d/default/udev.hotplug
+ fi
+
+ # delete the old wait_for_sysfs.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/05-wait_for_sysfs.hotplug" ]
+ then
+ rm -f ${ROOT}/etc/hotplug.d/default/05-wait_for_sysfs.hotplug
+ fi
+
+ # delete the old wait_for_sysfs.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/10-udev.hotplug" ]
+ then
+ rm -f ${ROOT}/etc/hotplug.d/default/10-udev.hotplug
+ fi
+
+ # is there a stale coldplug initscript? (CONFIG_PROTECT leaves it behind)
+ coldplug_stale=""
+ if [ -f "${ROOT}/etc/init.d/coldplug" ]
+ then
+ coldplug_stale="1"
+ fi
+}
+
+pkg_postinst() {
+ if [[ ${ROOT} == "/" ]] ; then
+ # check if root of init-process is identical to ours
+ if [ -r /proc/1/root -a /proc/1/root/ -ef /proc/self/root/ ]; then
+ einfo "restarting udevd now."
+ if [[ -n $(pidof udevd) ]] ; then
+ killall -15 udevd &>/dev/null
+ sleep 1
+ killall -9 udevd &>/dev/null
+ fi
+ /sbin/udevd --daemon
+ fi
+ fi
+
+ # people want reminders, I'll give them reminders. Odds are they will
+ # just ignore them anyway...
+
+ if [[ ${coldplug_stale} == "1" ]] ; then
+ ewarn "A stale coldplug init script found. You should run:"
+ ewarn
+ ewarn " rc-update del coldplug"
+ ewarn " rm -f /etc/init.d/coldplug"
+ ewarn
+ ewarn "udev now provides its own coldplug functionality."
+ fi
+
+ # delete 40-scsi-hotplug.rules - all integrated in 50-udev.rules
+ if has_version "=sys-fs/udev-103-r3"; then
+ if [[ -e "${ROOT}/etc/udev/rules.d/40-scsi-hotplug.rules" ]]
+ then
+ ewarn "Deleting stray 40-scsi-hotplug.rules"
+ ewarn "installed by sys-fs/udev-103-r3"
+ rm -f ${ROOT}/etc/udev/rules.d/40-scsi-hotplug.rules
+ fi
+ fi
+
+ # Removing some device-nodes we thought we need some time ago
+ if [[ -d "${ROOT}"/lib/udev/devices ]]; then
+ rm -f "${ROOT}"/lib/udev/devices/{null,zero,console,urandom}
+ fi
+
+ # Removing some old file
+ if has_version "<sys-fs/udev-104-r5"; then
+ rm -f "${ROOT}"/etc/dev.d/net/hotplug.dev
+ rmdir --ignore-fail-on-non-empty "${ROOT}"/etc/dev.d/net
+ fi
+
+ if has_version "<sys-fs/udev-106-r5"; then
+ if [[ -e ${ROOT}/etc/udev/rules.d/95-net.rules ]]; then
+ rm -f ${ROOT}/etc/udev/rules.d/95-net.rules
+ fi
+ fi
+
+ einfo
+ einfo "For more information on udev on Gentoo, writing udev rules, and"
+ einfo " fixing known issues visit:"
+ einfo " http://www.gentoo.org/doc/en/udev-guide.xml"
+}