summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2006-12-25 18:12:06 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2006-12-25 18:12:06 +0000
commit1cd4745a2bc4fa951fe35085341f943e13956ff4 (patch)
tree39789d08673f5a9ea26f36f8f03892b34cdf3b0e /sys-fs
parentdebug USE flag for disabling the debugger (diff)
downloadgentoo-2-1cd4745a2bc4fa951fe35085341f943e13956ff4.tar.gz
gentoo-2-1cd4745a2bc4fa951fe35085341f943e13956ff4.tar.bz2
gentoo-2-1cd4745a2bc4fa951fe35085341f943e13956ff4.zip
Added --disable-local-dpath --disable-chroot-support to support SMP, closes bug#159067, thanks to Michael Cramer for reporting this
(Portage version: 2.1.1-r2)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/dazuko/ChangeLog8
-rw-r--r--sys-fs/dazuko/dazuko-2.3.2-r3.ebuild92
-rw-r--r--sys-fs/dazuko/files/digest-dazuko-2.3.2-r36
3 files changed, 105 insertions, 1 deletions
diff --git a/sys-fs/dazuko/ChangeLog b/sys-fs/dazuko/ChangeLog
index 6c431cfdbae3..f355ce1a4169 100644
--- a/sys-fs/dazuko/ChangeLog
+++ b/sys-fs/dazuko/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/dazuko
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.15 2006/12/20 19:44:13 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.16 2006/12/25 18:12:06 alonbl Exp $
+
+*dazuko-2.3.2-r3 (25 Dec 2006)
+
+ 25 Dec 2006; Alon Bar-Lev <alonbl@gentoo.org> +dazuko-2.3.2-r3.ebuild:
+ Added --disable-local-dpath --disable-chroot-support to support SMP, closes
+ bug#159067, thanks to Michael Cramer for reporting this
20 Dec 2006; Alon Bar-Lev <alonbl@gentoo.org> dazuko-2.3.2-r2.ebuild:
fbsd support, closes bug#158647, thanks for Timothy Redaelli
diff --git a/sys-fs/dazuko/dazuko-2.3.2-r3.ebuild b/sys-fs/dazuko/dazuko-2.3.2-r3.ebuild
new file mode 100644
index 000000000000..96bc829468d9
--- /dev/null
+++ b/sys-fs/dazuko/dazuko-2.3.2-r3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.3.2-r3.ebuild,v 1.1 2006/12/25 18:12:06 alonbl Exp $
+inherit linux-mod toolchain-funcs flag-o-matic
+
+DESCRIPTION="Linux kernel module and interface providing file access control"
+MY_P="${P/_/-}" # for -preN versions
+SRC_URI="http://www.dazuko.org/files/${MY_P}.tar.gz
+ mirror://gentoo/${P}-linux-2.6.19.patch.bz2"
+HOMEPAGE="http://www.dazuko.org"
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND="kernel_linux? ( >=virtual/linux-sources-2.2 )"
+RDEPEND=${DEPEND}
+S="${WORKDIR}/${MY_P}"
+
+# kernel settings
+CONFIG_CHECK="SECURITY_CAPABILITIES"
+MODULE_NAMES="dazuko(misc:)"
+BUILD_TARGETS="dummy_rule"
+
+pkg_setup() {
+ [ "${KERNEL}" = "linux" ] && linux-mod_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-2.3.1-suspend2.patch"
+
+ if [ "${KERNEL}" == "linux" ] && kernel_is 2 6 19; then
+ epatch "${WORKDIR}/${P}-linux-2.6.19.patch"
+ fi
+}
+
+src_compile() {
+ if [ "${KERNEL}" = "FreeBSD" ]; then
+ KERNEL_DIR=/usr/src/sys
+ KBUILD_OUTPUT=/boot/modules
+ MAKE=make
+ fi
+ ./configure \
+ --without-dep \
+ --disable-local-dpath \
+ --disable-chroot-support \
+ --kernelsrcdir="${KERNEL_DIR}" \
+ --kernelobjdir="${KBUILD_OUTPUT}" \
+ || die "configure failed"
+
+ if [ "${KERNEL}" = "linux" ]; then
+ convert_to_m Makefile
+ linux-mod_src_compile
+ else
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" LDFLAGS="$(raw-ldflags)" || die
+ fi
+
+ emake -C library CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ if [ "${KERNEL}" = "linux" ]; then
+ linux-mod_src_install
+ else
+ insinto /boot/modules
+ doins "${S}"/dazuko.kld
+ exeinto /boot/modules
+ doexe "${S}"/dazuko.ko
+ fi
+
+ dolib.a library/libdazuko.a
+ insinto /usr/include
+ doins dazukoio.h
+
+ dodoc COPYING
+ dodoc README
+ dodoc README.linux26
+ dodoc README.trusted
+}
+
+pkg_postinst() {
+ [ "${KERNEL}" = "linux" ] && linux-mod_pkg_postinst
+
+ einfo "Please note that chroot support is disabled due to incompatability "
+ einfo "with SMP kernels"
+}
+
+pkg_postrm() {
+ [ "${KERNEL}" = "linux" ] && linux-mod_pkg_postrm
+}
+
diff --git a/sys-fs/dazuko/files/digest-dazuko-2.3.2-r3 b/sys-fs/dazuko/files/digest-dazuko-2.3.2-r3
new file mode 100644
index 000000000000..fee1e7bfde35
--- /dev/null
+++ b/sys-fs/dazuko/files/digest-dazuko-2.3.2-r3
@@ -0,0 +1,6 @@
+MD5 e82799830e44dc2b5dfc9d355bcc5b2e dazuko-2.3.2-linux-2.6.19.patch.bz2 4706
+RMD160 09a635922d364f73e6f32787397e3657d2ec8087 dazuko-2.3.2-linux-2.6.19.patch.bz2 4706
+SHA256 239c514ddb4345d758706c50c286b125d3e35e476931bec0909bdf15c80c8d06 dazuko-2.3.2-linux-2.6.19.patch.bz2 4706
+MD5 bb32e24ad60a31dbfc419d3341287f68 dazuko-2.3.2.tar.gz 177134
+RMD160 57fd3dd45a61609a18829467966657ef658ed500 dazuko-2.3.2.tar.gz 177134
+SHA256 b396fc344cf1bad0d7dfb6675573a8ca189f34867fe1256c7f31c8ec9aab45bb dazuko-2.3.2.tar.gz 177134