summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-05-14 08:48:42 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-05-14 08:48:42 +0000
commit30e7f1195357f2b2157c0902d59fe06c13cf472a (patch)
treed6ba38140ca7aa8da287e34539a905b3b92d7312 /sys-fs
parentDrop old version. (diff)
downloadgentoo-2-30e7f1195357f2b2157c0902d59fe06c13cf472a.tar.gz
gentoo-2-30e7f1195357f2b2157c0902d59fe06c13cf472a.tar.bz2
gentoo-2-30e7f1195357f2b2157c0902d59fe06c13cf472a.zip
Version bump per Bug #178455.
(Portage version: 2.1.2.7)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/device-mapper/ChangeLog8
-rw-r--r--sys-fs/device-mapper/device-mapper-1.02.19.ebuild55
-rw-r--r--sys-fs/device-mapper/files/digest-device-mapper-1.02.193
3 files changed, 65 insertions, 1 deletions
diff --git a/sys-fs/device-mapper/ChangeLog b/sys-fs/device-mapper/ChangeLog
index 8b49bd055ea4..5246493a2993 100644
--- a/sys-fs/device-mapper/ChangeLog
+++ b/sys-fs/device-mapper/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/device-mapper
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/device-mapper/ChangeLog,v 1.61 2007/05/12 18:46:14 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/device-mapper/ChangeLog,v 1.62 2007/05/14 08:48:42 robbat2 Exp $
+
+*device-mapper-1.02.19 (14 May 2007)
+
+ 14 May 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +device-mapper-1.02.19.ebuild:
+ Version bump per Bug #178455.
12 May 2007; Joshua Kinard <kumba@gentoo.org>
device-mapper-1.02.10-r1.ebuild:
diff --git a/sys-fs/device-mapper/device-mapper-1.02.19.ebuild b/sys-fs/device-mapper/device-mapper-1.02.19.ebuild
new file mode 100644
index 000000000000..6446837bee21
--- /dev/null
+++ b/sys-fs/device-mapper/device-mapper-1.02.19.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/device-mapper/device-mapper-1.02.19.ebuild,v 1.1 2007/05/14 08:48:42 robbat2 Exp $
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Device mapper ioctl library for use with LVM2 utilities"
+HOMEPAGE="http://sources.redhat.com/dm/"
+SRC_URI="ftp://sources.redhat.com/pub/dm/${PN}.${PV}.tgz
+ ftp://sources.redhat.com/pub/dm/old/${PN}.${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux"
+
+DEPEND="selinux? ( sys-libs/libselinux )"
+
+S=${WORKDIR}/${PN}.${PV}
+
+src_compile() {
+ econf --sbindir=/sbin $(use_enable selinux) || die "econf failed"
+ emake || die "compile problem"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+
+ # move shared libs to /
+ mv "${D}"/usr/$(get_libdir) "${D}"/ || die "move libdir"
+ dolib.a lib/ioctl/libdevmapper.a || die "dolib.a"
+ gen_usr_ldscript libdevmapper.so
+
+ insinto /etc
+ doins "${FILESDIR}"/dmtab
+ insinto /lib/rcscripts/addons
+ doins "${FILESDIR}"/dm-start.sh
+
+ newinitd ${FILESDIR}/device-mapper.rc device-mapper || die
+
+ dodoc INSTALL INTRO README VERSION WHATS_NEW
+}
+
+pkg_preinst() {
+ local l=${ROOT}/$(get_libdir)/libdevmapper.so.1.01
+ [[ -e ${l} ]] && cp "${l}" "${D}"/$(get_libdir)/
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /$(get_libdir)/libdevmapper.so.1.01
+
+ elog "device-mapper volumes are no longer automatically created for"
+ elog "baselayout-2 users. If you are using baselayout-2, be sure to"
+ elog "run: # rc-update add device-mapper boot"
+}
diff --git a/sys-fs/device-mapper/files/digest-device-mapper-1.02.19 b/sys-fs/device-mapper/files/digest-device-mapper-1.02.19
new file mode 100644
index 000000000000..82157204a9af
--- /dev/null
+++ b/sys-fs/device-mapper/files/digest-device-mapper-1.02.19
@@ -0,0 +1,3 @@
+MD5 37cb592a1fa8fc31dc00cb437bbb4969 device-mapper.1.02.19.tgz 183064
+RMD160 00b584c67856ab18323bcc2918aed5ac4198cb65 device-mapper.1.02.19.tgz 183064
+SHA256 4723a4ba55e10c58a4e1bd7551e1e7d90ce43d3fcdabfd78285d39c2d33cdead device-mapper.1.02.19.tgz 183064