summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-05-22 21:41:18 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-05-22 21:41:18 +0000
commit46032c7fb2caf48ee84f5ed981b0e253e41e43c4 (patch)
tree54189f20c63a5ec3766764a1713b22e8467e2b64 /sys-fs
parentVersion bump. (diff)
downloadgentoo-2-46032c7fb2caf48ee84f5ed981b0e253e41e43c4.tar.gz
gentoo-2-46032c7fb2caf48ee84f5ed981b0e253e41e43c4.tar.bz2
gentoo-2-46032c7fb2caf48ee84f5ed981b0e253e41e43c4.zip
Do not print modprobe-errors. Do some locking to not get multiple concurrent modprobe calls for same module, and no multiple loading messages.
(Portage version: 2.1.2.7)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/udev/ChangeLog9
-rw-r--r--sys-fs/udev/files/digest-udev-111-r13
-rwxr-xr-xsys-fs/udev/files/modprobe-111-r1.sh68
-rw-r--r--sys-fs/udev/udev-111-r1.ebuild315
4 files changed, 394 insertions, 1 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index ed99df8e23c3..e3207371384a 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/udev
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.307 2007/05/16 10:31:30 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.308 2007/05/22 21:41:18 zzam Exp $
+
+*udev-111-r1 (22 May 2007)
+
+ 22 May 2007; Matthias Schwarzott <zzam@gentoo.org>
+ +files/modprobe-111-r1.sh, +udev-111-r1.ebuild:
+ Do not print modprobe-errors. Do some locking to not get multiple concurrent
+ modprobe calls for same module, and no multiple loading messages.
16 May 2007; Matthias Schwarzott <zzam@gentoo.org> udev-111.ebuild:
Use /get_libdir/udev, instead of /lib/udev.
diff --git a/sys-fs/udev/files/digest-udev-111-r1 b/sys-fs/udev/files/digest-udev-111-r1
new file mode 100644
index 000000000000..6cefddeda901
--- /dev/null
+++ b/sys-fs/udev/files/digest-udev-111-r1
@@ -0,0 +1,3 @@
+MD5 bd2a94e3ed243e6a3d501a5c8afc4b54 udev-111.tar.bz2 190020
+RMD160 bb3f1c2b1e24092b42507b663eceffe17f8a4a06 udev-111.tar.bz2 190020
+SHA256 ec47cc46b15838321c31589d7bdbdcf553c0ea4f406edc6f239cb20a3732c233 udev-111.tar.bz2 190020
diff --git a/sys-fs/udev/files/modprobe-111-r1.sh b/sys-fs/udev/files/modprobe-111-r1.sh
new file mode 100755
index 000000000000..7516096e8457
--- /dev/null
+++ b/sys-fs/udev/files/modprobe-111-r1.sh
@@ -0,0 +1,68 @@
+#!/bin/sh
+
+# Do not continue for non-modular kernel - Bug #168322
+[ ! -f /proc/modules ] && exit 0
+
+if [ -e /dev/.udev_populate ]; then
+ # Enable verbose while called from udev-addon-start
+ . /dev/.udev_populate
+
+ if [ -c "${CONSOLE}" ]; then
+ # redirect stdin/out/err
+ exec <${CONSOLE} >${CONSOLE} 2>/${CONSOLE}
+ fi
+fi
+
+. /etc/init.d/functions.sh
+
+MODPROBE=/sbin/modprobe
+
+# Create a lock file for the current module.
+lock_modprobe() {
+ [ -e /dev/.udev/ ] || return 0
+
+ MODPROBE_LOCK="/dev/.udev/.lock-modprobe-${MODNAME}"
+
+ retry=20
+ while ! mkdir "$MODPROBE_LOCK" 2> /dev/null; do
+ if [ $retry -eq 0 ]; then
+ ewarn "Could lock modprobe ${MODNAME}!"
+ return 1
+ fi
+ sleep 1
+ retry=$(($retry - 1))
+ done
+ return 0
+}
+
+unlock_modprobe() {
+ [ "$MODPROBE_LOCK" ] || return 0
+ rmdir "$MODPROBE_LOCK" || true
+}
+
+MODLIST=$("${MODPROBE}" -q -i --show-depends "${@}" 2>/dev/null \
+ | sed -e "s#^insmod /lib.*/\(.*\)\.ko.*#\1#g" -e 's|-|_|g')
+
+# exit if you have no modules to load
+[ -z "${MODLIST}" ] && exit 0
+for m in ${MODLIST}; do
+ MODNAME=$m
+done
+
+# check for blacklisting
+if [ -f /etc/modprobe.conf ]; then
+ if grep -q '^blacklist.*[[:space:]]'"${MODNAME}"'\([[:space:]]\|$\)' /etc/modprobe.conf; then
+ # module blacklisted
+ exit 0
+ fi
+fi
+
+lock_modprobe
+# check if loaded
+if ! grep -q "^${MODNAME}[[:space:]]" /proc/modules; then
+ # now do real loading
+ einfo " udev loading module ${MODNAME}"
+ "${MODPROBE}" -q "${@}" >/dev/null 2>/dev/null
+fi
+unlock_modprobe
+
diff --git a/sys-fs/udev/udev-111-r1.ebuild b/sys-fs/udev/udev-111-r1.ebuild
new file mode 100644
index 000000000000..1c3a8f193209
--- /dev/null
+++ b/sys-fs/udev/udev-111-r1.ebuild
@@ -0,0 +1,315 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-111-r1.ebuild,v 1.1 2007/05/22 21:41:18 zzam Exp $
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Linux dynamic and persistent device naming support (aka userspace devfs)"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html"
+SRC_URI="mirror://kernel/linux/utils/kernel/hotplug/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux"
+
+DEPEND="selinux? ( sys-libs/libselinux )"
+RDEPEND="!sys-apps/coldplug"
+RDEPEND="${DEPEND} ${RDEPEND}
+ >=sys-apps/baselayout-1.12.5"
+# We need the lib/rcscripts/addon support
+PROVIDE="virtual/dev-manager"
+
+pkg_setup() {
+ udev_helper_dir="/$(get_libdir)/udev"
+}
+
+sed_helper_dir() {
+ sed -e "s#/lib/udev#${udev_helper_dir}#" -i "$@"
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # patches go here...
+ epatch ${FILESDIR}/${PN}-104-peristent-net-disable-xen.patch
+ EPATCH_OPTS="-p1" epatch ${FILESDIR}/${PN}-110-root-link-1.diff
+
+ # No need to clutter the logs ...
+ sed -ie '/^DEBUG/ c\DEBUG = false' Makefile
+ # Do not use optimization flags from the package
+ sed -ie 's|$(OPTIMIZATION)||g' Makefile
+
+ # Make sure there is no sudden changes to udev.rules.gentoo
+ # (more for my own needs than anything else ...)
+ MD5=`md5sum < "${S}/etc/udev/gentoo/50-udev.rules"`
+ MD5=${MD5/ -/}
+ if [ "${MD5}" != "04a8f3303a2b172affbed26973745f26" ]
+ then
+ echo
+ eerror "gentoo/udev.rules has been updated, please validate!"
+ die "gentoo/udev.rules has been updated, please validate!"
+ fi
+
+ sed_helper_dir \
+ etc/udev/gentoo/50-udev.rules \
+ extras/rule_generator/write_*_rules \
+ udev_rules_parse.c \
+ udev_utils_run.c
+}
+
+src_compile() {
+ filter-flags -fprefetch-loop-arrays
+ local myconf=
+ local extras="extras/ata_id \
+ extras/cdrom_id \
+ extras/edd_id \
+ extras/firmware \
+ extras/floppy \
+ extras/path_id \
+ extras/scsi_id \
+ extras/usb_id \
+ extras/volume_id \
+ extras/rule_generator \
+ extras/root_link"
+
+ use selinux && myconf="${myconf} USE_SELINUX=true"
+
+ # Not everyone has full $CHOST-{ld,ar,etc...} yet
+ local mycross=""
+ type -p ${CHOST}-ar && mycross=${CHOST}-
+
+ echo "get_libdir = $(get_libdir)"
+ emake \
+ EXTRAS="${extras}" \
+ udevdir="/dev/" \
+ CROSS_COMPILE=${mycross} \
+ OPTFLAGS="" \
+ ${myconf} || die
+}
+
+src_install() {
+ # we install everything by "hand" and don't rely on the udev Makefile to do
+ # it for us (why? it's easier that way...)
+ dobin udevinfo || die "Required binary not installed properly"
+ dobin udevtest || die "Required binary not installed properly"
+ dobin udevmonitor || die "Required binary not installed properly"
+ into /
+ dosbin udevd || die "Required binary not installed properly"
+ dosbin udevstart || die "Required binary not installed properly"
+ dosbin udevtrigger || die "Required binary not installed properly"
+ dosbin udevcontrol || die "Required binary not installed properly"
+ dosbin udevsettle || die "Required binary not installed properly"
+
+ # Helpers
+ exeinto "${udev_helper_dir}"
+ doexe extras/ata_id/ata_id || die "Required helper not installed properly"
+ doexe extras/volume_id/vol_id || die "Required helper not installed properly"
+ doexe extras/scsi_id/scsi_id || die "Required helper not installed properly"
+ doexe extras/usb_id/usb_id || die "Required helper not installed properly"
+ doexe extras/path_id/path_id || die "Required helper not installed properly"
+ doexe extras/cdrom_id/cdrom_id || die "Required helper not installed properly"
+ doexe extras/edd_id/edd_id || die "Required helper not installed properly"
+ doexe extras/rule_generator/write_cd_rules || die "Required helper not installed properly"
+ doexe extras/rule_generator/write_net_rules || die "Required helper not installed properly"
+ doexe extras/rule_generator/rule_generator.functions || die "Required helper not installed properly"
+ doexe extras/root_link/get_dir_major_minor || die "Required helper not installed properly"
+ doexe extras/floppy/create_floppy_devices || die "Required binary not installed properly"
+ doexe extras/firmware/firmware.sh || die "Required binary not installed properly"
+ newexe ${FILESDIR}/net-104-r10.sh net.sh || die "Required binary not installed properly"
+ newexe ${FILESDIR}/modprobe-111-r1.sh modprobe.sh || die "Required binary not installed properly"
+
+ keepdir "${udev_helper_dir}"/state
+ keepdir "${udev_helper_dir}"/devices
+
+ # create symlinks for these utilities to /sbin
+ # where multipath-tools expect them to be (Bug #168588)
+ dosym "..${udev_helper_dir}/vol_id" /sbin/vol_id
+ dosym "..${udev_helper_dir}/scsi_id" /sbin/scsi_id
+
+ # vol_id library (needed by mount and HAL)
+ dolib extras/volume_id/lib/*.a extras/volume_id/lib/*.so*
+ # move the .a files to /usr/lib
+ dodir /usr/$(get_libdir)
+ mv -f "${D}"/$(get_libdir)/*.a "${D}"/usr/$(get_libdir)/
+
+ # handle static linking bug #4411
+ gen_usr_ldscript libvolume_id.so
+
+ # save pkgconfig info
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins extras/volume_id/lib/*.pc
+
+
+ # Our udev config file
+ insinto /etc/udev
+ newins ${FILESDIR}/udev.conf.post_108 udev.conf
+
+ # Our rules files
+ insinto /etc/udev/rules.d/
+ doins etc/udev/gentoo/??-*.rules
+ #newins ${FILESDIR}/udev.rules-107-r1 50-udev.rules
+ #newins ${FILESDIR}/05-udev-early.rules-106-r5 05-udev-early.rules
+ #doins ${FILESDIR}/95-udev-late.rules
+ # Special rules for device-mapper
+ #newins ${FILESDIR}/64-device-mapper.rules-107-r1 64-device-mapper.rules
+ # Use upstream's persistent rules for devices
+ doins etc/udev/rules.d/60-*.rules
+ doins extras/rule_generator/75-*.rules || die "rules not installed properly"
+
+ # scsi_id configuration
+ insinto /etc
+ doins extras/scsi_id/scsi_id.config
+
+ # all of the man pages
+ doman *.7
+ doman *.8
+ doman extras/ata_id/ata_id.8
+ doman extras/edd_id/edd_id.8
+ doman extras/scsi_id/scsi_id.8
+ doman extras/volume_id/vol_id.8
+ doman extras/cdrom_id/cdrom_id.8
+ # create a extra symlink for udevcontrol
+ dosym udevd.8 /usr/share/man/man8/udevcontrol.8
+
+ # our udev hooks into the rc system
+ insinto /$(get_libdir)/rcscripts/addons
+ newins "${FILESDIR}"/udev-start-110-r1.sh udev-start.sh
+ newins "${FILESDIR}"/udev-stop-110-r1.sh udev-stop.sh
+
+ # convert /lib/udev to real used dir
+ sed_helper_dir "${D}/$(get_libdir)"/rcscripts/addons/*.sh
+
+ # needed to compile latest Hal
+ insinto /usr/include
+ doins extras/volume_id/lib/libvolume_id.h
+
+ dodoc ChangeLog FAQ README TODO RELEASE-NOTES
+ dodoc docs/{overview,udev_vs_devfs}
+ dodoc docs/writing_udev_rules/*
+
+ newdoc extras/volume_id/README README_volume_id
+
+ insinto /etc/modprobe.d
+ newins ${FILESDIR}/blacklist-110 blacklist
+ doins ${FILESDIR}/pnp-aliases
+
+ # convert /lib/udev to real used dir
+ sed_helper_dir "${D}"/etc/modprobe.d/*
+
+ if use s390; then
+ # s390 does not has persistent mac addresses
+ # and we only have persistence rules for mac.
+ # For now just remove the rules file.
+ rm ${D}/etc/udev/rules.d/75-persistent-net-generator.rules
+ fi
+
+}
+
+pkg_preinst() {
+ if [[ -d ${ROOT}/lib/udev-state ]] ; then
+ mv -f "${ROOT}"/lib/udev-state/* "${D}"/lib/udev/state/
+ rm -r "${ROOT}"/lib/udev-state
+ fi
+
+ if [ -f "${ROOT}/etc/udev/udev.config" -a \
+ ! -f "${ROOT}/etc/udev/udev.rules" ]
+ then
+ mv -f ${ROOT}/etc/udev/udev.config ${ROOT}/etc/udev/udev.rules
+ fi
+
+ # delete the old udev.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/udev.hotplug" ]
+ then
+ rm -f ${ROOT}/etc/hotplug.d/default/udev.hotplug
+ fi
+
+ # delete the old wait_for_sysfs.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/05-wait_for_sysfs.hotplug" ]
+ then
+ rm -f ${ROOT}/etc/hotplug.d/default/05-wait_for_sysfs.hotplug
+ fi
+
+ # delete the old wait_for_sysfs.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/10-udev.hotplug" ]
+ then
+ rm -f ${ROOT}/etc/hotplug.d/default/10-udev.hotplug
+ fi
+
+ # is there a stale coldplug initscript? (CONFIG_PROTECT leaves it behind)
+ coldplug_stale=""
+ if [ -f "${ROOT}/etc/init.d/coldplug" ]
+ then
+ coldplug_stale="1"
+ fi
+}
+
+pkg_postinst() {
+ if [[ ${ROOT} == "/" ]] ; then
+ # check if root of init-process is identical to ours
+ if [ -r /proc/1/root -a /proc/1/root/ -ef /proc/self/root/ ]; then
+ einfo "restarting udevd now."
+ if [[ -n $(pidof udevd) ]] ; then
+ killall -15 udevd &>/dev/null
+ sleep 1
+ killall -9 udevd &>/dev/null
+ fi
+ /sbin/udevd --daemon
+ fi
+ fi
+
+ # people want reminders, I'll give them reminders. Odds are they will
+ # just ignore them anyway...
+
+ if [[ ${coldplug_stale} == "1" ]] ; then
+ ewarn "A stale coldplug init script found. You should run:"
+ ewarn
+ ewarn " rc-update del coldplug"
+ ewarn " rm -f /etc/init.d/coldplug"
+ ewarn
+ ewarn "udev now provides its own coldplug functionality."
+ fi
+
+ # delete 40-scsi-hotplug.rules - all integrated in 50-udev.rules
+ if has_version "=sys-fs/udev-103-r3"; then
+ if [[ -e "${ROOT}/etc/udev/rules.d/40-scsi-hotplug.rules" ]]
+ then
+ ewarn "Deleting stray 40-scsi-hotplug.rules"
+ ewarn "installed by sys-fs/udev-103-r3"
+ rm -f ${ROOT}/etc/udev/rules.d/40-scsi-hotplug.rules
+ fi
+ fi
+
+ # Removing some device-nodes we thought we need some time ago
+ if [[ -d "${ROOT}"/lib/udev/devices ]]; then
+ rm -f "${ROOT}"/lib/udev/devices/{null,zero,console,urandom}
+ fi
+
+ # Removing some old file
+ if has_version "<sys-fs/udev-104-r5"; then
+ rm -f "${ROOT}"/etc/dev.d/net/hotplug.dev
+ rmdir --ignore-fail-on-non-empty "${ROOT}"/etc/dev.d/net
+ fi
+
+ if has_version "<sys-fs/udev-106-r5"; then
+ if [[ -e ${ROOT}/etc/udev/rules.d/95-net.rules ]]; then
+ rm -f ${ROOT}/etc/udev/rules.d/95-net.rules
+ fi
+ fi
+
+ # Try to remove /etc/dev.d as that is obsolete
+ if [[ -d "${ROOT}"/etc/dev.d ]]; then
+ rmdir --ignore-fail-on-non-empty "${ROOT}"/etc/dev.d/default "${ROOT}"/etc/dev.d
+ if [[ -d "${ROOT}"/etc/dev.d ]]; then
+ ewarn "You still have the directory /etc/dev.d on your system."
+ ewarn "This is no longer used by udev and can be removed."
+ fi
+ fi
+
+ einfo
+ einfo "For more information on udev on Gentoo, writing udev rules, and"
+ einfo " fixing known issues visit:"
+ einfo " http://www.gentoo.org/doc/en/udev-guide.xml"
+}