summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2008-11-16 01:24:38 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2008-11-16 01:24:38 +0000
commit52db9d4a895766008f0125b9886f1cc7c47b9fd7 (patch)
tree4ecda77a6e89e9b2e9cc4c3a84ec31dc90fdfe61 /sys-fs
parentRemove clean target from BUILD_TARGETS for bug 233910, preventing a (diff)
downloadgentoo-2-52db9d4a895766008f0125b9886f1cc7c47b9fd7.tar.gz
gentoo-2-52db9d4a895766008f0125b9886f1cc7c47b9fd7.tar.bz2
gentoo-2-52db9d4a895766008f0125b9886f1cc7c47b9fd7.zip
Build against sources in /usr/src/linux instead of /lib/modules/uname -r
for bug 241952. Thanks to Diego Petteno <flameeyes at gentoo dot org>. (Portage version: 2.1.4.5)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/vhba/ChangeLog6
-rw-r--r--sys-fs/vhba/vhba-1.1.0.ebuild9
2 files changed, 13 insertions, 2 deletions
diff --git a/sys-fs/vhba/ChangeLog b/sys-fs/vhba/ChangeLog
index db426088074f..caa5cedd7ce9 100644
--- a/sys-fs/vhba/ChangeLog
+++ b/sys-fs/vhba/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/vhba
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/ChangeLog,v 1.8 2008/11/16 01:06:24 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/ChangeLog,v 1.9 2008/11/16 01:24:38 vanquirius Exp $
+
+ 16 Nov 2008; Marcelo Goes <vanquirius@gentoo.org> vhba-1.1.0.ebuild:
+ Build against sources in /usr/src/linux instead of /lib/modules/uname -r for
+ bug 241952. Thanks to Diego Petteno <flameeyes at gentoo dot org>.
16 Nov 2008; Marcelo Goes <vanquirius@gentoo.org> vhba-1.1.0.ebuild:
Remove clean target from BUILD_TARGETS for bug 233910, preventing a compile
diff --git a/sys-fs/vhba/vhba-1.1.0.ebuild b/sys-fs/vhba/vhba-1.1.0.ebuild
index 924ae03f0024..c5eeacddfb92 100644
--- a/sys-fs/vhba/vhba-1.1.0.ebuild
+++ b/sys-fs/vhba/vhba-1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/vhba-1.1.0.ebuild,v 1.2 2008/11/16 01:06:24 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/vhba-1.1.0.ebuild,v 1.3 2008/11/16 01:24:38 vanquirius Exp $
inherit linux-info linux-mod eutils
@@ -27,6 +27,13 @@ pkg_setup() {
linux-mod_pkg_setup
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s:/lib/modules/\$(KERNELRELEASE)/build:${KERNEL_DIR}:g" \
+ Makefile || die "sed failed"
+}
+
src_compile() {
linux-mod_src_compile || die "Error: building module failed!"
}