summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2010-05-25 16:09:36 +0000
committerThomas Sachau <tommy@gentoo.org>2010-05-25 16:09:36 +0000
commit7759f76da07d82638386f2867c012baf7ffbd9b4 (patch)
tree0e6de13e6ebba4563279287c1af239f57eed16ac /sys-fs
parentStable on amd64 wrt bug #320711 (diff)
downloadgentoo-2-7759f76da07d82638386f2867c012baf7ffbd9b4.tar.gz
gentoo-2-7759f76da07d82638386f2867c012baf7ffbd9b4.tar.bz2
gentoo-2-7759f76da07d82638386f2867c012baf7ffbd9b4.zip
Version bump, includes support for kernel 2.6.34
(Portage version: 2.2_rc67-r7/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/aufs2/ChangeLog12
-rw-r--r--sys-fs/aufs2/aufs2-0_p20100524.ebuild (renamed from sys-fs/aufs2/aufs2-0_p20100308.ebuild)13
-rw-r--r--sys-fs/aufs2/files/aufs2-base-27.patch81
-rw-r--r--sys-fs/aufs2/files/aufs2-base-31.patch4
-rw-r--r--sys-fs/aufs2/files/aufs2-base-34.patch81
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-27.patch169
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-28.patch34
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-29.patch30
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-30.patch10
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-34.patch272
10 files changed, 540 insertions, 166 deletions
diff --git a/sys-fs/aufs2/ChangeLog b/sys-fs/aufs2/ChangeLog
index ec0ad605b130..3b59756e524e 100644
--- a/sys-fs/aufs2/ChangeLog
+++ b/sys-fs/aufs2/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-fs/aufs2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/ChangeLog,v 1.20 2010/05/17 17:04:58 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/ChangeLog,v 1.21 2010/05/25 16:09:36 tommy Exp $
+
+*aufs2-0_p20100524 (25 May 2010)
+
+ 25 May 2010; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ -aufs2-0_p20100308.ebuild, +aufs2-0_p20100524.ebuild,
+ +files/aufs2-base-27.patch, files/aufs2-standalone-27.patch,
+ files/aufs2-standalone-28.patch, files/aufs2-standalone-29.patch,
+ files/aufs2-standalone-30.patch, files/aufs2-base-31.patch,
+ +files/aufs2-base-34.patch, +files/aufs2-standalone-34.patch:
+ Version bump, includes support for kernel 2.6.34
17 May 2010; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
aufs2-0_p20100405.ebuild:
diff --git a/sys-fs/aufs2/aufs2-0_p20100308.ebuild b/sys-fs/aufs2/aufs2-0_p20100524.ebuild
index 35d4bdd29849..c203dcf3951c 100644
--- a/sys-fs/aufs2/aufs2-0_p20100308.ebuild
+++ b/sys-fs/aufs2/aufs2-0_p20100524.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/aufs2-0_p20100308.ebuild,v 1.3 2010/05/13 01:45:28 ferringb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/aufs2-0_p20100524.ebuild,v 1.1 2010/05/25 16:09:36 tommy Exp $
EAPI="2"
@@ -23,11 +23,12 @@ S=${WORKDIR}/${PN}-standalone
MODULE_NAMES="aufs(misc:${S})"
pkg_setup() {
- # uesd to allow merging of binpkg aufs2 on systems lacking kernel sources
- [ -n "$PKG_SETUP_HAS_ALREADY_BEEN_RAN" ] && return
+ # this is needed so merging a binpkg aufs2 is possible w/out a kernel unpacked on the system
+ [ -n "$PKG_SETUP_HAS_BEEN_RAN" ] && return
+
get_version
kernel_is lt 2 6 27 && die "kernel too old"
- kernel_is gt 2 6 33 && die "kernel too new"
+ kernel_is gt 2 6 34 && die "kernel too new"
if ! ( patch -p1 --dry-run --force -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-standalone-${KV_PATCH}.patch >/dev/null && \
patch -p1 --dry-run --force -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-base-${KV_PATCH}.patch >/dev/null ); then
@@ -48,7 +49,7 @@ pkg_setup() {
fi
fi
linux-mod_pkg_setup
- export PKG_SETUP_HAS_ALREADY_BEEN_RAN=1
+ export PKG_SETUP_HAS_BEEN_RAN=1
}
src_prepare() {
@@ -58,7 +59,7 @@ src_prepare() {
sed -i "s:DEBUG = y:DEBUG =:g" config.mk || die
fi
if use inotify; then
- sed -i "s:HINOTIFY =:HINOTIFY = y:g" config.mk || die
+ sed -i "s:HNOTIFY =:HNOTIFY = y:g" config.mk || die
fi
if use ramfs; then
sed -i "s:RAMFS =:RAMFS = y:g" config.mk || die
diff --git a/sys-fs/aufs2/files/aufs2-base-27.patch b/sys-fs/aufs2/files/aufs2-base-27.patch
new file mode 100644
index 000000000000..b97a4cace208
--- /dev/null
+++ b/sys-fs/aufs2/files/aufs2-base-27.patch
@@ -0,0 +1,81 @@
+aufs2 base patch for linux-2.6.27
+
+diff --git a/fs/namei.c b/fs/namei.c
+index 4ea63ed..2759ad4 100644
+--- a/fs/namei.c
++++ b/fs/namei.c
+@@ -1241,7 +1241,7 @@ out:
+ * needs parent already locked. Doesn't follow mounts.
+ * SMP-safe.
+ */
+-static struct dentry *lookup_hash(struct nameidata *nd)
++struct dentry *lookup_hash(struct nameidata *nd)
+ {
+ int err;
+
+@@ -1251,7 +1251,7 @@ static struct dentry *lookup_hash(struct nameidata *nd)
+ return __lookup_hash(&nd->last, nd->path.dentry, nd);
+ }
+
+-static int __lookup_one_len(const char *name, struct qstr *this,
++int __lookup_one_len(const char *name, struct qstr *this,
+ struct dentry *base, int len)
+ {
+ unsigned long hash;
+diff --git a/fs/splice.c b/fs/splice.c
+index a1e701c..409245a 100644
+--- a/fs/splice.c
++++ b/fs/splice.c
+@@ -887,8 +887,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
+ /*
+ * Attempt to initiate a splice from pipe to file.
+ */
+-static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+- loff_t *ppos, size_t len, unsigned int flags)
++long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
++ loff_t *ppos, size_t len, unsigned int flags)
+ {
+ int ret;
+
+@@ -911,9 +911,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+ /*
+ * Attempt to initiate a splice from a file to a pipe.
+ */
+-static long do_splice_to(struct file *in, loff_t *ppos,
+- struct pipe_inode_info *pipe, size_t len,
+- unsigned int flags)
++long do_splice_to(struct file *in, loff_t *ppos,
++ struct pipe_inode_info *pipe, size_t len,
++ unsigned int flags)
+ {
+ int ret;
+
+diff --git a/include/linux/namei.h b/include/linux/namei.h
+index 68f8c32..5522432 100644
+--- a/include/linux/namei.h
++++ b/include/linux/namei.h
+@@ -71,6 +71,9 @@ extern struct file *lookup_instantiate_filp(struct nameidata *nd, struct dentry
+ extern struct file *nameidata_to_filp(struct nameidata *nd, int flags);
+ extern void release_open_intent(struct nameidata *);
+
++extern struct dentry *lookup_hash(struct nameidata *nd);
++extern int __lookup_one_len(const char *name, struct qstr *this,
++ struct dentry *base, int len);
+ extern struct dentry *lookup_one_len(const char *, struct dentry *, int);
+ extern struct dentry *lookup_one_noperm(const char *, struct dentry *);
+
+diff --git a/include/linux/splice.h b/include/linux/splice.h
+index 528dcb9..5123bc6 100644
+--- a/include/linux/splice.h
++++ b/include/linux/splice.h
+@@ -71,4 +71,10 @@ extern ssize_t splice_to_pipe(struct pipe_inode_info *,
+ extern ssize_t splice_direct_to_actor(struct file *, struct splice_desc *,
+ splice_direct_actor *);
+
++extern long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
++ loff_t *ppos, size_t len, unsigned int flags);
++extern long do_splice_to(struct file *in, loff_t *ppos,
++ struct pipe_inode_info *pipe, size_t len,
++ unsigned int flags);
++
+ #endif
diff --git a/sys-fs/aufs2/files/aufs2-base-31.patch b/sys-fs/aufs2/files/aufs2-base-31.patch
index f8a34eb0de82..7b26e3e44ac3 100644
--- a/sys-fs/aufs2/files/aufs2-base-31.patch
+++ b/sys-fs/aufs2/files/aufs2-base-31.patch
@@ -1,7 +1,7 @@
-aufs2 base patch for linux-2.6.
+aufs2 base patch for linux-2.6.31
diff --git a/fs/namei.c b/fs/namei.c
-index f3c5b27..dcedad1 100644
+index 1f13751..b49c2af 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -1219,7 +1219,7 @@ out:
diff --git a/sys-fs/aufs2/files/aufs2-base-34.patch b/sys-fs/aufs2/files/aufs2-base-34.patch
new file mode 100644
index 000000000000..57e37f64ed1d
--- /dev/null
+++ b/sys-fs/aufs2/files/aufs2-base-34.patch
@@ -0,0 +1,81 @@
+aufs2 base patch for linux-2.6.34
+
+diff --git a/fs/namei.c b/fs/namei.c
+index b86b96f..c43d6b8 100644
+--- a/fs/namei.c
++++ b/fs/namei.c
+@@ -1177,7 +1177,7 @@ out:
+ * needs parent already locked. Doesn't follow mounts.
+ * SMP-safe.
+ */
+-static struct dentry *lookup_hash(struct nameidata *nd)
++struct dentry *lookup_hash(struct nameidata *nd)
+ {
+ int err;
+
+@@ -1187,7 +1187,7 @@ static struct dentry *lookup_hash(struct nameidata *nd)
+ return __lookup_hash(&nd->last, nd->path.dentry, nd);
+ }
+
+-static int __lookup_one_len(const char *name, struct qstr *this,
++int __lookup_one_len(const char *name, struct qstr *this,
+ struct dentry *base, int len)
+ {
+ unsigned long hash;
+diff --git a/fs/splice.c b/fs/splice.c
+index 9313b61..b9e871f 100644
+--- a/fs/splice.c
++++ b/fs/splice.c
+@@ -1054,8 +1054,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
+ /*
+ * Attempt to initiate a splice from pipe to file.
+ */
+-static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+- loff_t *ppos, size_t len, unsigned int flags)
++long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
++ loff_t *ppos, size_t len, unsigned int flags)
+ {
+ ssize_t (*splice_write)(struct pipe_inode_info *, struct file *,
+ loff_t *, size_t, unsigned int);
+@@ -1082,9 +1082,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+ /*
+ * Attempt to initiate a splice from a file to a pipe.
+ */
+-static long do_splice_to(struct file *in, loff_t *ppos,
+- struct pipe_inode_info *pipe, size_t len,
+- unsigned int flags)
++long do_splice_to(struct file *in, loff_t *ppos,
++ struct pipe_inode_info *pipe, size_t len,
++ unsigned int flags)
+ {
+ ssize_t (*splice_read)(struct file *, loff_t *,
+ struct pipe_inode_info *, size_t, unsigned int);
+diff --git a/include/linux/namei.h b/include/linux/namei.h
+index 05b441d..91bc74e 100644
+--- a/include/linux/namei.h
++++ b/include/linux/namei.h
+@@ -73,6 +73,9 @@ extern int vfs_path_lookup(struct dentry *, struct vfsmount *,
+ extern struct file *lookup_instantiate_filp(struct nameidata *nd, struct dentry *dentry,
+ int (*open)(struct inode *, struct file *));
+
++extern struct dentry *lookup_hash(struct nameidata *nd);
++extern int __lookup_one_len(const char *name, struct qstr *this,
++ struct dentry *base, int len);
+ extern struct dentry *lookup_one_len(const char *, struct dentry *, int);
+
+ extern int follow_down(struct path *);
+diff --git a/include/linux/splice.h b/include/linux/splice.h
+index 18e7c7c..8393b5c 100644
+--- a/include/linux/splice.h
++++ b/include/linux/splice.h
+@@ -82,4 +82,10 @@ extern ssize_t splice_to_pipe(struct pipe_inode_info *,
+ extern ssize_t splice_direct_to_actor(struct file *, struct splice_desc *,
+ splice_direct_actor *);
+
++extern long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
++ loff_t *ppos, size_t len, unsigned int flags);
++extern long do_splice_to(struct file *in, loff_t *ppos,
++ struct pipe_inode_info *pipe, size_t len,
++ unsigned int flags);
++
+ #endif
diff --git a/sys-fs/aufs2/files/aufs2-standalone-27.patch b/sys-fs/aufs2/files/aufs2-standalone-27.patch
index 52a140be38b4..451cb71878e9 100644
--- a/sys-fs/aufs2/files/aufs2-standalone-27.patch
+++ b/sys-fs/aufs2/files/aufs2-standalone-27.patch
@@ -1,29 +1,7 @@
aufs2 standalone patch for linux-2.6.27
-diff --git a/fs/Kconfig b/fs/Kconfig
-index abccb5d..b987e5e 100644
---- a/fs/Kconfig
-+++ b/fs/Kconfig
-@@ -1539,6 +1539,8 @@ config UFS_DEBUG
- Y here. This will result in _many_ additional debugging messages to be
- written to the system log.
-
-+source "fs/aufs/Kconfig"
-+
- endmenu
-
- menuconfig NETWORK_FILESYSTEMS
-diff --git a/fs/Makefile b/fs/Makefile
-index a1482a5..aa51c5a 100644
---- a/fs/Makefile
-+++ b/fs/Makefile
-@@ -122,3 +122,4 @@ obj-$(CONFIG_HPPFS) += hppfs/
- obj-$(CONFIG_DEBUG_FS) += debugfs/
- obj-$(CONFIG_OCFS2_FS) += ocfs2/
- obj-$(CONFIG_GFS2_FS) += gfs2/
-+obj-$(CONFIG_AUFS_FS) += aufs/
diff --git a/fs/namei.c b/fs/namei.c
-index 4ea63ed..b207821 100644
+index 2759ad4..b207821 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -354,6 +354,7 @@ int deny_write_access(struct file * file)
@@ -34,27 +12,15 @@ index 4ea63ed..b207821 100644
/**
* path_get - get a reference to a path
-@@ -1241,7 +1242,7 @@ out:
- * needs parent already locked. Doesn't follow mounts.
- * SMP-safe.
- */
--static struct dentry *lookup_hash(struct nameidata *nd)
-+struct dentry *lookup_hash(struct nameidata *nd)
- {
- int err;
-
-@@ -1250,8 +1251,9 @@ static struct dentry *lookup_hash(struct nameidata *nd)
+@@ -1250,6 +1251,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
return ERR_PTR(err);
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
+EXPORT_SYMBOL(lookup_hash);
--static int __lookup_one_len(const char *name, struct qstr *this,
-+int __lookup_one_len(const char *name, struct qstr *this,
+ int __lookup_one_len(const char *name, struct qstr *this,
struct dentry *base, int len)
- {
- unsigned long hash;
-@@ -1272,6 +1274,7 @@ static int __lookup_one_len(const char *name, struct qstr *this,
+@@ -1272,6 +1274,7 @@ int __lookup_one_len(const char *name, struct qstr *this,
this->hash = end_name_hash(hash);
return 0;
}
@@ -63,16 +29,14 @@ index 4ea63ed..b207821 100644
/**
* lookup_one_len - filesystem helper to lookup single pathname component
diff --git a/fs/namespace.c b/fs/namespace.c
-index 6e283c9..98f56b9 100644
+index 6e283c9..36030e8 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
-@@ -37,6 +37,9 @@
+@@ -37,6 +37,7 @@
/* spinlock for vfsmount related operations, inplace of dcache_lock */
__cacheline_aligned_in_smp DEFINE_SPINLOCK(vfsmount_lock);
-+#ifdef CONFIG_AUFS_EXPORT
+EXPORT_SYMBOL(vfsmount_lock);
-+#endif
static int event;
static DEFINE_IDA(mnt_id_ida);
@@ -89,21 +53,10 @@ index 07da935..b8e9726 100644
static long do_sys_truncate(const char __user *pathname, loff_t length)
{
diff --git a/fs/splice.c b/fs/splice.c
-index a1e701c..48d7e72 100644
+index 409245a..48d7e72 100644
--- a/fs/splice.c
+++ b/fs/splice.c
-@@ -887,8 +887,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
- /*
- * Attempt to initiate a splice from pipe to file.
- */
--static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
-- loff_t *ppos, size_t len, unsigned int flags)
-+long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
-+ loff_t *ppos, size_t len, unsigned int flags)
- {
- int ret;
-
-@@ -907,13 +907,14 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+@@ -907,6 +907,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
return out->f_op->splice_write(pipe, out, ppos, len, flags);
}
@@ -111,17 +64,7 @@ index a1e701c..48d7e72 100644
/*
* Attempt to initiate a splice from a file to a pipe.
- */
--static long do_splice_to(struct file *in, loff_t *ppos,
-- struct pipe_inode_info *pipe, size_t len,
-- unsigned int flags)
-+long do_splice_to(struct file *in, loff_t *ppos,
-+ struct pipe_inode_info *pipe, size_t len,
-+ unsigned int flags)
- {
- int ret;
-
-@@ -929,6 +930,7 @@ static long do_splice_to(struct file *in, loff_t *ppos,
+@@ -929,6 +930,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
return in->f_op->splice_read(in, ppos, pipe, len, flags);
}
@@ -129,18 +72,6 @@ index a1e701c..48d7e72 100644
/**
* splice_direct_to_actor - splices data directly between two non-pipes
-diff --git a/fs/super.c b/fs/super.c
-index e931ae9..141853c 100644
---- a/fs/super.c
-+++ b/fs/super.c
-@@ -270,6 +270,7 @@ int fsync_super(struct super_block *sb)
- __fsync_super(sb);
- return sync_blockdev(sb->s_bdev);
- }
-+EXPORT_SYMBOL(fsync_super);
-
- /**
- * generic_shutdown_super - common helper for ->kill_sb()
diff --git a/fs/sync.c b/fs/sync.c
index 2967562..34040d6 100644
--- a/fs/sync.c
@@ -153,60 +84,18 @@ index 2967562..34040d6 100644
static long __do_fsync(unsigned int fd, int datasync)
{
-diff --git a/include/linux/Kbuild b/include/linux/Kbuild
-index b68ec09..22d182c 100644
---- a/include/linux/Kbuild
-+++ b/include/linux/Kbuild
-@@ -34,6 +34,7 @@ header-y += atmppp.h
- header-y += atmsap.h
- header-y += atmsvc.h
- header-y += atm_zatm.h
-+header-y += aufs_type.h
- header-y += auto_fs4.h
- header-y += ax25.h
- header-y += b1lli.h
-diff --git a/include/linux/lockdep.h b/include/linux/lockdep.h
-index 331e5f1..606bf6e 100644
---- a/include/linux/lockdep.h
-+++ b/include/linux/lockdep.h
-@@ -58,7 +58,7 @@ enum lock_usage_bit
- #define LOCKF_USED_IN_IRQ_READ \
- (LOCKF_USED_IN_HARDIRQ_READ | LOCKF_USED_IN_SOFTIRQ_READ)
-
--#define MAX_LOCKDEP_SUBCLASSES 8UL
-+#define MAX_LOCKDEP_SUBCLASSES 12UL
+diff --git a/kernel/mutex-debug.c b/kernel/mutex-debug.c
+index 1d94160..34fda4a 100644
+--- a/kernel/mutex-debug.c
++++ b/kernel/mutex-debug.c
+@@ -30,6 +30,7 @@ void debug_mutex_set_owner(struct mutex *lock, struct thread_info *new_owner)
+ {
+ lock->owner = new_owner;
+ }
++EXPORT_SYMBOL(debug_mutex_set_owner);
- /*
- * Lock-classes are keyed via unique addresses, by embedding the
-diff --git a/include/linux/namei.h b/include/linux/namei.h
-index 68f8c32..5522432 100644
---- a/include/linux/namei.h
-+++ b/include/linux/namei.h
-@@ -71,6 +71,9 @@ extern struct file *lookup_instantiate_filp(struct nameidata *nd, struct dentry
- extern struct file *nameidata_to_filp(struct nameidata *nd, int flags);
- extern void release_open_intent(struct nameidata *);
-
-+extern struct dentry *lookup_hash(struct nameidata *nd);
-+extern int __lookup_one_len(const char *name, struct qstr *this,
-+ struct dentry *base, int len);
- extern struct dentry *lookup_one_len(const char *, struct dentry *, int);
- extern struct dentry *lookup_one_noperm(const char *, struct dentry *);
-
-diff --git a/include/linux/splice.h b/include/linux/splice.h
-index 528dcb9..5123bc6 100644
---- a/include/linux/splice.h
-+++ b/include/linux/splice.h
-@@ -71,4 +71,10 @@ extern ssize_t splice_to_pipe(struct pipe_inode_info *,
- extern ssize_t splice_direct_to_actor(struct file *, struct splice_desc *,
- splice_direct_actor *);
-
-+extern long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
-+ loff_t *ppos, size_t len, unsigned int flags);
-+extern long do_splice_to(struct file *in, loff_t *ppos,
-+ struct pipe_inode_info *pipe, size_t len,
-+ unsigned int flags);
-+
- #endif
+ void debug_mutex_lock_common(struct mutex *lock, struct mutex_waiter *waiter)
+ {
diff --git a/security/device_cgroup.c b/security/device_cgroup.c
index 46f2397..00ec611 100644
--- a/security/device_cgroup.c
@@ -220,7 +109,7 @@ index 46f2397..00ec611 100644
int devcgroup_inode_mknod(int mode, dev_t dev)
{
diff --git a/security/security.c b/security/security.c
-index 3a4b4f5..4d7882e 100644
+index 3a4b4f5..cd573d3 100644
--- a/security/security.c
+++ b/security/security.c
@@ -425,6 +425,7 @@ int security_inode_readlink(struct dentry *dentry)
@@ -239,3 +128,19 @@ index 3a4b4f5..4d7882e 100644
int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
{
+@@ -539,6 +541,7 @@ int security_file_permission(struct file *file, int mask)
+ {
+ return security_ops->file_permission(file, mask);
+ }
++EXPORT_SYMBOL(security_file_permission);
+
+ int security_file_alloc(struct file *file)
+ {
+@@ -561,6 +564,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
+ {
+ return security_ops->file_mmap(file, reqprot, prot, flags, addr, addr_only);
+ }
++EXPORT_SYMBOL(security_file_mmap);
+
+ int security_file_mprotect(struct vm_area_struct *vma, unsigned long reqprot,
+ unsigned long prot)
diff --git a/sys-fs/aufs2/files/aufs2-standalone-28.patch b/sys-fs/aufs2/files/aufs2-standalone-28.patch
index 5ce4bc016778..0cd970e12bc8 100644
--- a/sys-fs/aufs2/files/aufs2-standalone-28.patch
+++ b/sys-fs/aufs2/files/aufs2-standalone-28.patch
@@ -72,18 +72,6 @@ index 678100b..7b7d65e 100644
/**
* splice_direct_to_actor - splices data directly between two non-pipes
-diff --git a/fs/super.c b/fs/super.c
-index 400a760..a1df361 100644
---- a/fs/super.c
-+++ b/fs/super.c
-@@ -270,6 +270,7 @@ int fsync_super(struct super_block *sb)
- __fsync_super(sb);
- return sync_blockdev(sb->s_bdev);
- }
-+EXPORT_SYMBOL(fsync_super);
-
- /**
- * generic_shutdown_super - common helper for ->kill_sb()
diff --git a/fs/sync.c b/fs/sync.c
index 2967562..34040d6 100644
--- a/fs/sync.c
@@ -96,6 +84,18 @@ index 2967562..34040d6 100644
static long __do_fsync(unsigned int fd, int datasync)
{
+diff --git a/kernel/mutex-debug.c b/kernel/mutex-debug.c
+index 1d94160..34fda4a 100644
+--- a/kernel/mutex-debug.c
++++ b/kernel/mutex-debug.c
+@@ -30,6 +30,7 @@ void debug_mutex_set_owner(struct mutex *lock, struct thread_info *new_owner)
+ {
+ lock->owner = new_owner;
+ }
++EXPORT_SYMBOL(debug_mutex_set_owner);
+
+ void debug_mutex_lock_common(struct mutex *lock, struct mutex_waiter *waiter)
+ {
diff --git a/security/device_cgroup.c b/security/device_cgroup.c
index 5ba7870..8f880c2 100644
--- a/security/device_cgroup.c
@@ -109,7 +109,7 @@ index 5ba7870..8f880c2 100644
int devcgroup_inode_mknod(int mode, dev_t dev)
{
diff --git a/security/security.c b/security/security.c
-index c0acfa7..812ebf4 100644
+index c0acfa7..8b1dadc 100644
--- a/security/security.c
+++ b/security/security.c
@@ -434,6 +434,7 @@ int security_inode_readlink(struct dentry *dentry)
@@ -136,3 +136,11 @@ index c0acfa7..812ebf4 100644
int security_file_alloc(struct file *file)
{
+@@ -570,6 +573,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
+ {
+ return security_ops->file_mmap(file, reqprot, prot, flags, addr, addr_only);
+ }
++EXPORT_SYMBOL(security_file_mmap);
+
+ int security_file_mprotect(struct vm_area_struct *vma, unsigned long reqprot,
+ unsigned long prot)
diff --git a/sys-fs/aufs2/files/aufs2-standalone-29.patch b/sys-fs/aufs2/files/aufs2-standalone-29.patch
index 4ea6675ac92e..ed7914daf7e4 100644
--- a/sys-fs/aufs2/files/aufs2-standalone-29.patch
+++ b/sys-fs/aufs2/files/aufs2-standalone-29.patch
@@ -72,18 +72,18 @@ index 2fb3d17..57cce07 100644
/**
* splice_direct_to_actor - splices data directly between two non-pipes
-diff --git a/fs/super.c b/fs/super.c
-index 6ce5014..af66b69 100644
---- a/fs/super.c
-+++ b/fs/super.c
-@@ -287,6 +287,7 @@ int fsync_super(struct super_block *sb)
- __fsync_super(sb);
- return sync_blockdev(sb->s_bdev);
+diff --git a/kernel/mutex-debug.c b/kernel/mutex-debug.c
+index 1d94160..34fda4a 100644
+--- a/kernel/mutex-debug.c
++++ b/kernel/mutex-debug.c
+@@ -30,6 +30,7 @@ void debug_mutex_set_owner(struct mutex *lock, struct thread_info *new_owner)
+ {
+ lock->owner = new_owner;
}
-+EXPORT_SYMBOL(fsync_super);
++EXPORT_SYMBOL(debug_mutex_set_owner);
- /**
- * generic_shutdown_super - common helper for ->kill_sb()
+ void debug_mutex_lock_common(struct mutex *lock, struct mutex_waiter *waiter)
+ {
diff --git a/security/device_cgroup.c b/security/device_cgroup.c
index 3aacd0f..b900dc3 100644
--- a/security/device_cgroup.c
@@ -97,7 +97,7 @@ index 3aacd0f..b900dc3 100644
int devcgroup_inode_mknod(int mode, dev_t dev)
{
diff --git a/security/security.c b/security/security.c
-index c3586c0..9841a3e 100644
+index c3586c0..4f3a666 100644
--- a/security/security.c
+++ b/security/security.c
@@ -389,6 +389,7 @@ int security_path_mkdir(struct path *path, struct dentry *dentry, int mode)
@@ -180,3 +180,11 @@ index c3586c0..9841a3e 100644
int security_file_alloc(struct file *file)
{
+@@ -642,6 +652,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
+ {
+ return security_ops->file_mmap(file, reqprot, prot, flags, addr, addr_only);
+ }
++EXPORT_SYMBOL(security_file_mmap);
+
+ int security_file_mprotect(struct vm_area_struct *vma, unsigned long reqprot,
+ unsigned long prot)
diff --git a/sys-fs/aufs2/files/aufs2-standalone-30.patch b/sys-fs/aufs2/files/aufs2-standalone-30.patch
index f14058dc455e..53c84625ccbd 100644
--- a/sys-fs/aufs2/files/aufs2-standalone-30.patch
+++ b/sys-fs/aufs2/files/aufs2-standalone-30.patch
@@ -85,7 +85,7 @@ index 5fda7df..440e476 100644
int devcgroup_inode_mknod(int mode, dev_t dev)
{
diff --git a/security/security.c b/security/security.c
-index 5284255..ed62ecd 100644
+index 5284255..e419efc 100644
--- a/security/security.c
+++ b/security/security.c
@@ -389,6 +389,7 @@ int security_path_mkdir(struct path *path, struct dentry *dentry, int mode)
@@ -168,3 +168,11 @@ index 5284255..ed62ecd 100644
int security_file_alloc(struct file *file)
{
+@@ -644,6 +654,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
+ {
+ return security_ops->file_mmap(file, reqprot, prot, flags, addr, addr_only);
+ }
++EXPORT_SYMBOL(security_file_mmap);
+
+ int security_file_mprotect(struct vm_area_struct *vma, unsigned long reqprot,
+ unsigned long prot)
diff --git a/sys-fs/aufs2/files/aufs2-standalone-34.patch b/sys-fs/aufs2/files/aufs2-standalone-34.patch
new file mode 100644
index 000000000000..c219578b5a21
--- /dev/null
+++ b/sys-fs/aufs2/files/aufs2-standalone-34.patch
@@ -0,0 +1,272 @@
+aufs2 standalone patch for linux-2.6.34
+
+diff --git a/fs/namei.c b/fs/namei.c
+index c43d6b8..538d40a 100644
+--- a/fs/namei.c
++++ b/fs/namei.c
+@@ -348,6 +348,7 @@ int deny_write_access(struct file * file)
+
+ return 0;
+ }
++EXPORT_SYMBOL(deny_write_access);
+
+ /**
+ * path_get - get a reference to a path
+@@ -1186,6 +1187,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
+ return ERR_PTR(err);
+ return __lookup_hash(&nd->last, nd->path.dentry, nd);
+ }
++EXPORT_SYMBOL(lookup_hash);
+
+ int __lookup_one_len(const char *name, struct qstr *this,
+ struct dentry *base, int len)
+@@ -1208,6 +1210,7 @@ int __lookup_one_len(const char *name, struct qstr *this,
+ this->hash = end_name_hash(hash);
+ return 0;
+ }
++EXPORT_SYMBOL(__lookup_one_len);
+
+ /**
+ * lookup_one_len - filesystem helper to lookup single pathname component
+diff --git a/fs/namespace.c b/fs/namespace.c
+index f20cb57..7cc1b42 100644
+--- a/fs/namespace.c
++++ b/fs/namespace.c
+@@ -1282,6 +1282,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
+ }
+ return 0;
+ }
++EXPORT_SYMBOL(iterate_mounts);
+
+ static void cleanup_group_ids(struct vfsmount *mnt, struct vfsmount *end)
+ {
+diff --git a/fs/notify/group.c b/fs/notify/group.c
+index 0e16771..3fab10a 100644
+--- a/fs/notify/group.c
++++ b/fs/notify/group.c
+@@ -22,6 +22,7 @@
+ #include <linux/srcu.h>
+ #include <linux/rculist.h>
+ #include <linux/wait.h>
++#include <linux/module.h>
+
+ #include <linux/fsnotify_backend.h>
+ #include "fsnotify.h"
+@@ -169,6 +170,7 @@ void fsnotify_put_group(struct fsnotify_group *group)
+ fsnotify_recalc_global_mask();
+ fsnotify_destroy_group(group);
+ }
++EXPORT_SYMBOL(fsnotify_put_group);
+
+ /*
+ * Simply run the fsnotify_groups list and find a group which matches
+@@ -252,3 +254,4 @@ struct fsnotify_group *fsnotify_obtain_group(unsigned int group_num, __u32 mask,
+
+ return group;
+ }
++EXPORT_SYMBOL(fsnotify_obtain_group);
+diff --git a/fs/notify/inode_mark.c b/fs/notify/inode_mark.c
+index 0399bcb..74cdc13 100644
+--- a/fs/notify/inode_mark.c
++++ b/fs/notify/inode_mark.c
+@@ -105,6 +105,7 @@ void fsnotify_put_mark(struct fsnotify_mark_entry *entry)
+ if (atomic_dec_and_test(&entry->refcnt))
+ entry->free_mark(entry);
+ }
++EXPORT_SYMBOL(fsnotify_put_mark);
+
+ /*
+ * Recalculate the mask of events relevant to a given inode locked.
+@@ -215,6 +216,7 @@ void fsnotify_destroy_mark_by_entry(struct fsnotify_mark_entry *entry)
+ if (unlikely(atomic_dec_and_test(&group->num_marks)))
+ fsnotify_final_destroy_group(group);
+ }
++EXPORT_SYMBOL(fsnotify_destroy_mark_by_entry);
+
+ /*
+ * Given a group, destroy all of the marks associated with that group.
+@@ -281,6 +283,7 @@ struct fsnotify_mark_entry *fsnotify_find_mark_entry(struct fsnotify_group *grou
+ }
+ return NULL;
+ }
++EXPORT_SYMBOL(fsnotify_find_mark_entry);
+
+ /*
+ * Nothing fancy, just initialize lists and locks and counters.
+@@ -297,6 +300,7 @@ void fsnotify_init_mark(struct fsnotify_mark_entry *entry,
+ entry->inode = NULL;
+ entry->free_mark = free_mark;
+ }
++EXPORT_SYMBOL(fsnotify_init_mark);
+
+ /*
+ * Attach an initialized mark entry to a given group and inode.
+@@ -352,6 +356,7 @@ int fsnotify_add_mark(struct fsnotify_mark_entry *entry,
+
+ return ret;
+ }
++EXPORT_SYMBOL(fsnotify_add_mark);
+
+ /**
+ * fsnotify_unmount_inodes - an sb is unmounting. handle any watched inodes.
+diff --git a/fs/open.c b/fs/open.c
+index 74e5cd9..8192b46 100644
+--- a/fs/open.c
++++ b/fs/open.c
+@@ -225,6 +225,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
+ mutex_unlock(&dentry->d_inode->i_mutex);
+ return ret;
+ }
++EXPORT_SYMBOL(do_truncate);
+
+ static long do_sys_truncate(const char __user *pathname, loff_t length)
+ {
+diff --git a/fs/splice.c b/fs/splice.c
+index b9e871f..b069be4 100644
+--- a/fs/splice.c
++++ b/fs/splice.c
+@@ -1078,6 +1078,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+
+ return splice_write(pipe, out, ppos, len, flags);
+ }
++EXPORT_SYMBOL(do_splice_from);
+
+ /*
+ * Attempt to initiate a splice from a file to a pipe.
+@@ -1104,6 +1105,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
+
+ return splice_read(in, ppos, pipe, len, flags);
+ }
++EXPORT_SYMBOL(do_splice_to);
+
+ /**
+ * splice_direct_to_actor - splices data directly between two non-pipes
+diff --git a/security/commoncap.c b/security/commoncap.c
+index 6166973..a702444 100644
+--- a/security/commoncap.c
++++ b/security/commoncap.c
+@@ -951,3 +951,4 @@ int cap_file_mmap(struct file *file, unsigned long reqprot,
+ }
+ return ret;
+ }
++EXPORT_SYMBOL(cap_file_mmap);
+diff --git a/security/device_cgroup.c b/security/device_cgroup.c
+index f77c604..743f39b 100644
+--- a/security/device_cgroup.c
++++ b/security/device_cgroup.c
+@@ -515,6 +515,7 @@ found:
+
+ return -EPERM;
+ }
++EXPORT_SYMBOL(devcgroup_inode_permission);
+
+ int devcgroup_inode_mknod(int mode, dev_t dev)
+ {
+diff --git a/security/security.c b/security/security.c
+index 687c6fd..e9e5f6b 100644
+--- a/security/security.c
++++ b/security/security.c
+@@ -411,6 +411,7 @@ int security_path_mkdir(struct path *dir, struct dentry *dentry, int mode)
+ return 0;
+ return security_ops->path_mkdir(dir, dentry, mode);
+ }
++EXPORT_SYMBOL(security_path_mkdir);
+
+ int security_path_rmdir(struct path *dir, struct dentry *dentry)
+ {
+@@ -418,6 +419,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry)
+ return 0;
+ return security_ops->path_rmdir(dir, dentry);
+ }
++EXPORT_SYMBOL(security_path_rmdir);
+
+ int security_path_unlink(struct path *dir, struct dentry *dentry)
+ {
+@@ -425,6 +427,7 @@ int security_path_unlink(struct path *dir, struct dentry *dentry)
+ return 0;
+ return security_ops->path_unlink(dir, dentry);
+ }
++EXPORT_SYMBOL(security_path_unlink);
+
+ int security_path_symlink(struct path *dir, struct dentry *dentry,
+ const char *old_name)
+@@ -433,6 +436,7 @@ int security_path_symlink(struct path *dir, struct dentry *dentry,
+ return 0;
+ return security_ops->path_symlink(dir, dentry, old_name);
+ }
++EXPORT_SYMBOL(security_path_symlink);
+
+ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
+ struct dentry *new_dentry)
+@@ -441,6 +445,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
+ return 0;
+ return security_ops->path_link(old_dentry, new_dir, new_dentry);
+ }
++EXPORT_SYMBOL(security_path_link);
+
+ int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
+ struct path *new_dir, struct dentry *new_dentry)
+@@ -451,6 +456,7 @@ int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
+ return security_ops->path_rename(old_dir, old_dentry, new_dir,
+ new_dentry);
+ }
++EXPORT_SYMBOL(security_path_rename);
+
+ int security_path_truncate(struct path *path, loff_t length,
+ unsigned int time_attrs)
+@@ -459,6 +465,7 @@ int security_path_truncate(struct path *path, loff_t length,
+ return 0;
+ return security_ops->path_truncate(path, length, time_attrs);
+ }
++EXPORT_SYMBOL(security_path_truncate);
+
+ int security_path_chmod(struct dentry *dentry, struct vfsmount *mnt,
+ mode_t mode)
+@@ -467,6 +474,7 @@ int security_path_chmod(struct dentry *dentry, struct vfsmount *mnt,
+ return 0;
+ return security_ops->path_chmod(dentry, mnt, mode);
+ }
++EXPORT_SYMBOL(security_path_chmod);
+
+ int security_path_chown(struct path *path, uid_t uid, gid_t gid)
+ {
+@@ -474,6 +482,7 @@ int security_path_chown(struct path *path, uid_t uid, gid_t gid)
+ return 0;
+ return security_ops->path_chown(path, uid, gid);
+ }
++EXPORT_SYMBOL(security_path_chown);
+
+ int security_path_chroot(struct path *path)
+ {
+@@ -550,6 +559,7 @@ int security_inode_readlink(struct dentry *dentry)
+ return 0;
+ return security_ops->inode_readlink(dentry);
+ }
++EXPORT_SYMBOL(security_inode_readlink);
+
+ int security_inode_follow_link(struct dentry *dentry, struct nameidata *nd)
+ {
+@@ -564,6 +574,7 @@ int security_inode_permission(struct inode *inode, int mask)
+ return 0;
+ return security_ops->inode_permission(inode, mask);
+ }
++EXPORT_SYMBOL(security_inode_permission);
+
+ int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
+ {
+@@ -664,6 +675,7 @@ int security_file_permission(struct file *file, int mask)
+ {
+ return security_ops->file_permission(file, mask);
+ }
++EXPORT_SYMBOL(security_file_permission);
+
+ int security_file_alloc(struct file *file)
+ {
+@@ -691,6 +703,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
+ return ret;
+ return ima_file_mmap(file, prot);
+ }
++EXPORT_SYMBOL(security_file_mmap);
+
+ int security_file_mprotect(struct vm_area_struct *vma, unsigned long reqprot,
+ unsigned long prot)