summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-03-18 21:49:57 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-03-18 21:49:57 +0000
commit912fb064fd5928e9f3539ce16bed26ddb2d7e347 (patch)
treeccfd135a5a777dd62633cb21af68efda97bdd11d /sys-fs
parentVersion bump (diff)
downloadgentoo-2-912fb064fd5928e9f3539ce16bed26ddb2d7e347.tar.gz
gentoo-2-912fb064fd5928e9f3539ce16bed26ddb2d7e347.tar.bz2
gentoo-2-912fb064fd5928e9f3539ce16bed26ddb2d7e347.zip
Version bump as 2.9.6 had a bad default that enabled lazy-counts and then the filesystem did not work on kernels older than 2.6.23.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/xfsprogs/ChangeLog8
-rw-r--r--sys-fs/xfsprogs/xfsprogs-2.9.7.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/sys-fs/xfsprogs/ChangeLog b/sys-fs/xfsprogs/ChangeLog
index 60fd8f928937..9ef09211d24d 100644
--- a/sys-fs/xfsprogs/ChangeLog
+++ b/sys-fs/xfsprogs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/xfsprogs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/ChangeLog,v 1.93 2008/03/07 02:28:46 rich0 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/ChangeLog,v 1.94 2008/03/18 21:49:57 robbat2 Exp $
+
+*xfsprogs-2.9.7 (18 Mar 2008)
+
+ 18 Mar 2008; Robin H. Johnson <robbat2@gentoo.org> +xfsprogs-2.9.7.ebuild:
+ Version bump as 2.9.6 had a bad default that enabled lazy-counts and then
+ the filesystem did not work on kernels older than 2.6.23.
07 Mar 2008; Richard Freeman <rich0@gentoo.org> xfsprogs-2.9.5.ebuild:
amd64 stabe - 211152
diff --git a/sys-fs/xfsprogs/xfsprogs-2.9.7.ebuild b/sys-fs/xfsprogs/xfsprogs-2.9.7.ebuild
new file mode 100644
index 000000000000..b676b3c6dfdb
--- /dev/null
+++ b/sys-fs/xfsprogs/xfsprogs-2.9.7.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-2.9.7.ebuild,v 1.1 2008/03/18 21:49:57 robbat2 Exp $
+
+inherit eutils toolchain-funcs autotools
+
+MY_P="${PN}_${PV}-1"
+DESCRIPTION="xfs filesystem utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="sys-fs/e2fsprogs"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.8.18-symlinks.patch #166729
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in \
+ || die "sed include/builddefs.in failed"
+ # We'll handle /lib versus /usr/lib install
+ sed -i -e '/INSTALL.* -S .*LIBNAME/d' \
+ include/buildmacros || die "sed symlinks"
+ eautoconf
+}
+
+src_compile() {
+ export DEBUG=-DNDEBUG
+ export OPTIMIZER=${CFLAGS}
+ unset PLATFORM # if set in user env, this breaks configure
+ econf \
+ --bindir=/usr/bin \
+ --sbindir=/sbin \
+ --libexecdir=/usr/$(get_libdir) \
+ $(use_enable nls gettext) \
+ || die "config failed"
+ emake || die
+}
+
+src_install() {
+ emake DIST_ROOT="${D}" install install-dev || die "make install failed"
+
+ # shared in /lib, static in /usr/lib, ldscript fun too
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/lib*.so* "${D}"/$(get_libdir)/
+ dosym libhandle.so.1 /$(get_libdir)/libhandle.so
+ gen_usr_ldscript libhandle.so
+
+ prepalldocs
+}