summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-08-05 21:01:09 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2015-08-05 21:01:09 +0000
commit97248875d3eaacc99c2824d0db915fdcf4008d4d (patch)
tree54110c5621d4137c93bb7de30f6e71f9c44cf2b5 /sys-fs
parentsys-cluster/ganglia: run python_setup when python is enabled per mgorny (diff)
downloadgentoo-2-97248875d3eaacc99c2824d0db915fdcf4008d4d.tar.gz
gentoo-2-97248875d3eaacc99c2824d0db915fdcf4008d4d.tar.bz2
gentoo-2-97248875d3eaacc99c2824d0db915fdcf4008d4d.zip
Fix crash due to use uinitialised device ID, bug #556690 and fix by LE GARREC Vincent.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/mtpfs/ChangeLog9
-rw-r--r--sys-fs/mtpfs/files/mtpfs-1.1-unitialized-variable.patch12
-rw-r--r--sys-fs/mtpfs/mtpfs-1.1-r2.ebuild55
3 files changed, 75 insertions, 1 deletions
diff --git a/sys-fs/mtpfs/ChangeLog b/sys-fs/mtpfs/ChangeLog
index a92387d568f7..0b6244eccbe7 100644
--- a/sys-fs/mtpfs/ChangeLog
+++ b/sys-fs/mtpfs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/mtpfs
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtpfs/ChangeLog,v 1.12 2015/05/30 22:33:27 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtpfs/ChangeLog,v 1.13 2015/08/05 21:01:09 slyfox Exp $
+
+*mtpfs-1.1-r2 (05 Aug 2015)
+
+ 05 Aug 2015; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/mtpfs-1.1-unitialized-variable.patch, +mtpfs-1.1-r2.ebuild:
+ Fix crash due to use uinitialised device ID, bug #556690 and fix by LE GARREC
+ Vincent.
*mtpfs-1.1-r1 (30 May 2015)
diff --git a/sys-fs/mtpfs/files/mtpfs-1.1-unitialized-variable.patch b/sys-fs/mtpfs/files/mtpfs-1.1-unitialized-variable.patch
new file mode 100644
index 000000000000..fb49624515b8
--- /dev/null
+++ b/sys-fs/mtpfs/files/mtpfs-1.1-unitialized-variable.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/556690
+--- mtpfs.c.old 2015-08-04 21:56:13.080712801 +0200
++++ mtpfs.c 2015-08-04 21:20:54.822965092 +0200
+@@ -1324,7 +1324,7 @@ main (int argc, char *argv[])
+ LIBMTP_raw_device_t * rawdevices;
+ int numrawdevices;
+ LIBMTP_error_number_t err;
+- int i;
++ int i = 0;
+
+ int opt;
+ extern int optind;
diff --git a/sys-fs/mtpfs/mtpfs-1.1-r2.ebuild b/sys-fs/mtpfs/mtpfs-1.1-r2.ebuild
new file mode 100644
index 000000000000..73cd780c73ff
--- /dev/null
+++ b/sys-fs/mtpfs/mtpfs-1.1-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtpfs/mtpfs-1.1-r2.ebuild,v 1.1 2015/08/05 21:01:09 slyfox Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A FUSE filesystem providing access to MTP devices"
+HOMEPAGE="http://www.adebenham.com/mtpfs/"
+SRC_URI="http://www.adebenham.com/files/mtp/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug mad"
+
+RDEPEND="dev-libs/glib:2
+ >=media-libs/libmtp-1.1.2
+ sys-fs/fuse
+ mad? (
+ media-libs/libid3tag
+ media-libs/libmad
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=(AUTHORS NEWS README)
+
+src_prepare() {
+ sed -e "/#include <string.h>/ a\
+ #include <stdlib.h>" -i mtpfs.h id3read.c || die #implicit
+
+ epatch "${FILESDIR}"/${P}-fix-mutex-crash.patch
+ epatch "${FILESDIR}"/${P}-unitialized-variable.patch
+}
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_enable mad)
+}
+
+pkg_postinst() {
+ einfo "To mount your MTP device, issue:"
+ einfo " /usr/bin/mtpfs <mountpoint>"
+ echo
+ einfo "To unmount your MTP device, issue:"
+ einfo " /usr/bin/fusermount -u <mountpoint>"
+
+ if use debug; then
+ echo
+ einfo "You have enabled debugging output."
+ einfo "Please make sure you run mtpfs with the -d flag."
+ fi
+}