summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorGreg Kroah-Hartman <gregkh@gentoo.org>2006-08-31 04:58:44 +0000
committerGreg Kroah-Hartman <gregkh@gentoo.org>2006-08-31 04:58:44 +0000
commita940fa319b7c324ac14d46e4f0836fd3dad23214 (patch)
treea42151600315247f364619985a2900f36f67ab32 /sys-fs
parentadd sanity check for stable users (diff)
downloadgentoo-2-a940fa319b7c324ac14d46e4f0836fd3dad23214.tar.gz
gentoo-2-a940fa319b7c324ac14d46e4f0836fd3dad23214.tar.bz2
gentoo-2-a940fa319b7c324ac14d46e4f0836fd3dad23214.zip
098 release
(Portage version: 2.1.1_pre5-r3)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/udev/ChangeLog10
-rw-r--r--sys-fs/udev/files/digest-udev-0983
-rw-r--r--sys-fs/udev/files/udev-098-udevtrigger.patch47
-rw-r--r--sys-fs/udev/files/udev-start-098.sh139
-rw-r--r--sys-fs/udev/files/udev.rules-098283
-rw-r--r--sys-fs/udev/udev-098.ebuild312
6 files changed, 793 insertions, 1 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index bd5d2de4f5be..2abcc530d961 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/udev
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.208 2006/07/19 17:13:39 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.209 2006/08/31 04:58:44 gregkh Exp $
+
+*udev-098 (31 Aug 2006)
+
+ 31 Aug 2006; Greg Kroah-Hartman <gregkh@gentoo.org> +files/udev.rules-098,
+ +files/udev-098-udevtrigger.patch, +files/udev-start-098.sh,
+ +udev-098.ebuild:
+ 098 release. Loads of bugs fixed in the ebuild and surrounding scripts. Rules
+ files also updated to work properly.
19 Jul 2006; Martin Schlemmer <azarah@gentoo.org> udev-096-r1.ebuild:
Remove redundent 10-udev.hotplug symlink. Noticed by Walt
diff --git a/sys-fs/udev/files/digest-udev-098 b/sys-fs/udev/files/digest-udev-098
new file mode 100644
index 000000000000..131c6feef893
--- /dev/null
+++ b/sys-fs/udev/files/digest-udev-098
@@ -0,0 +1,3 @@
+MD5 bd5e254d074d6eed8687acaff92e30e5 udev-098.tar.bz2 195723
+RMD160 29a05c64d49397d345d25f75c916525fede346aa udev-098.tar.bz2 195723
+SHA256 565f3cba2edf87668f503ada3869f4d7ebfa866340cdf2f3ae3d1c319090f0f5 udev-098.tar.bz2 195723
diff --git a/sys-fs/udev/files/udev-098-udevtrigger.patch b/sys-fs/udev/files/udev-098-udevtrigger.patch
new file mode 100644
index 000000000000..7aaa410ac703
--- /dev/null
+++ b/sys-fs/udev/files/udev-098-udevtrigger.patch
@@ -0,0 +1,47 @@
+diff --git a/udevtrigger.c b/udevtrigger.c
+index 09ef60a..9479caa 100644
+--- a/udevtrigger.c
++++ b/udevtrigger.c
+@@ -358,6 +358,9 @@ int main(int argc, char *argv[], char *e
+ {
+ int i;
+ int failed = 0;
++ int block = 1;
++ int bus = 1;
++ int class = 1;
+
+ logging_init("udevtrigger");
+ udev_config_init();
+@@ -373,8 +376,15 @@ int main(int argc, char *argv[], char *e
+ dry_run = 1;
+ } else if (strcmp(arg, "--retry-failed") == 0 || strcmp(arg, "-F") == 0) {
+ failed = 1;
++ } else if (strcmp(arg, "--no-scan-block") == 0) {
++ block = 0;
++ } else if (strcmp(arg, "--no-scan-bus") == 0) {
++ bus = 0;
++ } else if (strcmp(arg, "--no-scan-class") == 0) {
++ class = 0;
+ } else if (strcmp(arg, "--help") == 0 || strcmp(arg, "-h") == 0) {
+- printf("Usage: udevtrigger [--help] [--verbose] [--dry-run] [--retry-failed]\n");
++ printf("Usage: udevtrigger [--no-scan-block] [--no-scan-bus] [--no-scan-class]\n");
++ printf(" [--help] [--verbose] [--dry-run] [--retry-failed]\n");
+ goto exit;
+ } else {
+ fprintf(stderr, "unrecognized option '%s'\n", arg);
+@@ -386,9 +396,12 @@ int main(int argc, char *argv[], char *e
+ scan_failed();
+ else {
+ /* default action */
+- scan_bus();
+- scan_class();
+- scan_block();
++ if (bus)
++ scan_bus();
++ if (class)
++ scan_class();
++ if (block)
++ scan_block();
+ }
+ exec_lists();
+
diff --git a/sys-fs/udev/files/udev-start-098.sh b/sys-fs/udev/files/udev-start-098.sh
new file mode 100644
index 000000000000..49e34f86fe73
--- /dev/null
+++ b/sys-fs/udev/files/udev-start-098.sh
@@ -0,0 +1,139 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+udev_version() {
+ local version=0
+
+ if [[ -x /sbin/udev ]] ; then
+ version=$(/sbin/udev -V)
+ # We need it without a leading '0', else bash do the wrong thing
+ version=${version##0}
+ # Older udev's will print nothing
+ [[ -z ${version} ]] && version=0
+ fi
+
+ echo "${version}"
+}
+
+populate_udev() {
+ # populate /dev with devices already found by the kernel
+ if [ $(get_KV) -gt "$(KV_to_int '2.6.14')" ] ; then
+ ebegin "Populating /dev with existing devices through uevents"
+ local opts=
+ [[ ${RC_COLDPLUG} != "yes" && $(udev_version) -ge "96" ]] && \
+ opts="--no-scan-bus"
+ /sbin/udevtrigger ${opts}
+ eend $?
+ else
+ ebegin "Populating /dev with existing devices with udevstart"
+ /sbin/udevstart
+ eend $?
+ fi
+
+ # loop until everything is finished
+ # there's gotta be a better way...
+ ebegin "Letting udev process events"
+ /sbin/udevsettle --timeout=60
+ eend $?
+
+ return 0
+}
+
+seed_dev() {
+ # Seed /dev with some things that we know we need
+ ebegin "Seeding /dev with needed nodes"
+
+ # copy over any persistant things
+ if [[ -d /lib/udev/devices ]] ; then
+ cp --preserve=all --recursive --update /lib/udev/devices/* /dev
+ fi
+
+ # Not provided by sysfs but needed
+ ln -snf /proc/self/fd /dev/fd
+ ln -snf fd/0 /dev/stdin
+ ln -snf fd/1 /dev/stdout
+ ln -snf fd/2 /dev/stderr
+ [[ -e /proc/kcore ]] && ln -snf /proc/kcore /dev/core
+
+ # Create problematic directories
+ mkdir -p /dev/{pts,shm}
+ eend 0
+}
+
+main() {
+ # Setup temporary storage for /dev
+ ebegin "Mounting /dev for udev"
+ if [[ ${RC_USE_FSTAB} == "yes" ]] ; then
+ mntcmd=$(get_mount_fstab /dev)
+ else
+ unset mntcmd
+ fi
+ if [[ -n ${mntcmd} ]] ; then
+ try mount -n ${mntcmd}
+ else
+ # This is bash only, but saves on using grep
+ if [[ $(</proc/filesystems)$'\n' =~ '[[:space:]]tmpfs'$'\n' ]] ; then
+ mntcmd="tmpfs"
+ else
+ mntcmd="ramfs"
+ fi
+ # many video drivers require exec access in /dev #92921
+ try mount -n -t ${mntcmd} udev /dev -o exec,nosuid,mode=0755
+ fi
+ eend $?
+
+ # Create a file so that our rc system knows it's still in sysinit.
+ # Existance means init scripts will not directly run.
+ # rc will remove the file when done with sysinit.
+ touch /dev/.rcsysinit
+
+ # Selinux lovin; /selinux should be mounted by selinux-patched init
+ if [[ -x /sbin/restorecon && -c /selinux/null ]] ; then
+ restorecon /dev &> /selinux/null
+ fi
+
+ # Actually get udev rolling
+ if [[ ${RC_DEVICE_TARBALL} == "yes" && \
+ -s /lib/udev/state/devices.tar.bz2 ]] ; then
+ ebegin "Populating /dev with saved device nodes"
+ try tar -jxpf /lib/udev/state/devices.tar.bz2 -C /dev
+ eend $?
+ fi
+
+ seed_dev
+
+ # Setup hotplugging (if possible)
+ if [[ -e /proc/sys/kernel/hotplug ]] ; then
+ ebegin "Setting up proper hotplug agent"
+ eindent
+ if [[ $(get_KV) -gt $(KV_to_int '2.6.14') ]] ; then
+ einfo "Using netlink for hotplug events..."
+ echo "" > /proc/sys/kernel/hotplug
+ else
+ einfo "Setting /sbin/udevsend as hotplug agent ..."
+ echo "/sbin/udevsend" > /proc/sys/kernel/hotplug
+ fi
+ eoutdent
+ eend 0
+ fi
+
+ ebegin "Starting udevd"
+ /sbin/udevd --daemon
+ eend $?
+
+ populate_udev
+
+ # Create nodes that udev can't
+ ebegin "Finalizing udev configuration"
+ [[ -x /sbin/dmsetup ]] && /sbin/dmsetup mknodes &>/dev/null
+ [[ -x /sbin/lvm ]] && \
+ /sbin/lvm vgscan -P --mknodes --ignorelockingfailure &>/dev/null
+ # Running evms_activate on a LiveCD causes lots of headaches
+ [[ -z ${CDBOOT} ]] && [[ -x /sbin/evms_activate ]] && \
+ /sbin/evms_activate -q &>/dev/null
+ eend 0
+}
+
+main
+
+# vim:ts=4
diff --git a/sys-fs/udev/files/udev.rules-098 b/sys-fs/udev/files/udev.rules-098
new file mode 100644
index 000000000000..bc1c84d4e525
--- /dev/null
+++ b/sys-fs/udev/files/udev.rules-098
@@ -0,0 +1,283 @@
+# /etc/udev/rules/50-udev.rules: device naming rules for udev
+#
+# Gentoo specific rules
+#
+# There are a number of modifiers that are allowed to be used in some of the
+# fields. See the udev man page for a full description of them.
+#
+# Try not to modify this file, if you wish to change things, create a new rule
+# file that can be run before this one.
+#
+
+
+# console
+KERNEL=="pty[pqrstuvwxyzabcdef][0123456789abcdef]", NAME="%k", GROUP="tty", OPTIONS="last_rule"
+KERNEL=="tty[pqrstuvwxyzabcdef][0123456789abcdef]", NAME="%k", GROUP="tty", OPTIONS="last_rule"
+KERNEL=="vcs*", NAME="%k", GROUP="tty", OPTIONS="last_rule"
+KERNEL=="vcsa*", NAME="%k", GROUP="tty", OPTIONS="last_rule"
+KERNEL=="tty", NAME="%k", GROUP="tty", MODE="0666", OPTIONS="last_rule"
+KERNEL=="tty[0-9]", NAME="%k", GROUP="tty", OPTIONS="last_rule"
+KERNEL=="tty[0-9][0-9]", NAME="%k", GROUP="tty", OPTIONS="last_rule"
+KERNEL=="console", NAME="%k", GROUP="tty", MODE="0600"
+KERNEL=="ptmx", NAME="%k", GROUP="tty", MODE="0666"
+
+# tty devices
+KERNEL=="ttyS[0-9]*", NAME="%k", SYMLINK="tts/%n", GROUP="tty"
+KERNEL=="ttyUSB[0-9]*", NAME="%k", SYMLINK="tts/USB%n", GROUP="tty", MODE="0660"
+KERNEL=="ippp0", NAME="%k", GROUP="tty"
+KERNEL=="isdn*" NAME="%k", GROUP="tty"
+KERNEL=="dcbri*", NAME="%k", GROUP="tty"
+KERNEL=="ircomm*", NAME="%k", GROUP="tty"
+
+# all block devices
+SUBSYSTEM=="block", GROUP="disk"
+
+# cdrom symlinks and other good cdrom naming
+BUS=="ide", KERNEL=="hd[a-z]", ACTION=="add", IMPORT="cdrom_id --export $tempnode"
+BUS=="scsi", KERNEL=="sr[0-9]*", ACTION=="add", IMPORT="cdrom_id --export $tempnode"
+BUS=="scsi", KERNEL=="scd[a-z]", ACTION=="add", IMPORT="cdrom_id --export $tempnode"
+BUS=="scsi", KERNEL=="sg[0-9]*", ACTION=="add", DRIVERS=="sr", GROUP="cdrom"
+ENV{ID_CDROM}=="?*", PROGRAM="seq_node.sh %r %k cdrom", SYMLINK+="%c", GROUP="cdrom"
+ENV{ID_CDROM_CD_RW}=="?*", PROGRAM="seq_node.sh %r %k cdrw", SYMLINK+="%c"
+ENV{ID_CDROM_DVD}=="?*", PROGRAM="seq_node.sh %r %k dvd", SYMLINK+="%c"
+ENV{ID_CDROM_DVD_R}=="?*", PROGRAM="seq_node.sh %r %k dvdrw", SYMLINK+="%c"
+
+# disk devices
+KERNEL=="sd*", NAME="%k", GROUP="disk"
+KERNEL=="dasd*", NAME="%k", GROUP="disk"
+KERNEL=="ataraid*", NAME="%k", GROUP="disk"
+
+# compaq smart array
+KERNEL=="cciss*", NAME="%k"
+KERNEL=="ida*", NAME="%k"
+
+# mylex
+KERNEL=="rd*", NAME="%k"
+
+# dri devices
+KERNEL=="card*", NAME="dri/card%n", GROUP="video"
+KERNEL=="nvidia*", NAME="%k", GROUP="video"
+KERNEL=="3dfx*", NAME="%k", GROUP="video"
+
+# alsa devices
+SUBSYSTEM=="sound", GROUP="audio"
+KERNEL=="controlC[0-9]*", NAME="snd/%k"
+KERNEL=="hw[CD0-9]*", NAME="snd/%k"
+KERNEL=="pcm[CD0-9cp]*", NAME="snd/%k"
+KERNEL=="midiC[D0-9]*", NAME="snd/%k"
+KERNEL=="timer", NAME="snd/%k"
+KERNEL=="seq", NAME="snd/%k"
+
+# capi devices
+KERNEL=="capi", NAME="capi20", SYMLINK+="isdn/capi20", GROUP="dialout"
+KERNEL=="capi*", NAME="capi/%n", GROUP="dialout"
+
+# cpu devices
+KERNEL=="cpu[0-9]*", NAME="cpu/%n/cpuid"
+KERNEL=="msr[0-9]*", NAME="cpu/%n/msr"
+KERNEL=="microcode", NAME="cpu/microcode"
+
+# dm devices (ignore them)
+KERNEL=="dm-[0-9]*", OPTIONS="ignore_device"
+# create a symlink named after the device map name
+# note devmap_name comes with extras/multipath
+#KERNEL=="dm-[0-9]*", PROGRAM="/sbin/devmap_name %M %m", NAME="%k", SYMLINK+="%c"
+KERNEL=="device-mapper", NAME="mapper/control"
+
+# fb devices
+KERNEL=="fb[0-9]*", NAME="fb/%n", SYMLINK+="%k", GROUP="video"
+
+# floppy devices
+KERNEL=="fd[0-9]*", NAME="floppy/%n", SYMLINK+="%k", GROUP="floppy"
+
+# i2c devices
+KERNEL=="i2c-[0-9]*", NAME="i2c/%n", SYMLINK+="%k"
+
+# input devices
+KERNEL=="mice", NAME="input/%k", MODE="0644"
+KERNEL=="mouse*", NAME="input/%k", MODE="0644"
+KERNEL=="event*", NAME="input/%k", MODE="0600"
+KERNEL=="js*", NAME="input/%k", MODE="664"
+KERNEL=="ts*", NAME="input/%k", MODE="0600"
+
+# loop devices
+KERNEL=="loop[0-9]*", NAME="loop/%n", SYMLINK+="%k", GROUP="disk"
+
+# md block devices
+KERNEL=="md[0-9]*", NAME="md/%n", SYMLINK+="%k", GROUP="disk"
+
+# aoe char devices,
+SUBSYSTEM=="aoe", KERNEL=="discover", NAME="etherd/%k", GROUP="disk", MODE="0220"
+SUBSYSTEM=="aoe", KERNEL=="err", NAME="etherd/%k", GROUP="disk", MODE="0440"
+SUBSYSTEM=="aoe", KERNEL=="interfaces", NAME="etherd/%k", GROUP="disk", MODE="0220"
+
+# misc devices
+KERNEL=="agpgart", NAME="misc/%k", SYMLINK+="%k"
+KERNEL=="psaux", NAME="misc/%k", SYMLINK+="%k"
+KERNEL=="rtc", NAME="misc/%k", SYMLINK+="%k", MODE="0664"
+KERNEL=="uinput", NAME="misc/%k", SYMLINK+="%k"
+KERNEL=="inotify", NAME="misc/%k", SYMLINK+="%k", MODE="0666"
+
+# netlink devices
+KERNEL=="route", NAME="netlink/%k"
+KERNEL=="skip", NAME="netlink/%k"
+KERNEL=="usersock", NAME="netlink/%k"
+KERNEL=="fwmonitor", NAME="netlink/%k"
+KERNEL=="tcpdiag", NAME="netlink/%k"
+KERNEL=="nflog", NAME="netlink/%k"
+KERNEL=="xfrm", NAME="netlink/%k"
+KERNEL=="arpd", NAME="netlink/%k"
+KERNEL=="route6", NAME="netlink/%k"
+KERNEL=="ip6_fw", NAME="netlink/%k"
+KERNEL=="dnrtmsg", NAME="netlink/%k"
+KERNEL=="tap*", NAME="netlink/%k"
+
+# network devices
+KERNEL=="tun", NAME="net/%k", MODE="0600"
+
+# ramdisk devices
+KERNEL=="ram[0-9]*", NAME="rd/%n", SYMLINK+="%k"
+
+# IEEE1394 (firewire) devices (must be before raw devices below)
+KERNEL=="raw1394", NAME="%k", GROUP="video"
+KERNEL=="dv1394*", NAME="dv1394/%n", GROUP="video"
+KERNEL=="video1394*", NAME="video1394/%n", GROUP="video"
+
+# raw devices
+KERNEL=="raw[0-9]*", NAME="raw/%k", GROUP="disk"
+KERNEL=="ram*", NAME="%k", GROUP="disk"
+
+# sound devices
+KERNEL=="adsp", NAME="sound/%k", SYMLINK+="%k", GROUP="audio"
+KERNEL=="adsp[0-9]*", NAME="sound/%k", SYMLINK+="%k", GROUP="audio"
+KERNEL=="audio", NAME="sound/%k", SYMLINK+="%k", GROUP="audio"
+KERNEL=="audio[0-9]*", NAME="sound/%k", SYMLINK+="%k", GROUP="audio"
+KERNEL=="dsp", NAME="sound/%k", SYMLINK+="%k", GROUP="audio"
+KERNEL=="dsp[0-9]*", NAME="sound/%k", SYMLINK+="%k", GROUP="audio"
+KERNEL=="mixer", NAME="sound/%k", SYMLINK+="%k", GROUP="audio"
+KERNEL=="mixer[0-9]*", NAME="sound/%k", SYMLINK+="%k", GROUP="audio"
+KERNEL=="sequencer", NAME="sound/%k", SYMLINK+="%k", GROUP="audio"
+KERNEL=="sequencer[0-9]*", NAME="sound/%k", SYMLINK+="%k", GROUP="audio"
+
+# memory devices
+KERNEL=="random", NAME="%k", MODE="0666"
+KERNEL=="urandom", NAME="%k", MODE="0444"
+KERNEL=="mem", NAME="%k", MODE="0640"
+KERNEL=="kmem", NAME="%k", MODE="0640"
+KERNEL=="port", NAME="%k", MODE="0640"
+KERNEL=="full", NAME="%k", MODE="0666"
+KERNEL=="null", NAME="%k", MODE="0666"
+KERNEL=="zero", NAME="%k", MODE="0666"
+
+# usb devices
+KERNEL=="hiddev*", NAME="usb/%k"
+KERNEL=="auer*", NAME="usb/%k"
+KERNEL=="legousbtower*", NAME="usb/%k", GROUP="usb"
+KERNEL=="dabusb*", NAME="usb/%k"
+BUS=="usb", KERNEL=="lp[0-9]*", NAME="usb/%k", GROUP="lp"
+
+# v4l devices
+KERNEL=="video[0-9]*", NAME="v4l/video%n", SYMLINK+="video%n", GROUP="video"
+KERNEL=="radio[0-9]*", NAME="v4l/radio%n", SYMLINK+="radio%n", GROUP="video"
+KERNEL=="vbi[0-9]*", NAME="v4l/vbi%n", SYMLINK+="vbi%n", GROUP="video"
+KERNEL=="vtx[0-9]*", NAME="v4l/vtx%n", GROUP="video"
+
+# dvb devices
+SUBSYSTEM=="dvb", PROGRAM="/bin/sh -c 'K=%k; K=$${K#dvb}; printf dvb/adapter%%i/%%s $${K%%%%.*} $${K#*.}'", NAME="%c", GROUP="video"
+
+# Asterisk Zaptel devices
+KERNEL=="zapctl", NAME="zap/ctl"
+KERNEL=="zaptimer", NAME="zap/timer"
+KERNEL=="zapchannel", NAME="zap/channel"
+KERNEL=="zappseudo", NAME="zap/pseudo"
+KERNEL=="zap[0-9]*", NAME="zap/%n"
+
+# pilot/palm devices
+KERNEL=="pilot", NAME="%k", GROUP="uucp"
+
+# jaz devices
+KERNEL=="jaz*", NAME="%k", GROUP="disk"
+
+# zip devices
+KERNEL=="pocketzip*", NAME="%k", GROUP="disk"
+KERNEL=="zip*", NAME="%k", GROUP="disk"
+
+# ls120 devices
+KERNEL=="ls120", NAME="%k", GROUP="disk"
+
+# lp devices
+KERNEL=="lp*", NAME="%k", GROUP="lp"
+KERNEL=="irlpt", NAME="%k", GROUP="lp"
+KERNEL=="usblp", NAME="%k", GROUP="lp"
+KERNEL=="lp*", NAME="%k", GROUP="lp"
+KERNEL=="parport*", NAME="%k", GROUP="lp"
+
+# tape devices
+KERNEL=="ht*", NAME="%k", GROUP="tape"
+KERNEL=="nht*", NAME="%k", GROUP="tape"
+KERNEL=="pt*", NAME="%k", GROUP="tape"
+KERNEL=="npt*", NAME="%k", GROUP="tape"
+KERNEL=="st*", NAME="%k", GROUP="tape"
+KERNEL=="nst*", NAME="%k", GROUP="tape"
+KERNEL=="osst*", NAME="%k", GROUP="tape"
+KERNEL=="nosst*", NAME="%k", GROUP="tape"
+
+# diskonkey devices
+KERNEL=="diskonkey*", NAME="%k", GROUP="disk"
+
+# rem_ide devices
+KERNEL=="microdrive*", NAME="%k", GROUP="disk"
+
+# kbd devices
+KERNEL=="kbd", NAME="%k", MODE="0664"
+
+# Sony Vaio Jogdial sonypi device
+KERNEL=="sonypi", NAME="%k", MODE="0666"
+
+# packet devices
+KERNEL=="pktcdvd", NAME="pktcdvd/control", GROUP="cdrw", MODE="0660"
+KERNEL=="pktcdvd[0-9]*", NAME="pktcdvd/pktcdvd%n", GROUP="cdrw", MODE="0660"
+
+# infiniband devices
+KERNEL=="umad*", NAME="infiniband/%k"
+KERNEL=="issm*", NAME="infiniband/%k"
+
+
+# usbfs-like device nodes
+SUBSYSTEM=="usb_device", PROGRAM="/bin/sh -c 'K=%k; K=$${K#usbdev}; printf bus/usb/%%03i/%%03i $${K%%%%.*} $${K#*.}'", NAME="%c", MODE="0644"
+
+
+# Module autoloading
+
+# Autoload modules that lack aliases but have them defined inutoload modules
+SYSFS{modalias}=="?*", ACTION=="add", RUN+="/sbin/modprobe $env{MODALIAS}"
+
+# /etc/modprobe.conf.
+SUBSYSTEM=="pnp", ENV{MODALIAS}!="?*", RUN+="/bin/sh -c 'while read id; do /sbin/modprobe pnp:d$$id; done < /sys$devpath/id'"
+# If you have problems with some pnp modules being loaded, please enter the
+# following aliases into the modprobe configuration files. These are needed by
+# udev to autoload some modules
+# alias pnp:dPNP0510 irtty-sir
+# alias pnp:dPNP0511 irtty-sir
+# alias pnp:dPNP0700 floppy
+# alias pnp:dPNP0800 pcspkr
+# alias pnp:dPNP0b00 rtc
+# alias pnp:dPNP0303 atkbd
+# alias pnp:dPNP0f13 psmouse
+# alias pnp:dPNPb02f analog
+
+
+
+# Load firmware
+SUBSYSTEM=="firmware", ACTION=="add", RUN+="firmware.sh"
+
+
+# be backward compatible for a while with the /etc/dev.d and /etc/hotplug.d/ systems
+# run /etc/hotplug.d/ stuff only if we came from a hotplug event, not for udevstart
+ENV{UDEVD_EVENT}=="1", RUN+="udev_run_hotplugd $env{SUBSYSTEM}"
+
+# always run /etc/dev.d/ stuff for now.
+RUN+="udev_run_devd $env{SUBSYSTEM}"
+
+# debugging monitor
+RUN+="socket:/org/kernel/udev/monitor"
diff --git a/sys-fs/udev/udev-098.ebuild b/sys-fs/udev/udev-098.ebuild
new file mode 100644
index 000000000000..9a03075757d1
--- /dev/null
+++ b/sys-fs/udev/udev-098.ebuild
@@ -0,0 +1,312 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-098.ebuild,v 1.1 2006/08/31 04:58:44 gregkh Exp $
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="Linux dynamic and persistent device naming support (aka userspace devfs)"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html"
+SRC_URI="mirror://kernel/linux/utils/kernel/hotplug/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux"
+
+# still rely on hotplug (need to fix that), but now we implement coldplug
+
+DEPEND="sys-apps/hotplug-base"
+RDEPEND="!sys-apps/coldplug"
+RDEPEND="${DEPEND} ${RDEPEND}
+ >=sys-apps/baselayout-1.11.14"
+# We need the lib/rcscripts/addon support
+PROVIDE="virtual/dev-manager"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # patches go here...
+ #epatch ${FILESDIR}/${P}-udev_volume_id.patch
+ # Add --no-scan-{block,bus,class} options to udevtrigger, bug #119989
+ epatch ${FILESDIR}/${P}-udevtrigger.patch
+
+ # No need to clutter the logs ...
+ sed -ie '/^DEBUG/ c\DEBUG = false' Makefile
+ # Do not use optimization flags from the package
+ sed -ie 's|$(OPTIMIZATION)||g' Makefile
+
+ # Make sure there is no sudden changes to udev.rules.gentoo
+ # (more for my own needs than anything else ...)
+ MD5=`md5sum < "${S}/etc/udev/gentoo/udev.rules"`
+ MD5=${MD5/ -/}
+ if [ "${MD5}" != "590d3e6346938e3b608237973f4f1805" ]
+ then
+ echo
+ eerror "gentoo/udev.rules has been updated, please validate!"
+ die "gentoo/udev.rules has been updated, please validate!"
+ fi
+}
+
+src_compile() {
+ filter-flags -fprefetch-loop-arrays
+ local myconf=
+ local extras="extras/ata_id \
+ extras/cdrom_id \
+ extras/dasd_id \
+ extras/edd_id \
+ extras/firmware \
+ extras/floppy \
+ extras/path_id \
+ extras/run_directory \
+ extras/scsi_id \
+ extras/usb_id \
+ extras/volume_id"
+
+ use selinux && myconf="${myconf} USE_SELINUX=true"
+
+ # Not everyone has full $CHOST-{ld,ar,etc...} yet
+ local mycross=""
+ type -p ${CHOST}-ar && mycross=${CHOST}-
+
+ echo "get_libdir = $(get_libdir)"
+ # Do not work with emake
+ make \
+ EXTRAS="${extras}" \
+ udevdir="/dev/" \
+ CROSS_COMPILE=${mycross} \
+ ${myconf} || die
+}
+
+src_install() {
+ # we install everything by "hand" and don't rely on the udev Makefile to do
+ # it for us (why? it's easier that way...)
+ dobin udevinfo || die "Required binary not installed properly"
+ dobin udevtest || die "Required binary not installed properly"
+ dobin udevmonitor || die "Required binary not installed properly"
+ into /
+ dosbin udev || die "Required binary not installed properly"
+ dosbin udevd || die "Required binary not installed properly"
+ #dosbin udevsend || die "Required binary not installed properly"
+ dosbin udevstart || die "Required binary not installed properly"
+ dosbin udevtrigger || die "Required binary not installed properly"
+ dosbin udevcontrol || die "Required binary not installed properly"
+ dosbin udevsettle || die "Required binary not installed properly"
+ # Helpers
+ exeinto /$(get_libdir)/udev
+ doexe extras/run_directory/udev_run_devd || die "Required helper not installed properly"
+ doexe extras/run_directory/udev_run_hotplugd || die "Required helper not installed properly"
+ doexe extras/ata_id/ata_id || die "Required helper not installed properly"
+ doexe extras/volume_id/vol_id || die "Required helper not installed properly"
+ doexe extras/scsi_id/scsi_id || die "Required helper not installed properly"
+ doexe extras/usb_id/usb_id || die "Required helper not installed properly"
+ doexe extras/path_id/path_id || die "Required helper not installed properly"
+ doexe extras/cdrom_id/cdrom_id || die "Required helper not installed properly"
+ doexe extras/dasd_id/dasd_id || die "Required helper not installed properly"
+ doexe extras/edd_id/edd_id || die "Required helper not installed properly"
+ keepdir /$(get_libdir)/udev/state
+
+ # vol_id library (needed by mount and HAL)
+ dolib extras/volume_id/lib/*.a extras/volume_id/lib/*.so*
+ # move the .a files to /usr/lib
+ dodir /usr/$(get_libdir)
+ mv -f "${D}"/$(get_libdir)/*.a "${D}"/usr/$(get_libdir)/
+
+ # handle static linking bug #4411
+ gen_usr_ldscript libvolume_id.so
+
+ # save pkgconfig info
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins extras/volume_id/lib/*.pc
+
+ #exeinto /etc/udev/scripts
+ exeinto /lib/udev
+ #doexe extras/ide-devfs.sh
+ #doexe extras/scsi-devfs.sh
+ #doexe extras/raid-devfs.sh
+ doexe extras/floppy/create_floppy_devices || die "Required binary not installed properly"
+ doexe extras/firmware/firmware.sh || die "Required binary not installed properly"
+ doexe ${FILESDIR}/seq_node.sh || die "Required binary not installed properly"
+
+ # Our udev config file
+ insinto /etc/udev
+ newins ${FILESDIR}/udev.conf.post_081 udev.conf
+
+ # Our rules files
+ insinto /etc/udev/rules.d/
+ newins etc/udev/gentoo/udev.rules 50-udev.rules
+ newins ${FILESDIR}/udev.rules-098 50-udev.rules
+ newins ${FILESDIR}/05-udev-early.rules-079 05-udev-early.rules
+ # Use upstream's persistent rules for devices
+ doins etc/udev/rules.d/60-*.rules
+
+ # scsi_id configuration
+ insinto /etc
+ doins extras/scsi_id/scsi_id.config
+
+ # set up the /etc/dev.d directory tree
+ dodir /etc/dev.d/default
+ dodir /etc/dev.d/net
+ exeinto /etc/dev.d/net
+ doexe extras/run_directory/dev.d/net/hotplug.dev
+
+ # all of the man pages
+ doman *.7
+ doman *.8
+ doman extras/ata_id/ata_id.8
+ doman extras/edd_id/edd_id.8
+ doman extras/scsi_id/scsi_id.8
+ doman extras/volume_id/vol_id.8
+ doman extras/dasd_id/dasd_id.8
+ doman extras/cdrom_id/cdrom_id.8
+
+ # our udev hooks into the rc system
+ insinto /lib/rcscripts/addons
+ newins "${FILESDIR}"/udev-start-098.sh udev-start.sh
+ doins "${FILESDIR}"/udev-stop.sh
+
+ # needed to compile latest Hal
+ insinto /usr/include
+ doins extras/volume_id/lib/libvolume_id.h
+
+ dodoc ChangeLog FAQ README TODO RELEASE-NOTES
+ dodoc docs/{overview,udev_vs_devfs}
+ dodoc docs/writing_udev_rules/*
+
+ newdoc extras/volume_id/README README_volume_id
+
+}
+
+pkg_preinst() {
+ if [[ -d ${ROOT}/$(get_libdir)/udev-state ]] ; then
+ mv -f "${ROOT}"/$(get_libdir)/udev-state/* "${D}"/$(get_libdir)/udev/state/
+ rm -r "${ROOT}"/$(get_libdir)/udev-state
+ fi
+
+ if [ -f "${ROOT}/etc/udev/udev.config" -a \
+ ! -f "${ROOT}/etc/udev/udev.rules" ]
+ then
+ mv -f ${ROOT}/etc/udev/udev.config ${ROOT}/etc/udev/udev.rules
+ fi
+
+ # delete the old udev.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/udev.hotplug" ]
+ then
+ rm -f ${ROOT}/etc/hotplug.d/default/udev.hotplug
+ fi
+
+ # delete the old wait_for_sysfs.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/05-wait_for_sysfs.hotplug" ]
+ then
+ rm -f ${ROOT}/etc/hotplug.d/default/05-wait_for_sysfs.hotplug
+ fi
+
+ # delete the old wait_for_sysfs.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/10-udev.hotplug" ]
+ then
+ rm -f ${ROOT}/etc/hotplug.d/default/10-udev.hotplug
+ fi
+
+ # is there a stale coldplug initscript? (CONFIG_PROTECT leaves it behind)
+ coldplug_stale=""
+ if [ -f "${ROOT}/etc/init.d/coldplug" ]
+ then
+ coldplug_stale="1"
+ fi
+
+ # Create some nodes that we know we need.
+ # set the time/date so we can see in /dev which ones we copied over
+ # in the udev-start.sh script
+ mkdir -p ${ROOT}/lib/udev/devices
+
+ if [ ! -e ${ROOT}/lib/udev/devices/null ] ; then
+ mknod ${ROOT}/lib/udev/devices/null c 1 3
+ fi
+ chmod 666 ${ROOT}/lib/udev/devices/null
+ touch -t 200010220101 ${ROOT}/lib/udev/devices/null
+
+ if [ ! -e ${ROOT}/lib/udev/devices/zero ] ; then
+ mknod ${ROOT}/lib/udev/devices/zero c 1 5
+ fi
+ chmod 666 ${ROOT}/lib/udev/devices/zero
+ touch -t 200010220101 ${ROOT}/lib/udev/devices/zero
+
+ if [ ! -e ${ROOT}/lib/udev/devices/console ] ; then
+ mknod ${ROOT}/lib/udev/devices/console c 5 1
+ fi
+ chmod 600 ${ROOT}/lib/udev/devices/console
+ chown root:tty ${ROOT}/lib/udev/devices/console
+ touch -t 200010220101 ${ROOT}/lib/udev/devices/console
+
+ if [ ! -e ${ROOT}/lib/udev/devices/urandom ] ; then
+ mknod ${ROOT}/lib/udev/devices/urandom c 1 9
+ fi
+ chmod 666 ${ROOT}/lib/udev/devices/urandom
+ touch -t 200010220101 ${ROOT}/lib/udev/devices/urandom
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" -a -n "`pidof udevd`" ]
+ then
+ killall -15 udevd &>/dev/null
+ sleep 1
+ killall -9 udevd &>/dev/null
+ fi
+ /sbin/udevd --daemon
+
+ # people want reminders, I'll give them reminders. Odds are they will
+ # just ignore them anyway...
+ if has_version '<sys-fs/udev-046' ; then
+ ewarn "Note: If you rely on the output of udevinfo for anything, please"
+ ewarn " either run 'udevstart' now, or reboot, in order to get a"
+ ewarn " up-to-date udev database."
+ ewarn
+ fi
+ if has_version '<sys-fs/udev-050' ; then
+ ewarn "Note: If you had written some custom permissions rules, please"
+ ewarn " realize that the permission rules are now part of the main"
+ ewarn " udev rules files and are not stand-alone anymore. This means"
+ ewarn " you need to rewrite them."
+ ewarn
+ fi
+ if has_version '<sys-fs/udev-059' ; then
+ ewarn "Note: If you are upgrading from a version of udev prior to 059"
+ ewarn " and you have written custom rules, and rely on the etc/dev.d/"
+ ewarn " functionality, or the etc/hotplug.d functionality, or just"
+ ewarn " want to write some very cool and power udev rules, please "
+ ewarn " read the RELEASE-NOTES file for details on what has changed"
+ ewarn " with this feature, and how to change your rules to work properly."
+ ewarn
+ elif has_version '<sys-fs/udev-057' ; then
+ ewarn "Note: If you have written custom rules, and rely on the etc/dev.d/"
+ ewarn " functionality, please read the RELEASE-NOTES file for details"
+ ewarn " on what has changed with this feature, and how to change your"
+ ewarn " rules to work properly."
+ ewarn
+ fi
+ if has_version '<sys-fs/udev-063' ; then
+ ewarn "Note: If you use the devfs-style names for your block devices"
+ ewarn " or use devfs-style names in /etc/inittab or /etc/securetty or"
+ ewarn " your GRUB or LILO kernel boot command line, you need to"
+ ewarn " change them back to LSB compliant names, as the devfs names are"
+ ewarn " now gone. If you wish to use some persistent names for your"
+ ewarn " block devices, look at the symlinks in /dev/disk/ for the names"
+ ewarn " you can use."
+ ewarn
+ fi
+
+ if [[ ${coldplug_stale} == "1" ]] ; then
+ ewarn "A stale coldplug init script found. You should run:"
+ ewarn
+ ewarn " rc-update del coldplug"
+ ewarn " rm -f /etc/init.d/coldplug"
+ ewarn
+ ewarn "udev now provides its own coldplug functionality."
+ fi
+
+ einfo
+ einfo "For more information on udev on Gentoo, writing udev rules, and"
+ einfo " fixing known issues visit:"
+ einfo " http://www.gentoo.org/doc/en/udev-guide.xml"
+}