summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2010-03-09 17:35:47 +0000
committerPatrick McLean <chutzpah@gentoo.org>2010-03-09 17:35:47 +0000
commitb5c6b04b89d7f12569ccd57444a787689233466b (patch)
tree8f1a16ebb1b330fcfcee19b40e9f232e69083720 /sys-fs
parentFix building with libpng14 wrt #308667 by Locke Shinseiko (Wizzleby). (diff)
downloadgentoo-2-b5c6b04b89d7f12569ccd57444a787689233466b.tar.gz
gentoo-2-b5c6b04b89d7f12569ccd57444a787689233466b.tar.bz2
gentoo-2-b5c6b04b89d7f12569ccd57444a787689233466b.zip
Version bump (bug #308493).
(Portage version: 2.1.8.2/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ntfs3g/ChangeLog7
-rw-r--r--sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index 838cfc1cf3f2..223ae72168c6 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.90 2010/02/10 03:48:10 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.91 2010/03/09 17:35:47 chutzpah Exp $
+
+*ntfs3g-2010.3.6 (09 Mar 2010)
+
+ 09 Mar 2010; Patrick McLean <chutzpah@gentoo.org> +ntfs3g-2010.3.6.ebuild:
+ Version bump (bug #308493).
10 Feb 2010; Joseph Jezak <josejx@gentoo.org> ntfs3g-2009.11.14.ebuild:
Marked ppc/ppc64 stable for bug #300126.
diff --git a/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild b/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild
new file mode 100644
index 000000000000..2cd6a7b3adff
--- /dev/null
+++ b/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2010.3.6.ebuild,v 1.1 2010/03/09 17:35:47 chutzpah Exp $
+
+EAPI=2
+
+MY_PN="${PN/3g/-3g}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.tuxera.com/community/ntfs-3g-download/"
+SRC_URI="http://tuxera.com/opensource/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="acl debug hal suid +external-fuse"
+
+RDEPEND=">=sys-fs/fuse-2.6.0
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ sys-apps/attr"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --enable-ldscript \
+ --disable-ldconfig \
+ --with-fuse=$(use external-fuse && echo external || echo internal) \
+ $(use_enable acl posix-acls) \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ prepalldocs || die "prepalldocs failed"
+ dodoc AUTHORS ChangeLog CREDITS
+
+ use suid && fperms u+s "/bin/${MY_PN}"
+
+ if use hal; then
+ insinto /etc/hal/fdi/policy/
+ newins "${FILESDIR}/10-ntfs3g.fdi.2009-r1" "10-ntfs3g.fdi"
+ fi
+}
+
+pkg_postinst() {
+ if use suid; then
+ ewarn
+ ewarn "You have chosen to install ${PN} with the binary setuid root. This"
+ ewarn "means that if there any undetected vulnerabilities in the binary,"
+ ewarn "then local users may be able to gain root access on your machine."
+ ewarn
+ fi
+}